plasmashell high CPU usage (100%+)

Bug #1597792 reported by Larry Garfield
144
This bug affects 29 people
Affects Status Importance Assigned to Milestone
plasma-workspace (Ubuntu)
Critical
Unassigned

Bug Description

After upgrading to Kubuntu 16.04, my plasmashell is acting up badly. After startup it sometimes (but not always) freezes for long periods before becoming responsive again. Today, I found just plasmashell reporting over 100% CPU usage for several minutes, although it was responsive (albeit slowly) during that time. It seemed to drop back down to almost nothing entirely on its own, despite no change in what I was doing.

At the recommendation of someone in the #KDE IRC channel, I grabbed the attached backtrace using gdb.

The person I spoke to indicated that it seemed to be waiting on a lock indefinitely.

This seems similar to, but not quite the same as, https://bugs.launchpad.net/ubuntu/+source/plasma-workspace/+bug/1436552

Revision history for this message
Larry Garfield (larry-garfieldtech) wrote :
tags: added: trusty
tags: added: xenial
removed: trusty
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-workspace (Ubuntu):
status: New → Confirmed
Revision history for this message
Guy Stalnaker (gstalnaker) wrote :

I have not used gdb to get a trace but the plasmashell behavior described here matches what I see on my MacBookPro 5,5 with 16.04.01 freshly,newly installed today from dvd made with iso downloaded this morning. Here's what top shows:

<quote>
top - 21:24:29 up 44 min, 2 users, load average: 6.72, 6.83, 6.65
Tasks: 206 total, 2 running, 203 sleeping, 0 stopped, 0 zombie
%Cpu(s): 83.7 us, 16.3 sy, 0.0 ni, 0.0 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
GiB Mem : 3.589 total, 0.563 free, 2.296 used, 0.730 buff/cache
GiB Swap: 3.725 total, 3.668 free, 0.056 used. 1.005 avail Mem

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 2769 jstalnak 20 0 3683820 223080 104680 t 97.7 5.9 27:41.12 plasmashell
</quote>

It can take 45-60 seconds to open an app. Load avg has climbed near 8 but usually hovers around 6.5-7.0. This is with konsole, chromium, and System Settings open, 44 minutes after a reboot.

Changed in plasma-workspace (Ubuntu):
importance: Undecided → Critical
Revision history for this message
Martin Jorgensen (newsboost) wrote :

I confirm having the same issue, so I hereby also subscribe to changes to this bug report...

Revision history for this message
jds (jay-schieber) wrote :

I have the same problem after upgrading from 14.04.

Revision history for this message
jds (jay-schieber) wrote :

Adding to my comment. My upgrade has been a mini-disaster. First, the upgrade from 14.04 repeatedly failed. So, I just did a fresh install. This was not too bad, because I had previously formatted my drive to keep home directories separate. I also had an external backup.

Finally, I also used aptik to help install software. That worked partially, and mitigated the pain, somewhat.

However, now audio works only sporadically, and requires that I do an "alsa force-reload" on a regular basis to get it to work. I often have to go to system settings to reset everything. Sometimes that reset isn't saved, and it still does not work. Given that the problem is sporadic, I am hesitant to ask for help, because that would require lots of homework on my end, which I don't really have the time for right now.

Possibly related to this is that squeezesoft sometimes starts eating up tons of resources, and I have to restart the service.

I also have your problem of plasma eating up lots of CPU and everything is often slow. Sometimes the whole screen just freezes for about 20 seconds, and I have to wait for even typing to catch up. I have tried some of the solutions on the web, but that hasn't worked. I built this particular desktop to be friendly with linux. Since this is a fresh install, the problems out of the starting box are particularly disappointing.

I hate microsoft windows, and don't want to enter the closed ecosystem of apple. But, linux requires this constant sort of maintenance, that I often need to avoid. Fortunately, this desktop is my sort of test case for such upgrades, and it did not really pass. I have already spent way too much time trying to get things working. I will avoid updating my other machines to 16.04, and only update when the support on 14.04 runs out. Not sure what I will do then, but certainly try to find some version that focuses more on stability. Maybe Mint?

Revision history for this message
jds (jay-schieber) wrote :

While I am annoying everyone with my spleen venting, let me add one more thing. I can no longer mount my network shared folders automatically either. There is a nice new feature on dolphin to add these as samba shares pretty easily. But, this is not sufficient for Amarok to see them. They have to be mounted as if they were local directories, and this has to be done by hand every time the computer is rebooted. Then amarok needs to start after doing this, or it will think all of the music has been deleted. Which means that it needs to be restarted by hand. Therefore none of the remote bits for amarok work either. So, now I have lost my music playing set up. Neither Amarok nor logitech work any more with this computer.

Revision history for this message
RS (salacr) wrote :

I have same issue on 16.10. If is there anything what i can do to help this fixed please let me know.

Revision history for this message
Carl Nobile (cnobile1) wrote :

I also have this issue on 16.04. I can restart plasmashell, but this only fixes the issue for a few hours, not good when I usually leave my machine running for week on end.

Revision history for this message
Stefano Forli (ntropia) wrote :

I will add that on my machine (Ubuntu 16.04.1) increases in CPU usage get triggered also by changes in the network connectivity.
For example, if the WiFi connection drops and Skype tries to connect, Plasma goes immediately to 100%. Killing Skype reduces the CPU usage to 15-30%, but it stays around that for a while.

Same thing when using Dolphin to copy large files from the internal SSD hardisk to USB thumbdrives.

(I'm sure it's a fixable, and it will indeed be fixed in time for the announcement of KDE 6, which will bring all kinds of new and exciting bugs together with some nasty and unavoidable new features)

Revision history for this message
pqia (process-quality-in-action) wrote :

I am running a fresh install of Kubuntu 16.10. It run great for a few weeks adding in apps and servers and virtualbox. Now plasmashell runs high cpu. is there a bug report to follow?

Revision history for this message
Stefano Forli (ntropia) wrote :

An update to confirm the issue also on Kubuntu 16.04.2 with backports:
  kernel 4.8.0-34-generic #36~16.04.1-Ubuntu SMP
  KDE Plasma version 5.8.5
  KDE Frameworks version 5.28.0
  Qt Version 5.6.1

Revision history for this message
Kirill (whobscr) wrote :

I have the same issue with KDE Neon 5.9.3

Revision history for this message
Silvan Geissmann (silvan-geissmann) wrote :

same issue with
Kernel: 4.4.0-67-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: KDE Plasma 5.5.5 (Qt 5.5.1) dm: sddm,sddm Distro: Ubuntu 16.04 xenial

Graphics: Card: NVIDIA GM107GL [Quadro K2200] bus-ID: 03:00.0 chip-ID: 10de:13ba
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: Quadro K2200/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 375.39 Direct Rendering: Yes

I have 10 (!) processes "/usr/bin/plasmashell --shut-up" and one 'usr/bin/baloo_file_extractor' eating 100% CPU each ..

Revision history for this message
André Bauer (monotek) wrote :

Same here on 16.10.

I have to kill & start /us/bin/plasmashell at least once a day because restarts after some time anyway when CPU is on 100% for some time.

Revision history for this message
aitor (aitor-cuartango) wrote :

I also suffer this bug. With kubuntu 17.04

Revision history for this message
Stefano Iozzi (t3t4n0) wrote :

Same for me in Kubuntu 17.04

Copying some file (55 GiB) from the Kubuntu Drive to a Data drive shared with Windows 10.
Only one CPU of four installed rise up to 100% usage. Consequent lag and freezing of the system

Revision history for this message
tik0 (orcera) wrote :

Same on "Kubuntu 16.04.2 LTS" with 4.8.0-52-generic kernel.

After automatic switching access points the process "plasmashell --shut-up" generates 100% CPU load.
In my case, it is related to the Skype 4.3.0.37 application.
As soon as I kill the Skype tray icon, the "plasmashell --shut-up" vanishes and the CPU load goes back to normal.

Revision history for this message
Rion (rion4ik) wrote :

Same on Gentoo system :-) killing/restarting plasmashell helps.

Revision history for this message
Christian Treczoks (ch.treczoks) wrote :

Kubuntu 17.4, and plasmashell startup is (still) a disaster. 21 cpu minutes at 80+%. killed plasmashell and restarted it, 6+ cpu minutes at 80+ %. The system is basically useless during this time.

Or does someone really expect me to log in and then come back half an hour later before the system is actually usable?

Revision history for this message
Ulrich Sibiller (uli42) wrote :

I see the same on Kubuntu 16.04 LTS. Removing all animated(!) icons from the systray made the issue disappear. I got the idea from this: https://bugs.kde.org/show_bug.cgi?id=356479

Revision history for this message
Adam Felson (adam-ubuntu) wrote :

Still present in kubuntu 17.10, occuring anytime a screen's resolution is changed.
Typically using 70-100% cpu, returning to <10% when plasmashell is killed and restarted.

tags: added: artful yakkety zesty
Revision history for this message
James Dingwall (a-james-launchpad) wrote :

This issue affects me on Ubuntu Bionic 18.04 if I have a Firefox window open with a frequently changing title bar. It seems that plasmashell cannot keep up with re-rendering the label on the task bar buttons. The specific Firefox operation that triggers it for me is using the HTML5 iKVM on a Supermicro server where the title is constantly updating with the FPS of the video connection.

plasma-workspace:
  Installed: 4:5.15.4-0ubuntu1
  Candidate: 4:5.15.4-0ubuntu1
  Version table:
 *** 4:5.15.4-0ubuntu1 500
        500 http://gb.archive.ubuntu.com/ubuntu disco/universe amd64 Packages
        100 /var/lib/dpkg/status

tags: added: disco
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.