package is uninstallable due to missing dependency

Bug #1458112 reported by Sergey Basalaev
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
plasma-widget-yawp (Ubuntu)
Confirmed
Medium
Unassigned

Bug Description

Package plasma-dataengines-yawp (and plasma-widget-yawp that depends on it) is in the repository but is uninstallable on vivid because it depends on libweather-ion6 while there is only libweather-ion7 in repository.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: plasma-dataengines-yawp (not installed)
ProcVersionSignature: Ubuntu 3.19.0-18.18-generic 3.19.6
Uname: Linux 3.19.0-18-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CurrentDesktop: KDE
Date: Sat May 23 09:42:41 2015
InstallationDate: Installed on 2015-05-04 (18 days ago)
InstallationMedia: Kubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
SourcePackage: plasma-widget-yawp
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Sergey Basalaev (sbasalaev) wrote :
Revision history for this message
Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue.

I get the same error message regarding unmet dependencies when attempting to install this package on Ubuntu Wily.

It looks like https://launchpad.net/ubuntu/+source/kde-workspace had libweather-ion6, but it seems to have been removed (replaced?) and instead https://launchpad.net/ubuntu/+source/plasma-workspace with libweather-ion7 has been added in Ubuntu 15.04 and newer.

Changed in plasma-widget-yawp (Ubuntu):
status: New → Confirmed
tags: added: unmetdeps wily
Changed in plasma-widget-yawp (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers