Ubuntu

the applet hangs on vpn disconnection and makes all the kde session to hang too

Reported by avlas on 2011-04-12
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
plasma-widget-networkmanagement (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: plasma-widget-networkmanagement

This is happening in kubuntu natty. When I connect vpnc within the applet (0.9~svngit20110408-0ubuntu1), everything works fine but the problem happens when I try to disconnect. This may be also a bug in network-manager-vpnc-kde (0.9~svngit20110408-0ubuntu1) though.

avlas (avlas) on 2011-04-12
summary: - the applet hangs on vpn disconnection and makes all the kde session the
+ the applet hangs on vpn disconnection and makes all the kde session to
hang too
avlas (avlas) wrote :

There was an update today that properly disconnects the vpn connection and avoids the hang both in plasma-widget-networkmanagement and in the kde session. However there is still a small issue with the applet not updating the disconnected status of the vpn connection.

avlas (avlas) wrote :

I just realized that when trying to disconnect the vpn there is a kded4 process that takes 100% cpu, so the issue is still more important than I thought

avlas (avlas) wrote :

I would really appreciate some attention to solve this important bug. I use vpn a lot and each time I use it, I end up killing kded4 to have a responsive system.

I tried with kvpnc to workaround the issue but exactly the same is happening, so I'm not sure this is a bug on the widget anymore.

Am I the only person suffering this? Could someone tell me how to report more information about the bug?

Thanks in advance

Jens Taprogge (jlt-launchpad) wrote :

Apparently kded4 is stuck in some communication with NetworkManager. When I call nm-tool it takes a very long time to complete its output.

avlas (avlas) wrote :

beyond killing kded4 and restarting the session, is there any workaround I can use to temporally fix the issue until the problem is fixed?

avlas (avlas) wrote :

I answer to myself just in case somebody else is also having the problem: instead of restarting the session (or rebooting), it's much more convenient just to kill kded4 and re-execute it again from krunner.

Jose Bernardo (bernardo-bandos) wrote :

I'm having this problem with mobile broadband, not vpn. but the exact same symptoms.

Bianca Kwey (biancakwey) wrote :

I'm having this problem too. I'm connect with a mobile broadband; the problem with kded4 happen when I try to disconnect. In the cd live knetwork manager; in the installed system (kubuntu 11.04 32 bit) when I try to disconnect kppp. CPU to 100% (intel pentium 4 3,20 Ghz)

Same problem here, trying to disconnect a mobile broadband USB modem. Killing kded4 and restarting it from krunner is a decent but annoying workaround for now.

Btw. I tried to rename ~/.kde to reset the settings but nothing changes.

The same problem occurs even when using nm-applet

shoo_ash is probably right, as the workaround suggested on comment #5 in bug #741200 (https://bugs.launchpad.net/ubuntu/+source/plasma-widget-networkmanagement/+bug/741200/comments/5) seems to work for me after restarting kded4. No more 100% cpu usage when disconnecting from the broadband or vpn.

avlas (avlas) wrote :

the workaround didn't work for me :( I'm using vpnc, what kind of vpn protocol you're using?

For me it works, both with openvpn and normal broadband disconnections. I can't use vpnc with the applet as it won't ask for the password.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers