Ubuntu

knetworkmanager in unmanaged mode after last package upgrade (solved with a workaround)

Reported by Vittorio Vallero on 2010-04-16
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
plasma-widget-networkmanagement (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: plasma-widget-networkmanagement

Description: Ubuntu lucid (development branch)
Release: 10.04
KNetworkManager: v0.9

After today package update knetwork manager starts in unmanaged mode. Both wired and wireless networks are working anymore.
Setting up network through ifconfig it is ok.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: network-manager-kde 1:0.9~svn1112085-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-21.31-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
Architecture: amd64
Date: Fri Apr 16 12:42:08 2010
ExecutablePath: /usr/bin/knetworkmanager
InstallationMedia: Kubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcEnviron:
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: plasma-widget-networkmanagement
XsessionErrors: (process:1970): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

koso (koso) wrote :

Lucid switched to plasma-widget-networkmanagement, so use plasmoid to control network interfaces. Only one of this frontend can be used at one time and default is noww plasmoid.

If you do not want to use plasmoid, you have to stop KDED Networkmanagement module and restart knetworkmanager.

It seems that for unknown reason in:
/var/lib/NetworkManager/NetworkManager.state
[main]
NetworkingEnabled=false
WirelessEnabled=true
WWANEnabled=true

Just changing to
NetworkingEnabled=true

solves the problem after restart

summary: - knetworkmanager in unmanaged mode after last package upgrade
+ knetworkmanager in unmanaged mode after last package upgrade (solved
+ with a workaround)

I got this again today after the computer was improperly shut down.

Yannis Tsop (ogiannhs) wrote :

same problem here, when the computer was improperly shutdown NetworkManager stopped working.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers