KNetworkManager installation misconfigured - /lib/dbus-1.0/dbus-daemon-launch-helper had wrong permissions

Bug #508940 reported by Stefan Fleiter on 2010-01-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dbus (Ubuntu)
Undecided
Unassigned
plasma-widget-networkmanagement (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: plasma-widget-networkmanagement

After starting network-manager kde in Lucid I get the following message in a dialog:

KNetworkManager cannot start because the installation is misconfigured.
System DBUS policy does not allow it to provide user settings;
contact your system administrator or distribution.
KNetworkManager will not start automatically in future.

Afterward I get the following segmentation fault:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
The current source language is "auto; currently asm".
[KCrash Handler]
#5 QHash<QWidget*, QHashDummyValue>::detach (this=0x1574b20, parentWidget=0x0, f=) at ../../include/QtCore/../../src/corelib/tools/qhash.h:299
#6 QHash<QWidget*, QHashDummyValue>::insert (this=0x1574b20, parentWidget=0x0, f=) at ../../include/QtCore/../../src/corelib/tools/qhash.h:749
#7 QSet<QWidget*>::insert (this=0x1574b20, parentWidget=0x0, f=) at ../../include/QtCore/../../src/corelib/tools/qset.h:176
#8 QWidgetPrivate::init (this=0x1574b20, parentWidget=0x0, f=) at kernel/qwidget.cpp:1119
#9 0x00007fed4a634cc1 in QWidget (this=0x12d48e0, dd=<value optimized out>, parent=0x0, f=...) at kernel/qwidget.cpp:1039
#10 0x00007fed4aa1ab5c in QMenu (this=0x12d48e0, title=..., parent=0x0) at widgets/qmenu.cpp:1373
#11 0x00007fed3f36c3a0 in QMultiInputContext (this=0x1552b50) at qmultiinputcontext.cpp:88
#12 0x00007fed3f36d935 in QMultiInputContextPlugin::create (this=<value optimized out>, key=<value optimized out>) at qmultiinputcontextplugin.cpp:83
#13 0x00007fed4abaa81e in QInputContextFactory::create (key=..., parent=0x7fff244dd7f0) at inputmethod/qinputcontextfactory.cpp:160
#14 0x00007fed4a5dbabf in QApplication::inputContext (this=0x7fff244dd7f0) at kernel/qapplication.cpp:5183
#15 0x00007fed4a67a19d in QWidget::destroy (this=0x1513800, destroyWindow=true, destroySubWindows=true) at kernel/qwidget_x11.cpp:1100
#16 0x00007fed4a679f14 in QWidget::destroy (this=0x15bd920, destroyWindow=true, destroySubWindows=<value optimized out>) at kernel/qwidget_x11.cpp:1050
#17 0x00007fed4a679f14 in QWidget::destroy (this=0x15b8450, destroyWindow=true, destroySubWindows=<value optimized out>) at kernel/qwidget_x11.cpp:1050
#18 0x00007fed4a679f14 in QWidget::destroy (this=0x1598e60, destroyWindow=true, destroySubWindows=<value optimized out>) at kernel/qwidget_x11.cpp:1050
#19 0x00007fed4a5e773b in ~QApplication (this=0x7fff244dd7f0, __in_chrg=<value optimized out>) at kernel/qapplication.cpp:1040
#20 0x000000000040e81a in _start ()

ProblemType: Bug
Architecture: amd64
Date: Mon Jan 18 00:17:18 2010
DistroRelease: Ubuntu 10.04
NonfreeKernelModules: nvidia
Package: network-manager-kde 1:0.9~svn1075616-0ubuntu1
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
SourcePackage: plasma-widget-networkmanagement
Tags: lucid
Uname: Linux 2.6.32-10-generic x86_64

Stefan Fleiter (stefan-fleiter) wrote :
Jonathan Thomas (echidnaman) wrote :

Could you attach a copy of /etc/dbus-1/system.d/NetworkManager-kde4.conf please?

Changed in plasma-widget-networkmanagement (Ubuntu):
status: New → Incomplete
Stefan Fleiter (stefan-fleiter) wrote :

Maybe a consolekit problem?

# ck-list-sessions

** (ck-list-sessions:9688): WARNING **: Failed to get list of seats: The permission of the setuid helper is not correct

Jonathan Thomas (echidnaman) wrote :

Certainly looks suspicious, but I'm not a consolekit expert. Let's see what the consolekit people think.

Stefan Fleiter (stefan-fleiter) wrote :

Here the log of "strace -v -e read=3 -o consolekit.log ck-list-sessions".

The following error messages seem suspect:
org.freedesktop.DBus.Error.NameHasNoOwner
org.free desktop.DBus Could not get owner of name 'org.freedesktop.ConsoleKit': no such name

org.freedesktop.DBus.Error.Spawn.PermissionsInvalid
org.freedesktop.DBus The permission of the setuid helper is not correct

Maybe the second set of errors is caused by the first?
But I do not know any dbus internals.

Jonathan Thomas (echidnaman) wrote :

This basically means that ConsoleKit is busted. For the time being I think we can consider this a consolekit bug.

Changed in plasma-widget-networkmanagement (Ubuntu):
status: Incomplete → Invalid
Stefan Fleiter (stefan-fleiter) wrote :

After *lot* of research I found out, that
/lib/dbus-1.0/dbus-daemon-launch-helper
had the wrong permissions.
A reinstall of every package with dbus in it's name fixed this.

The question is how the wrong permissions where attached to this file.

Now ck-list-sessions does work and
KNetworkmanager is funcational again, too.

Jonathan Thomas (echidnaman) wrote :

Neat, glad it worked out.

affects: consolekit (Ubuntu) → dbus (Ubuntu)
Changed in dbus (Ubuntu):
status: New → Invalid

Are you sure about the invalid state?
I did not change those permissions, I wonder if some bug caused the wrong permissions.

Changed in dbus (Ubuntu):
status: Invalid → New

It seems that the crash is not related to dbus nor the bug that was reported. I consistently get the same crash *every time* I log off. I'm running Kubuntu 9.10 and this started happening after I installed all the upgrades from the Kubuntu PPA Beta repo.

I have KNetworkManager running with wireless disabled and an active ethernet connection.

Here is the crash log (this happens after I give the log out command; there's no time to report the bug as the bug report window automatically closes, I just have enough time to save the report):

Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#5 QHash<QWidget*, QHashDummyValue>::detach (this=0x10ed3b0, parentWidget=0x0, f=) at ../../include/QtCore/../../src/corelib/tools/qhash.h:299
#6 QHash<QWidget*, QHashDummyValue>::insert (this=0x10ed3b0, parentWidget=0x0, f=) at ../../include/QtCore/../../src/corelib/tools/qhash.h:749
#7 QSet<QWidget*>::insert (this=0x10ed3b0, parentWidget=0x0, f=) at ../../include/QtCore/../../src/corelib/tools/qset.h:176
#8 QWidgetPrivate::init (this=0x10ed3b0, parentWidget=0x0, f=) at kernel/qwidget.cpp:1119
#9 0x00007f855939cc81 in QWidget (this=0x1076d50, dd=<value optimized out>, parent=0x0, f=...) at kernel/qwidget.cpp:1039
#10 0x00007f8559782ebc in QMenu (this=0x1076d50, title=..., parent=0x0) at widgets/qmenu.cpp:1373
#11 0x00007f854e526380 in QMultiInputContext (this=0x107cce0) at qmultiinputcontext.cpp:88
#12 0x00007f854e527915 in QMultiInputContextPlugin::create (this=<value optimized out>, key=<value optimized out>) at qmultiinputcontextplugin.cpp:83
#13 0x00007f8559912cce in QInputContextFactory::create (key=..., parent=0x7fff934bdad0) at inputmethod/qinputcontextfactory.cpp:160
#14 0x00007f8559343a1f in QApplication::inputContext (this=0x7fff934bdad0) at kernel/qapplication.cpp:5183
#15 0x00007f85593e212d in QWidget::destroy (this=0x11167b0, destroyWindow=true, destroySubWindows=true) at kernel/qwidget_x11.cpp:1100
#16 0x00007f85593e1ea4 in QWidget::destroy (this=0xfe0140, destroyWindow=true, destroySubWindows=<value optimized out>) at kernel/qwidget_x11.cpp:1050
#17 0x00007f85593e1ea4 in QWidget::destroy (this=0x110c500, destroyWindow=true, destroySubWindows=<value optimized out>) at kernel/qwidget_x11.cpp:1050
#18 0x00007f85593e1ea4 in QWidget::destroy (this=0x1103cf0, destroyWindow=true, destroySubWindows=<value optimized out>) at kernel/qwidget_x11.cpp:1050
#19 0x00007f855934f68b in ~QApplication (this=0x7fff934bdad0, __in_chrg=<value optimized out>) at kernel/qapplication.cpp:1040
#20 0x000000000040d13a in _start ()

I'm

plasma-widget-networkmanagement:
  Installed: 0.9~svn1029786+ag1-0ubuntu1
  Candidate: 0.9~svn1029786+ag1-0ubuntu1
  Version table:
 *** 0.9~svn1029786+ag1-0ubuntu1 0
        500 http://archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

libqt4-core:
  Installed: 4:4.6.0-1ubuntu3~karmic1~ppa1
  Candidate: 4:4.6.0-1ubuntu3~karmic1~ppa1
  Version table:
 *** 4:4.6.0-1ubuntu3~karmic1~ppa1 0
        500 http://ppa.launchpad.net karmic/main Packages
        100 /var/lib/dpkg/status
     4.5.3really4.5.2-0ubuntu1 0
        500 http://archive.ubuntu.com karmic/universe Packages

Jonathan Thomas (echidnaman) wrote :

Yeah, that's a different bug. (bug 512169)

The permissions of dbus-daemon-launch-helper got lost with todays updates again.

# ll /lib/dbus-1.0/dbus-daemon-launch-helper
-rwxr-xr-x 1 root root 47520 2010-02-19 07:47 /lib/dbus-1.0/dbus-daemon-launch-helper
This bug is serious.

/sbin/udevadm also was diverted to the posix shell alternative.
Maybe this is related to another.

summary: - KNetworkManager installation misconfigured
+ KNetworkManager installation misconfigured - /lib/dbus-1.0/dbus-daemon-
+ launch-helper had wrong permissions
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers