Ubuntu

kubuntu Karmic network dsl doesn't work

Reported by Yunkwan on 2009-10-09
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
plasma-widget-networkmanagement (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by la_serpe
Nominated for Lucid by la_serpe

Bug Description

OS: latest Kubuntu Karmic and Lucid and Maverick and Natty (updated to the latest package)
Arch: i386 and x86-64

1. The networkmanager applet is changed into a new one in Karmic. This time, DSL connection can be added in the DSL tab. However, this DSL connection doesn't work at all. I setup a pppoe connection in the DSL tab, but I can't never get it connected, even I selected "connect automatically" this option.

2. If I use pppoeconf to setup a dsl connection, it works. But the networkmanager will be unmanged after a system reboot.

Philip Muškovac (yofel) on 2009-10-09
affects: ubuntu → plasma-widget-networkmanagement (Ubuntu)
Sergio bh (kde-bhf) on 2009-12-28
description: updated
Nicolai_J. (fireandfuel) wrote :

It sounds like: Bug #432205
But I think it is not a duplicate of bug #334122 - that's about mobile broadband connections!

1. I also add a DSL (PPPoE) connection. I realized that the plasma widget doesn't show me a DSL connection.
I can set a DSL connection with pppoeconf and connect with "pon dsl-provider" - but it doesn't work for me.

2. A little fix:
Edit /etc/network/interfaces (with root privileges)
and remove everything that doesn't begin with an "auto" (like "auto eth0" and "auto lo").

for example an interfaces file can looks like this:

auto lo
auto eth0

Nicolai_J. (fireandfuel) on 2010-01-03
Changed in plasma-widget-networkmanagement (Ubuntu):
status: New → Confirmed
Nicolai_J. (fireandfuel) wrote :

I have found a solution (using the gnome network manager applet):

1. Add the line "deb http://ppa.launchpad.net/network-manager/trunk/ubuntu karmic main" to your /etc/apt/source.list
(sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com [ID] - if you want to add the key for the PPA)
2. Update your package list
3. Install the package network-manager-gnome
4. Remove the packages plasma-widget-networkmanagement and plasma-widget-network-manager
5. Add "nm-applet" to your autostart
6. Verify with "nm-connection-editor" that the wired connections are set up correctly.
7. Edit or create your DSL connection (pay attention to NOT set "Available to all users" for this connection!).

It seems that DSL isn't added to the network manager plasma widget.
Perhaps it will be available at the next ubuntu release (10.04 "lucid").

la_serpe (tom-mil) wrote :

I experience the same in Ubuntu Karmic Koala, but I must say that this problem occurs only on certain networks. For example I can easily establish DSL connection at home, but not in my university's dormitory. I would like to point out it has nothing to do with the network provider because it stopped working just after I updated my Ubuntu to Karmic. Before it was fine on both networks.

grasscap (grasscap) wrote :

This bug affects Lucid also. It need to be fixed considering it's a LTS release.

Scipione (sndsergiu) wrote :

"It seems that DSL isn't added to the network manager plasma widget.
Perhaps it will be available at the next ubuntu release (10.04 "lucid")." now I have ku 10.04 and this problem is still there..... :(

Adam Porter (alphapapa) wrote :

So...how many years before *this* bug gets fixed? How many more releases will Kubuntu ship out with broken networking? How bad does a bug have to be for it to block a release? Why does it seem that no one but the users care about basic feature parity with Ubuntu?

MohamadReza Mirdamadi (mohi) wrote :

I can confirm this "bug" still in 1010. maybe its needed to rport a new bug against plasma-widget-networkmanagement as this bug exists in several releases.

A short description and some love and attention from maintainers over this issue is appreciated highly.

description: updated
Andreas Samberg (a-samberg) wrote :

just a detail: It affects the 64bit versions, too.
And as I don't know if this was communicated sufficiently clearly: One (or is it just I?) _can_ configure a DSL connection. However, it doesn't appear in the `connections' list afterwards to be clicked; and `connect automatically' won't work (see description).

Mark (mark-wege) wrote :

I can confirm this bug. I am running Maverick with Kubuntu.

fioan89@gmail.com (fioan89) wrote :

Kubuntu 11.04 , and same problem.I got a feeling that kde 4.7 will be out on July and the problem will not be solved.

Andreas Samberg (a-samberg) wrote :

This is just incredible. Waiting since Karmic now.

grasscap (grasscap) wrote :

Guys, don't count on KDE's network manager. This bug exist for years and it would probably last for another a few years. Those developers probably don't use DSL.

There is a workaround:

1. sudo apt-get install network-manager-gnome
2. sudo apt-get remove network-manager-kde

add "nm-applet --sm-disable" to autostart

description: updated
grasscap (grasscap) wrote :

Anyone tried it with the latest beta release? I am expecting to see this bug again in 11.10.

Yep, fired up a daily build just yesterday and sure enough, DSL is MIA.

grasscap <email address hidden> wrote:

>Anyone tried it with the latest beta release? I am expecting to see this
>bug again in 11.10.
>
>--
>You received this bug notification because you are subscribed to the bug
>report.
>https://bugs.launchpad.net/bugs/447241
>
>Title:
> kubuntu Karmic network dsl doesn't work
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/ubuntu/+source/plasma-widget-networkmanagement/+bug/447241/+subscriptions

Gsus (jeguiluz) wrote :

I have the same problem.

this things move me from kubuntu to ubuntu. or (gnome-network-manager)

Rafał Miłecki (zajec5) wrote :

This bug was fixed in networkmanagement with commit:

commit 68ebd8231f942154cd743d4007b8ab9e8689808b
Author: Lamarque V. Souza <email address hidden>
Date: Mon Sep 12 21:52:11 2011 -0300

    Allow DSL connections be associated to ethernet interfaces.

    CCBUG: 204170

Upstream bug:
https://bugs.kde.org/show_bug.cgi?id=204170

You just need to update networkmanagement plasmoid (not sure which Ubuntu version contains fixed version).

Алексей (whitemailbox7) wrote :

add "dsl-connection", "automatic connection" - true, and remove all wired conections and restart NetworkManager.

You get "ppp0", if you enter "ifconfig" in console, but you not see "New PPPoE connection" in plasmawidget-networkmanagement

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.