Ubuntu

Can't connect to a hidden network

Reported by TuxFan on 2009-02-18
112
This bug affects 12 people
Affects Status Importance Assigned to Milestone
knetworkmanager
Fix Released
Medium
plasma-widget-network-manager (Ubuntu)
Low
Andreas Wenning
Jaunty
Undecided
Unassigned

Bug Description

Binary package hint: plasma-widget-network-manager

== SRU for 0.0+svn966653-0ubuntu0.1 ==
This SRU covers this bug, bug 334052 as well as numerous other small fixes.

Testcase for this bug:
Manually add a hidden wireless network in the setting; test that this network now shows up and connecting to it is possible. (Restart may be required)

Testcase for bug 334052:
Successfully connect to a WPA-2/enterprise network.

The above is of course dependent on that the underlying encryption methods etc. does actually work. Currently both of the above fail in all cases; so a working for some people is a success.

== Original description ==
I installed Jaynty's Alpha4 (Kubuntu) on my laptop for testing + all the current updates, and I can't connect to a hidden network.

If I put the network visible, the widget connects automaticly as configured. It keeps working if I hide the network, but after that it doesn't connect if I have to reboot my laptop.

Running plasma-widget-network-manager version: 0.0+svn924363-0ubuntu1

TuxFan (make) wrote :

This still happens with the latest release (0.0+svn930811-0ubuntu1).

I managed to get the hidden wireless network working by giving the system a little hint: from konsole I used iwconfig to set the essid of my hidden network for the wireless interface, and few moments after that kwallet pops up and plasma-widget-network-manager connected to my network normally.

So it seems that hidden networks isn't searched by plasma-widget-network-manager even if they are manually configured and saved in the settings. (And in fact, the plasma-widget-network-manager doesn't show found hidden networks, but that was the case even with the old network manager from KDE 3.5.x.)

Jonathan Thomas (echidnaman) wrote :

I believe I have found a bug at bugs.kde.org that adequately describes your problem: https://bugs.kde.org/show_bug.cgi?id=182205

Changed in plasma-widget-network-manager:
importance: Undecided → Low
status: New → Triaged
Changed in knetworkmanager:
status: Unknown → Confirmed
Christiansen (happylinux) wrote :

Running Kubuntu Jaunty Alpha 6 it is still impossible to connect to networks with hidden SSID. When unhidding the SSID plasma-widget-network-manager connects okay as described TuxFan.

I believe that the that the KDE bug mentioned by Jonathan is slightly different, when the network isn't listed running nm-tool. But I found that as soon an attempt to connect e.g. by the wpa_supplicant CLI tool, the hidden SSID is listed by the nm-tool.

BTW. Still in Alpha 6 as mentioned in bug #338973, installing the network-manager-gnome applet connections to hidden networks is possible. Hopefully there will be a solution to this bug, marked as "low importance" soon. Isn't network connection a must for most desktop computers today ?

TuxFan (make) wrote :

I also think that the mentioned KDE bug is a different bug. It's about NetworkManager-kde4 not been able to save (or show) the used password. My password is saved and I can see it if I check the "Show password" field. Also, nm-tool doesn't show my network at all. (It does show it after I do the trick with iwconfig, and after that kwallet pops up and plasma-widget-network-manager connects to my network normally.)

TuxFan (make) wrote :

If network-manager-gnome works, then I guess this is a bug in network-manager-kde? And not in the plasma widget. I get these lines in my daemon.log after logging in and before doing any tricks:

NetworkManager: <WARN> list_connections_cb(): Couldn't retrieve connections: No such method 'ListConnections' in interface 'org.freedesktop.NetworkManagerSettings' at object path '/org/freedesktop/NetworkManagerSettings' (signature '').
NetworkManager: <WARN> connection_get_settings_cb(): connection_get_settings_cb: Invalid connection: 'NMSettingWirelessSecurity' / 'auth-alg' invalid: 6
NetworkManager: <WARN> connection_get_settings_cb(): connection_get_settings_cb: Invalid connection: 'NMSettingGsm' / 'network-id' invalid: 1

Luka Renko (lure) wrote :

I have tested this today on up-to-date Kubuntu/Jaunty. I used hidden network with following settings:
- WPA Enterprise,
- PEAP,
- MSCHAPv2

nm-applet 0.7.1~rc3-0ubuntu1: works!
knetworkmanager 1:0.7svn864988-0ubuntu8: works!
plasma-widget-network-manager 0.0+svn930811-0ubuntu2: does not even try to connect

I think that knetworkmanager task should be closed as Fixed, while there is for sure the problem with plasma-widget. I think when you add hidden network (Manage connections -> Add) and mark it to "Autoconnect", it does not even try to auto-connect and also does not show newly added network in the list of available SSIDs.

Luka Renko (lure) wrote :

Search for "==> TRY" to see different clients used.

pauls (paulatgm) wrote :

jaunty running here and knetworkmanager (after reboot) won't connect to hidden router, and it is not listed in nm-tool. Yes, knetworkmanager sees the hidden and it's possible to create the configuration, but it still does not connect on bootup.

But in gnome jaunty, hidden router can be configured and connects ok.

So, it's a gnome vs. kde issue here.

TuxFan (make) wrote :

I wasn't able to make knetworkmanager connect automaticly either on my quick test. Actually I wasn't able to make it to connect at all...

I wonder if this bug is limited to some specific hardware, since it doesn't seem to affect a lot of people. (Not that I would have any idea how many people are already using the beta and how many of them have their a wireless network hidden...) But anyway, I'm using:

Access Point: Buffalo WHR-G54S (with dd-wrt + WPA mixed PSK)
Client: Thinkpad R50e (with Intel 2200BG [Calexica2] which uses the ipw2200 module)

I also had to reconfigure my network in plasma-widget-network-manager a while back to be able to use the iwconfig trick mentioned earlier. I don't remember what upgrades I got before that, but I don't think that the plasma widget got an upgrade back then...

Christiansen (happylinux) wrote :

Did a fresh install of 9.04 Beta today and updated it from the main repository. Still not able to connect to a hidden SSID with plasma-widget-network-manager (PWNM) and a ThinkPad buildin Intel 2915ABG adapter.
Removed the SSID from Network-Managment rebooted, disabled the buildin adapter in BIOS, and after login to KDE inserted a Cisco PCMCIA Atheros AR5212 based adapter. Recreated the SSID in Network-Managment and waited a while, executing nm-tools to find out if the hidden SSID was listed. The SSID did not show up at any time until I forced a scan by using "wpa_supplicant", then the PWNM recognized it an connected.
Removed the SSID from Network-Managment and shutdown the box, removed the PCMCIA adapter and booted. As above I inserted a 3COM USB WiFi stick with Zyxel zd1211 chipset, recreated the SSID and waited as described above - no connection until a scan was forced by "wpa_supplicant"

All tests was done using a Cisco router with a build Atheros based radio as access point. Using WPA2 and CCMP encryption, and a simpel secret on 8 characters.

TuxFan (make) wrote :

I got tired of this bug and installed wicd, which removed network-manager, network-manager-kde and plasma-widget-network-manager from the system. After the first install wicd wasn't able to connect to a hidden network (I wasn't able to input the ESSID), but after a reinstall it works well and automaticly connects to a hidden network.

Yves Glodt (yglodt) wrote :

Has this bug been reported upstream already? if not, Kubuntu-maintainers, should we do it?

David (dogge2k) wrote :

I have the same problem, plasma-widget-network-manager-0.0+svn930811-0ubuntu2 doesn't connect to my hidden wpa protected wireless. At the moment this widget is not usable for me and I will have to switch to knetworkmanager if the problem still exists in the final.

David (dogge2k) wrote :

https://bugs.kde.org/show_bug.cgi?id=186951

Maybe we should consider increasing the importance. I think a lot of people are using a hidden ap with their wireless.

Craig Magina (craig.magina) wrote :

Also being hit by this issue. Thanks to the person who brought iwconfig to my attention as that works. This is a KDE specific issue as the GNOME NM applet does not suffer from this. I moved to Kubuntu 9.04 from Fedora 10.

Kent57 (kent5700) wrote :

I have the same problem with a Compac laptop running Kubuntu 9.04. It started after upgrading from Kubuntu 8.10, which worked just fine. The only way to connect to my hidden wireless network now is to make it visible. I've tried Wicd which finds the hidden network & also works well. I would like to see plasma-widget-network-manager work as it has that cool plasma look. But in the meantime I'll stick with Wicd.

Same here. I have to use konsole and use iwlist scan essid <hidden-net>. Then network manager wakes up and asks for a wallet password.

David (dogge2k) wrote :

Maybe we should switch back to knetworkmanager as the default network manager because I don't think this problem will be fixed shortly. knetworkmanager doesn't look as nice as the plasma widget, but can handle hidden aps and works fine with kubuntu.

Christiansen (happylinux) wrote :

@David
I do agree with you, that it probably would be a good idea to switch back to knetworkmanager, even though this plasma-widget is nice and locks promising. From this bug report it seems that more people are affected by this bug, and probably even more to come when 9.04 is released (based on earlier work with NM and hidden networks). Finally other bugs that has similar problems (like Bug #334122) would be solved too.
I've been hacking around in the source code from KDE and the bug rapports there, and the ToDo list does not even lists this problems, despite the open KDE bug rapport you mentioned earlier. Further more the authors mentions somewhere, that a fully working application isn't to be expected before KDE 4.3 arrives.

Unfortunately, right now I,m not able to get knetworkmanager connect to hidden APs. This seems to be some sort of broken link to kwalletmanager, an I don't know if there is simple solution to this.

Michael Marley (mamarley) wrote :

This won't be possible for two reasons. First, the final release is only weeks away. It is way to late to make an intrusive change like that. Second, I have heard the developers say that there is no room on the CD left for the KDE3 libraries that would be necessary to run KNetworkManager.

Hopefully, KNetworkManager4 will have been released and/or the bugs in the plasmoid will have been fixed in time for Karmic.

nils (internationils) wrote :

If there is no chance of a fix for Jaunty (including a switch to KNetworkManager) could someone please post a semi-official workaround? I.e. installing knetworkmanager yourself, using wicd, Gnome NM, etc. ? I get the feeling that a LOT of people will stumble across this bug in the next 6 months...

zdenek.zikan (zdenek-zikan) wrote :

Guys, shouldn't the release be postponed in case that such an important issue exists? Cause when somebody upgrades to a new distro and it will not allow him to connect to the internet by the same means that have already that worked for some years, that's a big problem. Mainly because without internet connection working it's much more difficult to find a solution on how to make it work again, install new packages (knetworkmanager, nm-applet, wicd). I don't see it as a good idea to release it to common user. Or at least provide some warning about this problem _before_ he actually starts the upgrade.

nils (internationils) wrote :

I can confirm that

'sudo iwlist wlan0 scan essid <hidden_ssid>'

works, and connects to the network. I had to do it twice (or maybe it was do it once and wait a little), but it worked. The network is then listed in the plasma widget and connected to automatically.

For people who are unsure what their wireless device is (wlan0 in my case), run 'ifconfig' to see the list of network devices. 'lo' is a loopback device, 'eth0' are network cards, etc.

Patrick T. (p1703) wrote :

I confirm this bug using the 9.04 RC amd64 version and I fully agree to zdenek.zikan - this is going to be the third low-quality-release of kubuntu with major bugs so that working won't be possible anymore for a long time. It is not acceptable that existing important features are dropped by a new distro version. I would prefer a stable and completely working release 2 months later, if required.

I do not understand how such a missing, previously existing feature can be on 'low' importance.

pauls (paulatgm) wrote :

nils, your method of issuing this

'sudo iwlist wlan0 scan essid <hidden_ssid>'

does not work here. It will successfully show my hidden network, but it never shows up in jaunty's network manager widget. The widget will only show networks that are not hidden.

pauls (paulatgm) wrote :

some people have suggested using gnome network manager applet (nm-applet) instead of plasma network manager widget on kde, but when I do that, there seems to be no way to save the password with the kde wallet. so that is not such a good work around.

nils (internationils) wrote :

pauls, I had the hidden network configured and set to autoconnect in the network manager beforehand. When I issue the iwlist command (sometimes I need to issue it a few times if I just enabled the wireless until it sees the network), the kde wallet asks me for a password, and a few seconds later it is connected. I'm running latest amd64 jaunty.

pauls (paulatgm) wrote :

thanks, nils. it finally worked after 12 tries.

pauls (paulatgm) wrote :

I've found a repeatable way to get it recognized after issuing the command only one. I have to uncheck the wireless enable box after issuing 'sudo iwlist wlan0 scan essid <hidden_ssid>' and then recheck it. Apparently, just issuing the command does not cause the applet to rescan afterward, but unchecking / rechecking enable does. Then it will popup the kde wallet, as well as list it in the wifi list.

I have another bug that the popup does not resize automatically, so multiple wireless listings do not appear. The fix is to click on the collapse / expand button just left of the word "wireless" in the applet. This resizes it so I can see all my wifis.

Marco (bulletxt) wrote :

I can only give a -1000 points to kubuntu team. Where do they find the courage to release a distro with such high severe bug? I want to know who is going to tell my brother he has to use windows because "linux" can't find his hidden essid. What a shame.

Since I hate gnome, and since Kubuntu seems to be full of these "stupid for year 2009" bugs, what should I do? Switch to Windows? Then people complain about Microsoft. No way, it's time to complain about people releasing a linux distro with a well known bug. This sucks, totally. Not to mention the ATI known bugs. I mean, if you know about these severe bugs, DON'T do the release. Is someone forcing you guys?
I'm hating all this and sometimes I prefer using and paying Windows with an antivirus rather than booting an OS that is uncapable of connecting to the internet. It's year 2009, and I'm tired of such sh$%.

Luka Renko (lure) wrote :

Yes, it unfortunate to have plasma network-manager with such bug. However, you have a workaround: you can install knetworkmanager and hidden networks should work for you. Just removed the plasma applet and start knetworkmanager and you will hvae same functionality as in 8.10.

zdenek.zikan (zdenek-zikan) wrote :

Well, there is a workaround. But somebody perhaps forgot the Ubuntu's “Linux for human beings” goal. People writing here are probably capable of using the workaround. But we're talking about situation when somebody who is not geek tries doing such a trivial thing as connecting to the internet (yes, in 2009) - and he's lost. He doesn't know what to do, he cannot even look up the solution here and because he's offline, he cannot download and install the knetworkmanager or nm-applet. Great that we have release in time ... it's not working but who cares. :-(
(Or is my understanding of the words “beta”, “release candidate” and “final release” wrong?)

Michael Marley (mamarley) wrote :

This bug needs to have High priority.

But, I also wanted to ask, have any of you tried the plasma-widget-network-manager package from Anthony Mercatante (tonio)'s PPA? This is a much newer version that might fix the problem.

cAbLe (alejandro-maulen) wrote :

Hi:

I am also having problems.

My SSID was not hidden, and anyways, I couldnt connect.

First, I configure my Wifi network in the network manager and I set the pass there. In the plasma menu, it asks me again for pass, no idea why.

After that, it tells me that the connection failed.

I use WPA-PSK with AES, that works perfectly in windows.

This machine only has wifi, so that means, that I am screwed.
As one guy said, the distro shouldnt be released if such error exists :(

Now back to windows.

Thanks.

Michael Marley (mamarley) wrote :

This sounds like a different bug. This bug has to do with hidden networks only. Perhaps you should file a new bug.

sandman71 (sandman71g) wrote :

A walkthrough could be

 sudo iwconfig wlan0 essid name_of_the_hidden_essid

After few seconds wallet asks for the pass as usual

KayGee (kris-gielis) wrote :

Well I tried this walkthrough a couple of times, but on my machine there is no reaction from the wallet.
And the trick of unchecking / rechecking the wlan interface enable box indeed performs a rescan of the available networks, but still doesn't find my hidden wlan essid.
Anybody else with an idea for a workaround ?

Adam Przepiórkowski (adamp) wrote :

The supposed workaround "remove plasma applet and start knetworkmanager" does not work for me. Knetworkmanager worked for me in 8.10, doesn't in 9.04. Neither does the above "iwconfig wlan0 essid..." work for me.

Releasing Kubuntu with such a serious bug is truly surprising. The low priority assigned to it is disheartening. Time to look for a different Linux distribution, I suppose...

David (dogge2k) wrote :

Still not working for me, even knetworkmanager doesn't connect to my hidden wireless. When I stop plasma-widget-network-manager and start knetworkmanager I can see my "Home" wlan connection. But when I click on the entry the following message appears:
Activate Connection /org/freedesktop/NetworkManagerSettings/Connection/0 on Device /org/freedesktop/Hal/devices/net_xx_xx_xx_xx_xx_xx

After a few seconds I see this message in my syslog:
<WARN> wait_for_connection_expired(): Connection (2) /org/freedesktop/NetworkManagerSettings/Connection/0 failed to activate (timeout): (0) Connection was not provided by any settings service

The only way I can use my wireless is to call "iwlist" with plasma-widget-network-manager running. This can't be the solution, my 8.10 kubuntu still works fine with the knetworkmanager.
I can't see anybody working on this problem so far, the priority is still low for this bug and I haven't seen any work on the KDE bug report for the plasma-widget-network-manage.

Same problem here - no connection to hidden wireless networks with the plasma widget on a few Laptops. I open a terminal and start knetworkmanager manually (didn't have to install it - was still there, while not available in the menu) to get connected. But since I'm working in a room with 37 Laptops (for teaching purposes) that's actually annoying. No connectivity is really not funny. A fix is strongly recommended!

Marco (bulletxt) wrote :

Importante: Low ? Yea, you call this low? Lol it's time to switch back to Windows. Continue like this and Ubuntu will never fix its Bug Number 1. Good job Kubuntu team and thank you for releasing a distro that doesn't connect to the internet.

Jonathan Thomas (echidnaman) wrote :

Funny, I seem to be using the internet just fine.

Yves Glodt (yglodt) wrote :

My install of jaunty suffers as well of this bug.
What I do not really get is why canonical, who actually pay people to do make a decent distro, do not simply acknowledge the bug, check with upstream, fix it in svn, and ship the updated package?
Or is it because in this particular case the package we talk about has been coded by opensuse/novell mainly?

pauls (paulatgm) wrote :

If you're willing to try the svn version, it's available at https://launchpad.net/~kubuntu-experimental/+archive/ppa

It's working here some of the time (for hidden essid), but had to reboot 3 times. Ever since, it's worked. So, if you want to help devel, give it a go.

regards,

sebaestn (sebaestn) wrote :

Hey folks, please remember that neither you pay for the software nor most of the people who develop the software are paid for it. So please remain friendly, even though bugs such as this one suck.

I can confirm that the update from the ppa works - at least semi-automatically. I installed it and rebootet my computer three times as paul suggested. However, it didn't work.
After the fourth reboot without suces, I applied the iwconfig trick mentioned above and a dialog opened asking for the WPA-PSK. Now (the last two boots) kwallet pops up and the plasma widget connects to the wlan automatically.

May be it would have also worked if I had reentered the wlan specifications again. I also didn't check if the plasma widget shows my wlan in that list - there are too much networks around here that my wlan showed up among the three displayed (by the way, a scrollbar would be nice...).

Thanks to the developers for their effort to solve this bug!

Marco (bulletxt) wrote :

Don't get me wrong. I love linux and I love Ubuntu and Canonical. However, i'm not complaining about the existance of the bug. I'm complaining about Kubuntu Team politics. I can't accept they released a distro with such a well known bug. It means not being serious and I don't like this.

The philosophy that "it's free, it's gratis" doesn't hold. Especially when Kubuntu website states:
"With this release, the development team brings you the best KDE distro out there. " Is that a joke? The best kde distro out there? No, I can't accept these things.

plasma-widget-network-manager=0.0+svn961724-0ubuntu1~ppa1 from kubuntu-experimental repository works fine for me. In both startup and connection loss cases.

Toni Helenius (toni-helenius) wrote :

Could this working package added to at least the official repos under proposed? And if it seems to work better then distribute the update further. Important bug fix for many and should work out of the box...

David (dogge2k) wrote :

plasma-widget-network-manager=0.0+svn961724-0ubuntu1~ppa1 works for me too! After rebooting my system it took a few seconds and the network was established. I also tested activating the wireless after the computer booted and I could connect to it.

For sure the fact that this bug has low importance shows how kubuntu has low importance compared to ubuntu as well.
I wonder if this was a bug in the gnome version, would it be flagged as low importance? I'm sure not.
Anyway, the solution does exist: the package from kubuntu-experimental does work.
Now, we just need to wait for a good soul to put it in the official repos, so that everybody will have this fix.
Even better: there should be a new cd image released with this fix, so that people who download it would be happy from the beginning...

Christiansen (happylinux) wrote :

My experience is pretty much the same as Sebaestn describes on the 2009-05-02 - with plasma-widget-network-manager-0.7+svn961724-0ubuntu1~ppa1, it works after an initial connection has been created by different workarounds.

This was tested with different boxes and different WiFi chipsets, after a clean install of the box on every event. On the Intel 2915ABG WiFi chipset the first connection was created by entering "sudo iwconfig eth1 essid 'SSID'". After a cupple of minuttes the connection was automatically created, and works on continuosly reboots.

On a Atheros 521x Chipset (internal as well as external PCMCIA cards) this didn't work at all, and the default jaunty driver ath5k seems to make things worse. Changed the driver from the "Hardware Drivers" application, rebooted and tried the iwconfig thing without luck. Unhidding the SSID on the AP for the initial connection, and hidding the SSID again, connection was established automatically on successive reboots.

Reinstalled the OS a cupple of times on the boxes, and the latest Kubuntu experimental build does make things better, but definitely doesn't solve the problem yet.
Finally I think that it would make sense if the bug importance was raised to a higher level upstream at KDE (comment #2 for this bug) and the ToDo.txt at KDE's SVN, where the bug isn't mentioned at all.

zdenek.zikan (zdenek-zikan) wrote :

I looked at KDE SVN and revision 966608 promises "Support connecting to hidden wireless networks". I haven't tested it yet because I don't have any hidden network but someone may give it a try. Kubuntu experimental PPA (http://ppa.launchpad.net/kubuntu-experimental/ubuntu) plasma-widget-network-manager has been updated to newer revision 966653 so you don't need to compile.

Michael Marley (mamarley) wrote :

I am using this package, and I have noticed the addition of a new button "Connect to hidden network." Looks like this bug is fixed.

Christiansen (happylinux) wrote :

I have tried to use plasma-widget-network-manager_0.0+svn966653-0ubuntu1~ppa1_i386.deb, with the new ability to connect to hidden networks, for a couple of days now.
For the Intel 2915ABG WiFI chipset, autoconnect after a reboot often seems to work, but takes up to one minute after the desktop is ready.

With Atheros 521x WiFi chipsets things seems worse. Using the 64 bit OS it can connect, but you have to enter the SSID after every reboot to connect to the hidden SSID network, filling your wireless connections in Network management with a new entry every time. On the 32 bit OS I've only managed to connect probably one time out of 20-30 times, and of course no autoconnect occurred at all.

On the atheros boxes, removing rev. 966653 and installing rev. 964432 (without the menu entry for hidden networks) and autoconnect works again on both 64 and 32 bit OS.

BTW Using nm-applet (from Ubuntu) on all the boxes still connect fast, easy and every time, but certainly doesn't integrate well with KDE (keyring vs. kwallet) and do not auto start on login.

zdenek.zikan (zdenek-zikan) wrote :

Autostart is not an issue, you can put it into KDE's startup directory. Just create a symlink to nm-applet in ~/.kde/Autostart/

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plasma-widget-network-manager - 0.0+svn966653-0ubuntu1

---------------
plasma-widget-network-manager (0.0+svn966653-0ubuntu1) karmic; urgency=low

  * New svn snapshot. (LP: #334052) (LP: #330811)
  * Manual update of kubuntu_01_place_kcm_in_network_kcm.diff

 -- Andreas Wenning <email address hidden> Fri, 15 May 2009 20:51:08 +0200

Changed in plasma-widget-network-manager (Ubuntu):
status: Triaged → Fix Released
Christiansen (happylinux) wrote :

This bug is marked fixed now !, so Kubuntu 9.04 should not work with Atheros 521x based WiFi chipsets, as Ubuntu does ?

Kenneth Perry (thothonegan) wrote :

From what I can tell, its fixed in karmic or by using kubuntu-experimental. However the version mentioned is not in any of the jaunty-* repositories.

What's the problem pushing it to jaunty-updates?

Changed in knetworkmanager:
status: Confirmed → Fix Released
Jonathan Riddell (jr) wrote :

Please test the package in jaunty-proposed and comment here 0.0+svn966653-0ubuntu0.1 so we can get it through to -updates.

I've installed plasma-widget-network-manager from jaunty-proposed.
Works fine in both auto-connect and reconnect (when you turn off wifi by button on your notebook, for example) cases.

TuxFan (make) wrote :

I didn't have much luck with 0.0+svn966653-0ubuntu0.1. After installing it from jaunty-proposed (with punch of other updated packages) I:

1. removed my hidden network from the settings (all the old settings was there from the old install)
2. used the "Connect to hidden network." to add my network to the settings

after that I could use my network, BUT after rebooting the plasma-widget-network-manager didn't connect to my network automaticly (yes I had that setting selected). When I checked the security settings, my network's password was missing... Putting the password there didn't help anything. I also rebooted few times, but no luck, so now I'm back with wicd which works perfectly.

In case it matters, I'm currently running KDE 4.2.3... (http://www.kubuntu.org/news/kde-4.2.3)

Toni Helenius (toni-helenius) wrote :

I tried it with Kubuntu Jaunty with latest OFFICIAL updates. I just installed the updated NM package from the Jaunty proposed.

BEFORE update:
 - Tested on non secured visible WLANs: works, reconnecting too
 - Hidden networks do NOT work
 - WLAN plasma menu cluttered and kicker panel plus other panels on NM overlaps WLAN panel occasionally (unusable at times)

AFTER update:
 - I was able to connect to a hidden secured network, and the password was saved
 - Reconnecting did NOT work on my hidden network
 - It was really hard to use at times, the WLAN menu was still cluttered
 - I didn't get the logic behind the "connect to hidden networks", using the same SSID it tried to add a new connection instead using the saved ones. And the plasma menu didn't always show the saved ones

Conclusion:
 - The update kinda works out this bug (connecting to a hidden network) BUT any chance to improve its usability and work out the other bugs?

Toni Helenius (toni-helenius) wrote :

More thoughts:
 - I was too hasty, reconnecting to hidden networks seems to work BUT ONLY when I have one visible network set to auto connect. The NM prioritizes the visible network but on failure may connect to the hidden one set as auto connect as well
- Plasma menu seems to list my WLANs only after I manage to connect to one but can use them to connect to existing saved networks now because of this
- The plasma menu doesn't resize itself and usually the "connect to hidden network" button as well as the bottom items in the WLAN menu are unaccessible!

The patch isn't ready yet... :(

Kent57 (kent5700) wrote :

Count me hasty too. I just had to revert to Wicd because I could not get plasma widget to connect to hidden network again. I had to replace a dead wireless router a simply could not get widget to auto connect with new router (configured the same as the old one).
I don't think this issue is resolved yet.

Martin Pitt (pitti) on 2009-06-19
tags: added: verification-needed
Changed in plasma-widget-network-manager (Ubuntu Jaunty):
status: New → Fix Committed
Changed in plasma-widget-network-manager (Ubuntu):
assignee: nobody → Andreas Wenning (andreas-wenning)
Changed in plasma-widget-network-manager (Ubuntu Jaunty):
assignee: nobody → Andreas Wenning (andreas-wenning)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plasma-widget-network-manager - 0.0+svn966653-0ubuntu0.1

---------------
plasma-widget-network-manager (0.0+svn966653-0ubuntu0.1) jaunty-proposed; urgency=low

  * New svn snapshot. (LP: #334052) (LP: #330811)
    - Updating to a new svn snapshot is the only approach feasible for this
      package due to the range of required changes
  * Manual update of kubuntu_01_place_kcm_in_network_kcm.diff

 -- Andreas Wenning <email address hidden> Fri, 15 May 2009 20:49:50 +0200

Changed in plasma-widget-network-manager (Ubuntu Jaunty):
status: Fix Committed → Fix Released

Verifying that the new release does now work for WPA1/TKIP hidden networks. I'll test others as I run across them.

For those who cannot get it to work, it may be worth noting that the fix did NOT work for me until I
1) went into the plasmoid's Manage Connections screen, on the Wireless tab, and deleted ALL instances of the hidden network,
2) disabled wireless,
3) logged out and back in, and finally
4) attempted to connect as normal (using the new "Connect to hidden network" button -- hooray!).

It's worked flawlessly since, and the negotiation speed seems to be just a tiny bit faster than before.

Alex Antão (alexcarlosantao) wrote :

How is the real status of this bug. I just reinstalled kubuntu in the laptop at home, and updated to the last repository (checked jaunty-backports and jaunty-proposed at sources editor).

Sent the laptop to home and it did not find my Hidden WPA/WPA2 network.
After I run the command iwlist wlan0 scan essid Mynetwork , it appears at the list (for alimited time) and does not auto-connect (it is checked).

It this fix at the last repository jaunty-proposed or do I have to add another on sources.list ?

The fix is in jaunty-updates. Also have a look at the previous comment by Scott about how to get it to work.

Rob M (dmrlook) wrote :

This bug does not appear to be completely fixed. I just installed 9.04 and have all the updated applied. I am able to connect to my secure network, however each time I reboot the machine, I need to go through the connect to hidden network process all over again (including typing in the WEB key). The Auto Connect option does not seem to work at all for me. What information can I provide or teest can I run to help debug this issue?

sebaestn (sebaestn) wrote :

I also encounter problems connecting my hidden WLAN again. As Rob M wrote I also have to reenter mit WPA key after every reboot. If I follow the instructios of Scott I also don't have success. Furthermore, I didn't change anything in my wireless network.

Now 0.0+svn966653-0ubuntu0.1 version is installed. As I wrote above, it worked with the version from the PPA (I think it was the 0.0+svn961724-0ubuntu1~ppa1). I browsed through the aptitude logs but couldn't figure out when my system updated to 966653. I have this trouble for some weeks now, so it might have been right after the 966653 version has been packaged and released to the jaunty-updates repository.

Rob M (dmrlook) wrote :

Not sure if it is OK for me to be changing the status of this issue, however as more than just I am still seeing this issue and we are up-to-date with fixes, it seems this issue has yet to be completely fixed. Is there anything I can do to help debug/fix?

Changed in plasma-widget-network-manager (Ubuntu):
status: Fix Released → Confirmed
Steve Langasek (vorlon) wrote :

Since you are reporting that the bug is still present in 9.04, reopening the jaunty task, not the devel release task.

Changed in plasma-widget-network-manager (Ubuntu Jaunty):
status: Fix Released → Incomplete
status: Incomplete → Confirmed
Changed in plasma-widget-network-manager (Ubuntu):
status: Confirmed → Fix Released
Changed in plasma-widget-network-manager (Ubuntu Jaunty):
assignee: Andreas Wenning (andreas-wenning) → nobody
tags: added: iso-testing
Changed in knetworkmanager:
importance: Unknown → Medium
Scott Kitterman (kitterman) wrote :

Jaunty is no longer supported and this is fixed in more recent releases.

Changed in plasma-widget-network-manager (Ubuntu Jaunty):
status: Confirmed → Won't Fix
elvin (elvin-r) wrote :

same thing on *Kubuntu Oneiric*

helped:
  sudo iwconfig wlan0 essid name_of_the_hidden_essid

and after some seconds it recognized my hidden network.

$ lsb_release -a
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric

$ uname -a
Linux ###### 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:25:36 UTC 2011 i686 i686 i386 GNU/Linux

Christiansen (happylinux) wrote :

Experiencing the same problem on Kubuntu 11.10, I've opened a new bug #893755 as it seems I can't mark this new.

Please see that bug for another workaround using a Precise pre-Alpha package. The package maybe won't be available and installable on 11.10 for long though, since it's a development version.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.