FTBFS: error: 'TaskManager::TaskPtr' has not been declared

Bug #908462 reported by Andreas Moog on 2011-12-24
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
plasma-widget-daisy (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

Tried rebuilding:

[ 42%] Building CXX object applet/CMakeFiles/plasma_applet_daisy.dir/src/daisy.o
cd /«PKGBUILDDIR»/obj-x86_64-linux-gnu/applet && /usr/bin/c++ -DMAKE_PLASMA_APPLET_DAISY_LIB -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -DQT_NO_STL -D
In file included from /«PKGBUILDDIR»/applet/src/daisy.cpp:29:0:
/«PKGBUILDDIR»/applet/src/daisy.h:105:20: error: 'TaskManager::TaskPtr' has not been declared
/«PKGBUILDDIR»/applet/src/daisy.h:106:20: error: 'TaskManager::StartupPtr' has not been declared
In file included from /«PKGBUILDDIR»/applet/src/daisy.cpp:29:0:
/«PKGBUILDDIR»/applet/src/daisy.h:340:31: error: 'TaskPtr' has not been declared
/«PKGBUILDDIR»/applet/src/daisy.h:421:5: error: 'TaskPtr' does not name a type
/«PKGBUILDDIR»/applet/src/daisy.h:515:23: error: 'StartupPtr' has not been declared
/«PKGBUILDDIR»/applet/src/daisy.h:516:25: error: 'StartupPtr' has not been declared
In file included from /«PKGBUILDDIR»/applet/src/daisy.cpp:33:0:
/«PKGBUILDDIR»/applet/src/daisyTasks.cpp:162:26: error: variable or field 'startupAdded' declared void
/«PKGBUILDDIR»/applet/src/daisyTasks.cpp:162:26: error: 'StartupPtr' was not declared in this scope
make[3]: *** [applet/CMakeFiles/plasma_applet_daisy.dir/src/daisy.o] Error 1
make[3]: Leaving directory `/«PKGBUILDDIR»/obj-x86_64-linux-gnu'
make[2]: *** [applet/CMakeFiles/plasma_applet_daisy.dir/all] Error 2
make[2]: Leaving directory `/«PKGBUILDDIR»/obj-x86_64-linux-gnu'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/«PKGBUILDDIR»/obj-x86_64-linux-gnu'
dh_auto_build: make -j1 returned exit code 2
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Andreas Moog (ampelbein) wrote :
tags: added: rls-mgr-p-tracking
Evan Peck (colors) wrote :

How to replicate?

The same problem emerges when trying to build plasma-widget-fancytasks, version 1.0.94-0ubuntu4.
Apprently has to be with libraries dependency. I'm using some 'unusual' repositories and this may break development dependencies.
I'm trying to figure out what is the exact dependency problem and fix it using the correct repositories.
I will keep all of you informed about my progress.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-widget-daisy (Ubuntu Precise):
status: New → Confirmed
Changed in plasma-widget-daisy (Ubuntu):
status: New → Confirmed
Evan Peck (colors) wrote :

Fix released. Thank you for reporting!

Changed in plasma-widget-daisy (Ubuntu):
status: Confirmed → Fix Released
Changed in plasma-widget-daisy (Ubuntu Precise):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers