19.04 OpenVPN plug-in not installed

Bug #1841767 reported by Ben Hamilton
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
plasma-nm (Ubuntu)
Undecided
Unassigned

Bug Description

On latest Kubuntu 19.10 build (dated 26/08/19), when adding new OpenVPN connections (from config files) in System Settings > Connections, am then unable to connect to these due to error 'Missing VPN Plugin' when trying to connect. This definitely does not happen on Kubuntu 19.04. So it is a new issue on this 19.10 build.

Manually installing the network-manager-ovpn package via CLI resolved the issue but this should not be necessary. the system should not present in-operable options to the user and then throw difficult and un-freidnly error messages. This feels like a bug/design fedect/oversight in this build.

Also raised as bug with KDE (https://bugs.kde.org/show_bug.cgi?id=411321) but they have closed this as 'not a bug'.

Thanks.

STEPS TO REPRODUCE
1. Open System Settings > Connections
2. Click the + sign to add a new connection
3. Scroll down to select last option "Import VPN connection
4. Import an OpenVPN config file
5. Try and connect to the VPN connection.

OBSERVED RESULT
Unable to connect to VPN, a network manager notification alerts pops up from the system tray saying 'Missing VPN Plug in'

EXPECTED RESULT
Successful connection to the VPN.

SOFTWARE/OS VERSIONS
Windows: N/A
macOS: N/A
Linux/KDE Plasma: Kubuntu 19.10, build dated 26/08/19
(available in About System)
KDE Plasma Version: Unknown
KDE Frameworks Version: Unknown
Qt Version: Unknown

tag:
"Brakuje wtyczki VPN"
dependency:
network-manager-openvpn

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-nm (Ubuntu):
status: New → Confirmed
Tomasz Makara (csowiec)
description: updated
Tomasz Makara (csowiec)
description: updated
Revision history for this message
Bohdan Liakhovetskyi (gaponec) wrote :

Sovled this issue by installing network-manager-openvpn-gnome

Revision history for this message
Justin (metal450) wrote :

This bug is still there in 20.04.

Revision history for this message
Timur Tabi (timur-tabi) wrote :

Installing network-manager-openvpn-gnome didn't help me in Kubuntu 20.04. Is there another fix?

Revision history for this message
Krasi (krasi-georgiev) wrote :

solved by

apt install network-manager-openvpn-gnome

Revision history for this message
Fazylzhan (zfazylz) wrote :

installing network-manager-openvpn-gnome not helping on Kubuntu 20.04.
In Ubuntu 20.04 works perfect, without any installations

Revision history for this message
jjyxcweo (jnczhxoq) wrote :

This bug is caused because network-manager-openvpn is not installed by default for some reason to fix this just do apt install network-manager-openvpn

Revision history for this message
Ben Hamilton (exharris) wrote : Re: [Bug 1841767] Re: 19.04 OpenVPN plug-in not installed

Core functionality which is presented in the GUI as being operational should be operational, and not require CLI use to activate.

It is absolutely a but.

This kind of mindset is why Linux on the desktop will never ever really take off.

Sent with ProtonMail Secure Email.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Saturday, 21 November 2020 07:58, jjyxcweo <email address hidden> wrote:

> This bug is caused because network-manager-openvpn is not installed by
> default for some reason to fix this just do apt install network-manager-
> openvpn
>
> --------------------------------------------------------------------------------------------------------------------------------------------------------
>
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1841767
>
> Title:
> 19.04 OpenVPN plug-in not installed
>
> Status in plasma-nm package in Ubuntu:
> Confirmed
>
> Bug description:
> On latest Kubuntu 19.10 build (dated 26/08/19), when adding new
> OpenVPN connections (from config files) in System Settings >
> Connections, am then unable to connect to these due to error 'Missing
> VPN Plugin' when trying to connect. This definitely does not happen on
> Kubuntu 19.04. So it is a new issue on this 19.10 build.
>
> Manually installing the network-manager-ovpn package via CLI resolved
> the issue but this should not be necessary. the system should not
> present in-operable options to the user and then throw difficult and
> un-freidnly error messages. This feels like a bug/design
> fedect/oversight in this build.
>
> Also raised as bug with KDE
> (https://bugs.kde.org/show_bug.cgi?id=411321) but they have closed
> this as 'not a bug'.
>
> Thanks.
>
> STEPS TO REPRODUCE
>
> 1. Open System Settings > Connections
>
> 2. Click the + sign to add a new connection
>
> 3. Scroll down to select last option "Import VPN connection
>
> 4. Import an OpenVPN config file
>
> 5. Try and connect to the VPN connection.
>
> OBSERVED RESULT
> Unable to connect to VPN, a network manager notification alerts pops up from the system tray saying 'Missing VPN Plug in'
>
> EXPECTED RESULT
> Successful connection to the VPN.
>
> SOFTWARE/OS VERSIONS
> Windows: N/A
> macOS: N/A
> Linux/KDE Plasma: Kubuntu 19.10, build dated 26/08/19
> (available in About System)
> KDE Plasma Version: Unknown
> KDE Frameworks Version: Unknown
> Qt Version: Unknown
>
> tag:
> "Brakuje wtyczki VPN"
> dependency:
> network-manager-openvpn
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/plasma-nm/+bug/1841767/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.