Can only connect once to wireless network

Bug #1509140 reported by Chris Vanden Berghe on 2015-10-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
plasma-nm (Ubuntu)
High
Unassigned

Bug Description

After upgrading from 15.04 to 15.10 plasma-nm no longer autoconnects to existing networks. In fact, even clicking on 'connect' in network manager yields no result. The only way to join a network is to remove the existing network and readd it. On adding it will connect to the network. Every subsequent connection attempt requires the same steps (remove network and readd). In 'Configure network connections' I'm not able to edit existing networks. The window abruptly closes when I do that.

Everything worked just fine under 15.04 although I did initially have an issue on upgrade from 14.10 to 15.04 in which I had to edit existing wireless networks to enable autoconnect (something along the lines of allow/enable connection for all users). I only had to this once for each existing network, though.

tags: added: kubuntu wily
Jean Visser (jean-visser) wrote :

I can confirm the exact same experience.

I've been unable to spot any useful log entries either.

Soeren (soeren-h-g) wrote :

I am also not able to connect via wlan after upgrading from Kubuntu 15.04 to 15.10. Removing access point and adding it again helps but only until restart or suspend.
Really annoying bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-nm (Ubuntu):
status: New → Confirmed

I have exact the same problem.

Chris Vanden Berghe (chrisvdb) wrote :

I have created a KDE bug report: https://bugs.kde.org/show_bug.cgi?id=355067

Chris Vanden Berghe (chrisvdb) wrote :

The upstream developer has requested some additional information through the KDE bug report (linked above). Please help provide the information if you can, I'll try to do the same but it might take me a few days.

https://techbase.kde.org/Projects/Solid/Plasma-nm#My_connection_in_the_applet_shows_wrong_information
https://techbase.kde.org/Projects/Solid/Plasma-nm#Plasma-nm_fails_to_activate_my_connection

Soeren (soeren-h-g) wrote :

Hi Chris.,

I added the logs to the KDE bug report. Hope they contain all needed information.

Chris Vanden Berghe (chrisvdb) wrote :

Thanks, Soeren! I will monitor the KDE bug report and add logs if required.

Chris Vanden Berghe (chrisvdb) wrote :

Restarting KDED improved the situation for me (see KDE bug report). Can the rest of the affected people give this a try as well?

I haven't checked if the issue reappears after a reboot or looked into what causes KDED/Secret Agent to misbehave in the first place.

Chris Vanden Berghe (chrisvdb) wrote :

Ok, I can confirmed that the issue is solved for me now. The issue was related to KWallet/Secret Agent not running. By restarting KDED things magically started working.

I *think* the root cause might be that I was using Kubuntu Updates (initially) and Kubuntu CI Stable (later on) PPAs on Vivid. All PPAs got automatically disabled on upgrade to Willy but did leave some files lingering (as they are at higher version than Willy).

I did the following steps (not all might be necessary):

- opened KWallet, created a new wallet and removed old one
- restarted KDED, added new wifi connection, disconnected from wifi, reconnected successfully (but connection editor still crashes on edit)
- used ppa-purge to downgrade all packages from above mentioned PPAs (need to readd PPAs first), used accepted answer on http://askubuntu.com/questions/363653/remove-all-packages-installed-from-a-ppa as guide
- confirmed that connection editor no longer crashes
- rebooted, wifi automatically connected, connection editor is working, KWallet shows connection I created

Chris Vanden Berghe (chrisvdb) wrote :

Can the other people affected by this issue confirm if this solution works for them so I can close the bug report?

Deinstalling libkf5networkmanagerqt6 packages and reinstalling with all dependencies from Kubuntu 15.10 solved the problem for me as well.

Changed in plasma-nm (Ubuntu):
importance: Undecided → High
Chris Vanden Berghe (chrisvdb) wrote :

Marked this bug as fixed as the solution described in the report seems to fix the issue for multiple people.

Changed in plasma-nm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.