Ubuntu

crash on upgrade from networkmanagement to plasma-nm

Reported by Jonathan Riddell on 2013-09-26
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
plasma-nm (Ubuntu)
Undecided
Unassigned

Bug Description

crash in kded on upgrade from kubuntu 13.04 to 13.10 when connecting to a network after the upgrade

https://bugs.kde.org/show_bug.cgi?id=325324

Jonathan Riddell (jr) on 2013-09-26
Changed in plasma-nm (Ubuntu):
milestone: none → ubuntu-13.10
tags: added: kubuntu
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1231360

tags: added: iso-testing
Jonathan Riddell (jr) wrote :

--- Comment #1 from Jan Grulich <email address hidden> ---
It crashes in the old networkmanagement applet, not in plasma-nm (the new one).
Probably there is still running the old kded modul. The script won't be
necessary for the upcoming plasma-nm version, because we renamed it so upgrade
will be much easier.

Something not being removed

Harald Sitter (apachelogger) wrote :

If it is the kded module this is non-trivial, as we'd need an upgrade script that uses dbus to unload the old module and then loads the new one (although I think it would be loaded on-demand regardless).

Jonathan Riddell (jr) wrote :

plasma-nm 0.9.3.1 is out which renames the kded module and plasmoid to match the old networkmanagement

An SRU to this would be nice but it would need a plasma script to fix the change of name

Corrado Mella (c-mella) wrote :

So, in a nutshell, is this bug fixed in 13.10 or not?
What happens if we upgrade?
Can we upgrade or should we hold back until this showstopper is fixed?
Answers please.

Changed in plasma-nm (Ubuntu):
milestone: ubuntu-13.10 → saucy-updates
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-nm (Ubuntu):
status: New → Confirmed
Gérard Talbot (info-gtalbot) wrote :

Hello,

I filed
Bug 327543: No longer can restart, reboot or log off via applications kickoff launcher
https://bugs.kde.org/show_bug.cgi?id=327543

Please let me know if you want/need more info which can help resolve this issue.

Gérard

Joseph Davis (cwmj601) wrote :

I just did a fresh install of 13.10, both i386 and 64 versions, I run the updater right after installation, because that's _the_ most important feature of any OS TO ME. In both cases I get a crash of the application.

I will assume others have reported this, if anyone wants to know my specific hardware, I'll dig it up. I know the system is an MSI mobo with built in dual core amd E-350D I think.

Love Kubuntu, but this is frustrating.

regards - Joseph

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.