empty plasmoid on default active workspace

Bug #1046437 reported by Jonathan Riddell on 2012-09-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plasma-mobile (Ubuntu)
Low
Harald Sitter
Quantal
Low
Harald Sitter
Raring
Low
Harald Sitter

Bug Description

To resolve this issue a patch was added as explained in bug #1068212 which breaks compatibility and therefore needs to be reverted and a new solution is required to resolve the issue at hand.

The Plasmoid org.kde.news-qml is part of a whole upstream source called declarative-plasmoids. Unfortunately this was not packaged for quantal so we believe the appropriate course of action is to simply include the source into plasma-mobile and the plasma-active binary. This way we can provide these plasmoids specifically made for Plasma Active.

[Test Case]
* grep -r PluginInfo-Name /usr/share/kde4/services/plasma-applet-news-qml.desktop

[Regression Potential]
Since the declarative-plasmoids did not undergo regular pre-release testing we cannot assure their quality. However since the plasma-active environment is considered a tech preview in Kubuntu this should not proof a particular problem.

---------------

empty plasmoid on bootup of kubuntu active:
could not find requested component: org.kde.news-qml
also share-like-connect on panel

Jonathan Riddell (jr) on 2012-09-05
tags: added: kubuntu
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1046437

tags: added: iso-testing
Changed in plasma-mobile (Ubuntu Quantal):
milestone: none → ubuntu-12.10-beta-2
Jonathan Riddell (jr) on 2012-09-10
Changed in plasma-mobile (Ubuntu Quantal):
importance: Undecided → Low
Changed in plasma-mobile (Ubuntu Quantal):
milestone: ubuntu-12.10-beta-2 → none
Jonathan Riddell (jr) on 2012-10-16
Changed in plasma-mobile (Ubuntu Quantal):
status: New → Fix Released
Harald Sitter (apachelogger) wrote :

Resolution for Raring needs to be the introduction of delcarative-plasmoids.

description: updated
Changed in plasma-mobile (Ubuntu Quantal):
status: Fix Released → Triaged
assignee: nobody → Harald Sitter (apachelogger)
Changed in plasma-mobile (Ubuntu Raring):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Harald Sitter (apachelogger)
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in plasma-mobile (Ubuntu Quantal):
status: Triaged → Won't Fix
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in plasma-mobile (Ubuntu Raring):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers