Plaese remove from Eoan: plasma-mediacenter: build-depends on obsolete libkfilemetadata-dev

Bug #1841097 reported by Steve Langasek
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plasma-mediacenter (Ubuntu)
High
Rik Mills

Bug Description

kfilemetadata has been removed from Debian unstable. The only reverse-dependency in Ubuntu which prevents its removal is plasma-mediacenter, which has a build-dependency on libkfilemetadata-dev.

Either plasma-mediacenter should be updated to not build-depend on kfilemetadata, or plasma-mediacenter should be removed, or someone should take ownership of kfilemetadata in Ubuntu if it's still needed by uploading it with a changed maintainer field.

If there is no action on this bug by the eoan release, I will opt to remove kfilemetadata from eoan and leave plasma-mediacenter unbuildable - since it's a build-dependency but not a runtime dependency, I suspect that the build-dep is spurious and can easily be dropped when someone cares.

Revision history for this message
Steve Langasek (vorlon) wrote :

Assigning to Rik, as the uploader of the only 2 uploads of this package in the past 3 years

Changed in plasma-mediacenter (Ubuntu):
importance: Undecided → High
assignee: nobody → Rik Mills (rikmills)
Revision history for this message
Rik Mills (rikmills) wrote :

This package is dead upstream. Last released in 2016 on a plasma 5.7 branch, where we are now up to Plasma 5.16.

There are a few 'fixit' commit in upstream git by well intentioned non maintainers, but this thing is never going see a new release.

summary: - plasma-mediacenter: build-depends on obsolete libkfilemetadata-dev
+ Plaese remove from Eoan: plasma-mediacenter: build-depends on obsolete
+ libkfilemetadata-dev
Revision history for this message
Rik Mills (rikmills) wrote :

So this can and should be removed in preference to trying to fix.

Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from eoan:
 plasma-mediacenter 4:5.7.5-0ubuntu2 in eoan
  plasma-mediacenter 4:5.7.5-0ubuntu2 in eoan amd64
  plasma-mediacenter 4:5.7.5-0ubuntu2 in eoan arm64
  plasma-mediacenter 4:5.7.5-0ubuntu2 in eoan armhf
  plasma-mediacenter 4:5.7.5-0ubuntu2 in eoan i386
  plasma-mediacenter 4:5.7.5-0ubuntu2 in eoan ppc64el
  plasma-mediacenter 4:5.7.5-0ubuntu2 in eoan s390x
  plasma-mediacenter-dbg 4:5.7.5-0ubuntu2 in eoan amd64
  plasma-mediacenter-dbg 4:5.7.5-0ubuntu2 in eoan arm64
  plasma-mediacenter-dbg 4:5.7.5-0ubuntu2 in eoan armhf
  plasma-mediacenter-dbg 4:5.7.5-0ubuntu2 in eoan i386
  plasma-mediacenter-dbg 4:5.7.5-0ubuntu2 in eoan ppc64el
  plasma-mediacenter-dbg 4:5.7.5-0ubuntu2 in eoan s390x
Comment: Dead upstream, depends on obsolete qt4 and libkfilemetadata-dev; LP: #1841097
1 package successfully removed.

Changed in plasma-mediacenter (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers