[FFe] KDE Frameworks 5.62.0 into Eoan archive

Bug #1843866 reported by Rik Mills
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plasma-framework (Ubuntu)
Undecided
Unassigned

Bug Description

This bug report is a Feature Freeze Exception request on behalf of the Kubuntu team for KDE Frameworks 5.62.0 (updated from 5.61.0).

https://www.kde.org/announcements/kde-frameworks-5.62.0.php

As is usual with a KDE Frameworks release, this is a mixture of new some new features and incremental important bugfixes.

I would also note that while Plasma 5.17 will not be released in time to ship in Eoan, Frameworks 5.62 will be its minimum version dependency. Having 5.62 already available in Eoan will make the task of offering optional backports to Eoan post release MUCH easier.

We currently have this staged in ppa:kubuntu-ppa/staging-frameworks if you wish to inspect the packages.

We have also run autotests for amd64 and i386, which as far as we can test considering test infra differences seem ok, or at least do not cause additional regressions. However, should issues occur on those or other architectures, we commit to fixing those issues for release.

We also have testers that have been running a system with this staged update and have reported no problems.

The following packages form the KDE Frameworks set:

attica-kf5
baloo-kf5
bluez-qt
breeze-icons
extra-cmake-modules
frameworkintegration
kactivities-kf5
kactivities-stats
kapidox
karchive
kauth
kbookmarks
kcmutils
kcodecs
kcompletion
kconfig
kconfigwidgets
kcoreaddons
kcrash
kdbusaddons
kdeclarative
kded
kdelibs4support
kdesignerplugin
kdesu
kdewebkit
kdnssd-kf5
kdoctools
kemoticons
kfilemetadata-kf5
kglobalaccel
kguiaddons
kholidays
khtml
ki18n
kiconthemes
kidletime
kimageformats
kinit
kio
kirigami2
kitemmodels
kitemviews
kjobwidgets
kjs
kjsembed
kmediaplayer
knewstuff
knotifications
knotifyconfig
kpackage
kparts
kpeople
kplotting
kpty
kross
krunner
kservice
ksyntax-highlighting
ktexteditor
ktextwidgets
kunitconversion
kwallet-kf5
kwayland
kwidgetsaddons
kwindowsystem
kxmlgui
kxmlrpcclient
modemmanager-qt
networkmanager-qt
oxygen-icons5
plasma-framework
prison-kf5
purpose
qqc2-desktop-style
solid
sonnet
threadweaver

Rik Mills (rikmills)
description: updated
Revision history for this message
Michael Marley (mamarley) wrote :

I've been running this on several computers for daily use ever since Rik uploaded it and haven't had any issues.

Revision history for this message
Rik Mills (rikmills) wrote :
Revision history for this message
Rik Mills (rikmills) wrote :

Under Kubuntu packageset FFe delegated authority

https://wiki.ubuntu.com/FreezeExceptionProcess#Packageset_FFe_Delegations

I ack/approve this FFe.

Revision history for this message
Simon Quigley (tsimonq2) wrote :

ACK, using the aforementioned FFe packageset delegation.

Revision history for this message
Darin Miller (darinmiller) wrote :

5.62 is also running well on disco desktop and eaon laptop.

Revision history for this message
Darin Miller (darinmiller) wrote :

On another note, 5.62 seems to have fixed this alt-tab bug: https://bugs.kde.org/show_bug.cgi?id=406180.

This is great news!

Revision history for this message
Darin Miller (darinmiller) wrote :

NM, the alt-tab bug is still present. On fresh boot it works fine, but let the system sit for a few minutes and the bug remains.... sigh...

Rik Mills (rikmills)
Changed in plasma-framework (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.