Live session desktop uses too small folder view widget

Bug #1560404 reported by Marcin Sągol on 2016-03-22
72
This bug affects 16 people
Affects Status Importance Assigned to Milestone
plasma-framework (Ubuntu)
High
Unassigned
Xenial
High
Philip Muškovac

Bug Description

[Impact]
Thanks to bad event timing during the size calculation the folderview widget has a very small size when added to the desktop instead of the recommended size. This makes it unusable unless you manually resize it.
We use the folderview widget to display the installer icon on the live image, which makes the installer almost invisible as you can see on the screenshot.

[Test Case]
This can be tested on any installed system and doesn't require an updated image.
- Try adding a folderview widget to your desktop by right clicking on the desktop -> Add Widgets -> select Folder View from the list.
- it will have a very small size and usually show part of an icon (see attached screenshot)
- install libkf5plasma5 and libkf5plasmaquick5 from proposed
- restart plasma using Alt+F2 and running 'kquitapp plasmashell; plasmashell'
or by restarting your login session.
- Try adding a folderview widget again using above steps
- it should now be large enough to show 2 rows, 3 columns of icons.

[Regression potential]
The patch has been recommended by upstream, has not caused any direct regressions and no misbehaving widgets have been found by just adding this patch.

[Original Description]
Description: Ubutnu Xenial Xerus (development branch)
Release: 16.04

kubuntu-settings-desktop
Installed: 1:16.04ubuntu2
Candidate: 1:16.04ubuntu2

I we run live session either from USB or in virtual machine then the default Folder View widget with installation icon inside is rendered in small size, making the mentioned icon almost invisible (see attached screenshot). This widget size should be changed to make the whole icon inside visible.

Marcin Sągol (soee) wrote :
description: updated
description: updated
Philip Muškovac (yofel) on 2016-03-22
Changed in kubuntu-settings (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-16.04
status: New → Triaged
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1560404

tags: added: iso-testing
flamboyant (flamboyant) wrote :

if i add a Folder View widget to the desktop in an installed Kubuntu, it has the same small size. i don't know what defines the default size of a new Folder View widget, whether it's a config parameter or a line of code, but i guess that's where the root cause of the problem is.

Philip Muškovac (yofel) wrote :

Ok, after looking into this I was pointed to http://bugs.kde.org/358039 and after a quick test http://commits.kde.org/plasma-framework/11937533e83659dc4dab6f7e8e6019863a28ddae does seem to fix this. I'll try to get the SRU done ASAP.

affects: kubuntu-settings (Ubuntu) → plasma-framework (Ubuntu)
Changed in plasma-framework (Ubuntu):
milestone: ubuntu-16.04 → none
status: Triaged → Fix Released
Changed in plasma-framework (Ubuntu Xenial):
importance: Undecided → High
status: New → Triaged
milestone: none → ubuntu-16.04.1
Philip Muškovac (yofel) wrote :

Yakkety has 5.22 so it's already fixed there.

Changed in plasma-framework (Ubuntu Xenial):
assignee: nobody → Philip Muškovac (yofel)
Philip Muškovac (yofel) on 2016-07-06
description: updated
Philip Muškovac (yofel) on 2016-07-08
summary: - Live session desktop uses to small folder view widget
+ Live session desktop uses too small folder view widget

Hello Marcin, or anyone else affected,

Accepted plasma-framework into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/plasma-framework/5.18.0-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in plasma-framework (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed
Rik Mills (rikmills) wrote :

I can confirm that testing with package versions 5.18.0-0ubuntu1.1 fixes this issue in a clean and up to date Xenial install.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plasma-framework - 5.18.0-0ubuntu1.1

---------------
plasma-framework (5.18.0-0ubuntu1.1) xenial; urgency=medium

  * Update the Vcs URLs now that the repositories are hosted on
    Launchpad
  * Add upstream_Ignore-check-if-just-one-part-of-size-is-zero-in-com.diff
    to fix the initial size of plasma widgets. (LP: #1560404)

 -- Philip Muškovac <email address hidden> Fri, 06 May 2016 12:52:04 +0200

Changed in plasma-framework (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for plasma-framework has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers