Plasma Discover does not start because of missing QtQuick.Controls

Bug #1788863 reported by Norbert on 2018-08-24
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
plasma-discover (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Have Ubuntu 18.04 LTS (MATE in my case)
2. Install Plasma Discover with

    sudo apt-get install plasma-discover \
    plasma-discover-flatpak-backend plasma-discover-snap-backend

3. Try to launch Plasma Discover from GUI.

Expected results:
* Plasma Discover starts and works normally

Actual results:
* Plasma Discover does not start, when opened from terminal shows errors:

$ plasma-discover
QQmlApplicationEngine failed to load component
qrc:/qml/DiscoverWindow.qml:3 module "QtQuick.Controls" is not installed

Errors when loading the GUI
no packages for "org.gnome.DiskUtility"
no packages for "org.mate-desktop.mate-eiciel"
no packages for "org.gnome.DejaDup"
empty appstream db
setting currentApplicationBackend PackageKitBackend(0x557c7d4a1c00)

Probably some dependencies are missed.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: plasma-discover 5.12.6-0ubuntu0.1
ProcVersionSignature: Ubuntu 4.15.0-33.36-generic 4.15.18
Uname: Linux 4.15.0-33-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: MATE
Date: Fri Aug 24 16:13:53 2018
InstallationDate: Installed on 2018-04-26 (119 days ago)
InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
SourcePackage: plasma-discover
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) wrote :

Problem may be temporarily fixed by the solution from https://askubuntu.com/a/1068567/66509 :

sudo apt-get install qml-module-qtquick-controls

Norbert (nrbrtx) wrote :

Installation of

    sudo apt-get install qml-module-qtquick-dialogs

is needed too.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-discover (Ubuntu):
status: New → Confirmed
Histesh Shah (chimak111) wrote :

I can confirm the same additional packages are needed to have Plasma Discover working on Lubuntu 18.04.

Rik Mills (rikmills) on 2018-08-25
Changed in plasma-discover (Ubuntu Cosmic):
status: Confirmed → Fix Committed
Changed in plasma-discover (Ubuntu Bionic):
status: New → Confirmed
Rik Mills (rikmills) wrote :

Fix pushed to Cosmic 18.10.

For Bionic 18.04, this will be fixed in either a stand-alone stable release update to 5.12.6, or at the latest with the plasma 5.12.7 update due in Sept.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plasma-discover - 5.13.4-0ubuntu3

---------------
plasma-discover (5.13.4-0ubuntu3) cosmic; urgency=medium

  * Cherry pick debian changes adding missing runtime qml module
    dependencies. (LP: #1788863)

 -- Rik Mills <email address hidden> Sat, 25 Aug 2018 12:43:21 +0100

Changed in plasma-discover (Ubuntu Cosmic):
status: Fix Committed → Fix Released

Hello Norbert, or anyone else affected,

Accepted plasma-discover into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/plasma-discover/5.12.7-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in plasma-discover (Ubuntu Bionic):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-bionic
Norbert (nrbrtx) wrote :

Seems to be fixed on my Ubuntu MATE 18.04 LTS with packages from -proposed.
APT, Snap and FlatPak functionality is OK.

Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers