plasma-discover-flatpak-backend should add flathub repo during installation

Bug #1737645 reported by Nate Graham
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
plasma-discover (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

The plasma-discover-flatpak-backend package isn't very useful without any repos configured. Right now, Flathub is the only really useful one, so I think it makes sense to add it when the package is installed, to save the user (who is probably non-technical if they want to use the Flatpak backend) from having to figure out that they have to add a Flatpak repo, what one would be, how to do it, etc.

I recommended doing this automatically for all distros in https://bugs.kde.org/show_bug.cgi?id=387718, but Discover's author and maintainer advised that this is a distro packager's decision. So here I am, asking Kubuntu's plasma-discover packagers to automatically add the Flathub repo (https://flathub.org/repo/flathub.flatpakrepo) when plasma-discover-flatpak-backend is installed. :)

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-discover (Ubuntu):
status: New → Confirmed
Revision history for this message
Valorie Zimmerman (valorie-zimmerman) wrote :

I am the non-technical user who tried to install a flatpak package and had it fail, and didn't know why. I assume this is the reason, so +1 from me on fixing it!

Revision history for this message
Kenneth Groves (mars-pc69) wrote :

I added flatpack to plasma-discover and it bricked discover completely.

Revision history for this message
Nate Graham (pointedstick) wrote :

Then I assume you filed a bug report on bugs.kde.org so we can find out what went wrong and fix it, right? ;)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers