plasma-discover crashed with SIGSEGV in QQuickScrollBarAttached::qt_metacall()

Bug #1674760 reported by Ovidiu-Florin BOGDAN on 2017-03-21
120
This bug affects 27 people
Affects Status Importance Assigned to Milestone
plasma-discover (Fedora)
Won't Fix
Undecided
plasma-discover (Ubuntu)
Medium
Unassigned

Bug Description

freezes every time after installing updates. Cannot be closed, unless forced.

ProblemType: Crash
DistroRelease: Ubuntu 17.04
Package: plasma-discover 5.9.3-0ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-13.15-generic 4.10.1
Uname: Linux 4.10.0-13-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.4-0ubuntu2
Architecture: amd64
CrashCounter: 1
CurrentDesktop: KDE
Date: Tue Mar 21 18:52:32 2017
ExecutablePath: /usr/bin/plasma-discover
InstallationDate: Installed on 2017-02-23 (26 days ago)
InstallationMedia: Kubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.1)
ProcCmdline: /usr/bin/plasma-discover --mode update
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=ro_RO.UTF-8
 SHELL=/usr/bin/zsh
 LANGUAGE=
Signal: 11
SourcePackage: plasma-discover
StacktraceTop:
 QObject::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
 QQuickScrollBarAttached::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5QuickTemplates2.so.5
 ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
 QV4::QObjectWrapper::getProperty(QV4::ExecutionEngine*, QObject*, QQmlPropertyData*, bool) () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
 QV4::QObjectWrapper::getQmlProperty(QQmlContextData*, QV4::String*, QV4::QObjectWrapper::RevisionMode, bool*, bool) const () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
Title: plasma-discover crashed with SIGSEGV in QObject::qt_metacall()
UpgradeStatus: Upgraded to zesty on 2017-02-27 (22 days ago)
UserGroups: adm cdrom dialout dip docker lpadmin plugdev sambashare sudo
XsessionErrors:
 (firefox:5258): Gtk-WARNING **: Error loading theme icon 'network-idle' for stock: Icon 'network-idle' not present in theme breeze
 (firefox:31478): Gtk-WARNING **: Error loading theme icon 'network-idle' for stock: Icon 'network-idle' not present in theme breeze

information type: Private → Public

StacktraceTop:
 ?? ()
 ?? ()
 QQuickScrollBarAttached::qt_metacall (this=0x564bfec814e0, _c=QMetaObject::WriteProperty, _id=<optimized out>, _a=0x7fffda9a8090) at .moc/moc_qquickscrollbar_p.cpp:446
 Direct (property=..., n=0x0, output=0x7fffda9a8070, object=0x564bfec814e0) at jsruntime/qv4qobjectwrapper.cpp:135
 LoadProperty<ReadAccessor::Direct> (v4=0x564bfe874b70, object=0x564bfec814e0, property=..., notifier=0x0) at jsruntime/qv4qobjectwrapper.cpp:160

Changed in plasma-discover (Ubuntu):
importance: Undecided → Medium
summary: - plasma-discover crashed with SIGSEGV in QObject::qt_metacall()
+ plasma-discover crashed with SIGSEGV in
+ QQuickScrollBarAttached::qt_metacall()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-discover (Ubuntu):
status: New → Confirmed
Rik Mills (rikmills) on 2017-04-03
Changed in plasma-discover (Ubuntu):
milestone: none → ubuntu-17.04
tags: added: kubuntu
Peter Hewett (peter-hewett) wrote :

plasma-discover crashes every time I try to close it.
This is a fresh install of Kubuntu 17.04 64 bit in a virtualbox.

steve77 (funmaker-11) wrote :

Have you solved this yet because I have seen it several times. I think it may have messed up my shiny new Kubuntu 17.04 system.

Michael MacEachern (maceach-b) wrote :

Just installed on a new system, and like everyone else is saying, it crashes..

Do we plan on fixing this one? Because it's a pretty big show stopper, especially when you then can't open up anything, everything just starts quitting on you.

Daniel Eckl (daniel-eckl) wrote :

It's still the same with using Kubuntu Backports which gives you Plasma 5.4.10, Frameworks 5.36 and QT 5.7.1

bt full 30 is here https://pastebin.com/fyAcaE1d

Oliver Urs Lenz (oulenz) wrote :

I can confirm that Discover has (nearly) always crashed for me upon closing. Kubuntu 17.04.

Raúl Vidal (raulvior-bcn) wrote :

I also confirm this bug. I am affected by it. But not only does Plasma Discover crash upon closing.
SMPlayer also crashes.
I am running Kubuntu 17.04 with the backported packages.

anuszka (ochab) wrote :

Confirmed! plasma-discover crashes upon closing.
Kubuntu 17.04
KDE Plasma Version: 5.9.5

Changed in plasma-discover (Fedora):
importance: Unknown → Undecided
status: Unknown → Confirmed
Changed in plasma-discover (Fedora):
status: Confirmed → Won't Fix
Kenneth Groves (mars-pc69) wrote :

I added flatpak, added a couple of apps and now, no apps, no discover. Discover won't open but shows the update icon but won't open updater. Discover also won't open at all from icon or usr/bin/plams-discover. Synaptic still works, stills shows plasma-discover in list. Can find Plasma-discover in usr/bin but not the apps anywhere. Tried reinstalling, no change. Ultimate Edition 5.7 x64. KDE Plasma Version 5.10.5, KDE Frameworks 5.38.0, QT 5.9.1, Kernal 4.13.0-46. Everything else works fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.