Desktop icons can be incorrected placed on the Desktop at login

Bug #1806224 reported by Gordon Lack on 2018-12-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plasma-desktop (Ubuntu)
Undecided
Unassigned

Bug Description

I have my Desktop Folder settings as:

Layout: Folder View
Location: Show the Desktop folder

The icons are arranged how I want them and locked in place (a 3x8 array).

When I login the icons can be wrongly arranged. This does not happen every time, but does seem more likely to occur if I login immediately after a reboot rather than waiting for several minutes.

The mis-placemment, when it occurs, does seem to be consistent (i.e. the wrong arrangement is always the same wrong arrangement). [I have been unable to work out what that arrangement is. It is not date-time stamps on files, directory order or size)

As a work-around I have made .config/plasma-org.kde.plasma.desktop-appletsrc read-only, to prevent this wrong-arrangement being written to it and becoming persistent. This works, to the extent that if I log in an the arrangement is wrong I can logout, log straight back in and the arragement will then be as I desire.
This is inconvenient if I ever wish to change anything else configured in that file, though...

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: plasma-desktop 4:5.13.5-1ubuntu4
ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
Uname: Linux 4.18.0-11-generic x86_64
ApportVersion: 2.20.10-0ubuntu13.1
Architecture: amd64
CurrentDesktop: KDE
Date: Sun Dec 2 02:07:21 2018
InstallationDate: Installed on 2018-05-09 (206 days ago)
InstallationMedia: Kubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
SourcePackage: plasma-desktop
UpgradeStatus: Upgraded to cosmic on 2018-10-26 (36 days ago)

Gordon Lack (gordon-lack) wrote :
Gordon Lack (gordon-lack) wrote :

This seems to be a timing issue.

I've only ever seen this on my desktop system, which had HDDs. On my laptop (with SSDs) it didn't happen, even though the desktop set-up was essentially the same.

And a few weeks ago I switched my desktop system over to SSDs. The problem no longer shows up there.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers