Plasma session does not start after upgrading Kubuntu

Bug #1523070 reported by doniks on 2015-12-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
plasma-desktop (Ubuntu)
Undecided
Unassigned

Bug Description

I just upgraded to Kubuntu 15.04. There were no problems during the upgrade itself. After the reboot I see the new login screen (sddm, used to be lightdm before the upgrade).

I can enter my password but then nothing visibly changes. The screen still shows the login screen, but nothing can be clicked. On some occasions there is one change: the mouse cursor changes to an X.

I can go to Ctrl-Alt-F1 and login ok.

I have removed some old user configurations:
mv ~/.kde dot.kde.old
mv ~/.config dot.config.old
rm -rf ~/.cache
then rebooted and tried again, but the result is the same

I have switched back to lightdm:
dpkg-reconfigure lightdm
then
service sddm stop
service lightdm start
but the behaviour in lightdm is basically the same. I can enter the password then only the lightdm background is visible anymore and nothing furhter happens

What I see now is that after sddm or lightdm are in this post-password-nothing-happens-anymore state, I can go to Ctrl-Alt-F1 and do:
export DISPLAY=:0
xlogo
back to Ctrl-Alt-F7
and the logo shows ok.

In fact, it seems I can even do
startkde
and the session comes up ok and now everything appers to be running fine. Hey I can even open a browser and report a bug!

doniks (kaabud-lp) on 2015-12-05
summary: - Plasma session does not start after upgrade to Kubuntu 15.10
+ Plasma session does not start after upgrade to Kubuntu 15.04
description: updated

Today, I couldn't manage to log in at all, also not with the Ctrl-Alt-F1 startkde workaround, I tried a view things, an older kernel that was installed, but that didn't help. What finally worked was to use the "(upstart)" version of the current linux kernel available via grub. This produced the lightdm login and then I could do the Ctrl-Alt-F1 startkde workaround. From there, I upgraded to 15.10. Now I'm back to the original problem. lightdm login comes up, logging in doesn't work, the Ctrl-Alt-F1 startkde workaround works.

summary: - Plasma session does not start after upgrade to Kubuntu 15.04
+ Plasma session does not start after upgrading Kubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers