Plasma screen flickering on lower resolutions after upgrade to Kubuntu 15.10

Bug #1514167 reported by Lorenzo Bettini on 2015-11-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
plasma-desktop (Ubuntu)
Undecided
Unassigned

Bug Description

On my laptop, Dell m3800, the default resolution 3200x1800 makes everything unreadable, so I need to keep the resolution lower, i.e., 1920x1080. Everything worked fine in Kubuntu 15.04. After the upgrade to Kubuntu 15.10, if I turn the resolution to 1920x1080 (or any lower resolution than the default one), the screen starts to flickering often (with the default resolution 3200x1800 this does not happen).

I tried to turn off compositing, using Xrender, etc. nothing seems to work.

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile
OpenGL version string: 3.0 Mesa 11.0.2
OpenGL shading language version string: 1.30
Driver: Intel
GPU class: Haswell
OpenGL version: 3.0
GLSL version: 1.30
Mesa version: 11.0.2
X server version: 1.17.2
Linux kernel version: 4.2
Requires strict binding: yes
GLSL shaders: yes
Texture NPOT support: yes
Virtual Machine: no

Lorenzo Bettini (bettini) wrote :

Some additional information: it might be a kernel issue (see my comment on the other bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1509556/comments/44)

Lorenzo Bettini (bettini) wrote :

It looks like it's a bug in the DRM/Intel driver: https://bugs.freedesktop.org/show_bug.cgi?id=91393

Perec Fix (perecfx) wrote :

It is also affects Ubuntu 15.10 Unity desktop on all resolutions. I've tried 4.4, 4.3 and 4.2 kernels. Same flickering.
The only workaround for me for now is to use 3.19 kernel. It works fine with this.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-desktop (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.