Can't terminate session after a while

Bug #1465866 reported by Luca Olivetti on 2015-06-16
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
plasma-desktop (Ubuntu)
High
Unassigned

Bug Description

I doesn't happen always, but usually after a relatively long session, the "exit session" instead of showing the "going to exit in 30 seconds dialog", just does nothing.
After that, trying to launch other programmes doesn't work either.
In another tty I can see that ksmserver is at 100% cpu.
I have to kill -KILL ksmserver in order to terminate the session (with no prompt).
Don't know if it is relevant but baloo_file is also at 100% cpu.
I saw it in 3 different vivid installations, one upgraded from 14.04, one a fresh install (this one) and another one in a virtualbox virtual machine that started life as 12.10 and upgraded at each new release.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: plasma-desktop 4:5.2.2-0ubuntu4
ProcVersionSignature: Ubuntu 3.19.0-21.21-generic 3.19.8
Uname: Linux 3.19.0-21-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17.2-0ubuntu1.1
Architecture: amd64
CurrentDesktop: KDE
Date: Wed Jun 17 00:05:16 2015
SourcePackage: plasma-desktop
UpgradeStatus: No upgrade log present (probably fresh install)

Luca Olivetti (olivluca) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-desktop (Ubuntu):
status: New → Confirmed
Changed in plasma-desktop (Ubuntu):
importance: Undecided → High
dv_ (dv-9) wrote :

I can confirm this on Kubuntu 15.10. I get the exact same error, and it is highly irritating.

marco (nazgul17) wrote :
Download full text (3.9 KiB)

I can confirm this on Kubuntu 15.10. I run
sudo gdb -p <pid-of-ksmserver>
(gdb) backtrace

and this is the output:
(gdb) backtrace
#0 0x00007f5524e41e15 in _nv014tls () from /usr/lib/nvidia-352/tls/libnvidia-tls.so.352.41
#1 0x00007f55274c85cd in ?? () from /usr/lib/nvidia-352/libGL.so.1
#2 0x00007f55274c8998 in ?? () from /usr/lib/nvidia-352/libGL.so.1
#3 0x00007f552746d6f2 in ?? () from /usr/lib/nvidia-352/libGL.so.1
#4 0x00007f552749a51e in ?? () from /usr/lib/nvidia-352/libGL.so.1
#5 0x00007f552749edd8 in ?? () from /usr/lib/nvidia-352/libGL.so.1
#6 0x00007f5527491793 in glXCreateContextAttribsARB () from /usr/lib/nvidia-352/libGL.so.1
#7 0x00007f5514fe4ab4 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so
#8 0x00007f5514fbd34b in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so
#9 0x00007f5529a3cbeb in QOpenGLContext::create() () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#10 0x00007f5514fe513a in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so
#11 0x00007f5514fe52e1 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so
#12 0x00007f5518bfd62b in QSGRenderLoop::instance() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f5518c2de45 in QQuickWindowPrivate::init(QQuickWindow*, QQuickRenderControl*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f5518cd90bd in QQuickView::QQuickView(QWindow*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f5518026a04 in ?? () from /usr/lib/x86_64-linux-gnu/libkdeinit5_ksmserver.so
#16 0x00007f55180285e2 in ?? () from /usr/lib/x86_64-linux-gnu/libkdeinit5_ksmserver.so
#17 0x00007f55180363a6 in ?? () from /usr/lib/x86_64-linux-gnu/libkdeinit5_ksmserver.so
#18 0x00007f551803be0f in ?? () from /usr/lib/x86_64-linux-gnu/libkdeinit5_ksmserver.so
#19 0x00007f551803c025 in ?? () from /usr/lib/x86_64-linux-gnu/libkdeinit5_ksmserver.so
#20 0x00007f551f543d4e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#21 0x00007f551f547d5a in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#22 0x00007f551f54881f in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#23 0x00007f551f54999e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#24 0x00007f5529715651 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#25 0x00007f5528144b8c in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#26 0x00007f552814a230 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#27 0x00007f55296e3f1b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007f55296e6057 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#29 0x00007f552973ae73 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#30 0x00007f55261d4ff7 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f55261d5250 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f55261d52fc in g_main_context_iteration () from /lib/...

Read more...

Luca Olivetti (olivluca) wrote :

I may be wrong, but I think the nvidia thing is a red herring (or an easy scapegoat): If you read my original report you'll see that I also had the same problem in a virtualbox guest, and that is surely not using the nvidia driver. Unfortunately I don't have the same virtual machine available to test now.

Peter Hewett (peter-hewett) wrote :

Similar symptoms experienced here on Kubuntu 15.10; occasionally (but not always) when I click shutdown or log off, the system doesn't exit, ksmserver goes to 100% CPU and system become unresponsive (or very very slow to open a new window).

Could this be related to KDE bug 328571 ?
https://bugs.kde.org/show_bug.cgi?id=328571

Luca Olivetti (olivluca) wrote :

According to that bug report it should be fixed in 15.10.
I'm using 15.10 and the backports ppa but I still see it happening.
I tried manually exporting QT_NO_GLIB=1 let's see how it behaves.

Luca Olivetti (olivluca) wrote :

I had to remove QT_NO_GLIB=1 because kmix stopped working and the system tray vvolume applet (which I usually keep disabled in order not to have 2 volume icons) showed "no available input/ouput devices".

Peter Hewett (peter-hewett) wrote :

I have two machines here running Kubuntu 15.10. One has nvidia graphics card and it has this problem. The other machine has Intel graphics, and has not exhibited any symptoms of this bug.
The machine with the nvidia graphics is using nvidia driver 352 (recommended in system settings).

Peter Hewett (peter-hewett) wrote :

The driver manager in system settings offers 3 graphics drivers;
- nvidia 352 (recommended)
- nvidia 352-updates
- x.org nouveau display driver

I have tried with all three drivers (with a reboot between changes) and the freeze-on-shutdown symptoms occur with each of the nvidia drivers, but not (so far) with the x.org driver.
Of course, the x.org driver struggles a bit to run my dual monitor setup, but at least it is good to know that I can properly shutdown the system when I want to.

Peter Hewett (peter-hewett) wrote :

And maybe also KDE bug 357140 .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.