Ubuntu

(Breezy) Planner Gantt view vertically misaligned

Reported by Dave Rosky on 2005-10-19
10
Affects Status Importance Assigned to Milestone
planner
Confirmed
Medium
planner (Ubuntu)
Medium
Unassigned

Bug Description

In Planner's Gantt view, the task list in the left pane is vertically misaligned
with the grahpical Gantt chart in the right pane. The rows in the Gantt pane
are smaller vertically than the rows in the task list pane, resulting in the
Gantt chart and task list being quite badly misaligned by the time you reach the
bottom of the chart.

I thought this might be a font problem, so I tried several fonts and font sizes
for the application font in the GNOME font preferences, but although the fonts
did change in planner, the misalignment was always there.

In case it helps, I also use the same version of planner on a Fedora 4 system
and don't seem to have this problem, so I don't know if it might be GTK or GNOME
related.

Regards,
Dave

http://bugs.gnome.org/show_bug.cgi?id=144773: http://bugs.gnome.org/show_bug.cgi?id=144773
Gnome bug 128983 - related to this.: http://bugzilla.gnome.org/show_bug.cgi?id=128983

Daniel Holbach (dholbach) wrote :

Thanks for your bug report. http://bugs.gnome.org/show_bug.cgi?id=144773 seems
to discuss the same problem. If you could follow up there, it would enable
upstream to gather more information on the problem.

Changed in planner:
status: Unconfirmed → Confirmed
Changed in planner:
status: Unconfirmed → Confirmed
Martin-Éric Racine (q-funk) wrote :

Is this still an issue with planner 0.14-10 ?

Dave Rosky (d-rosky) wrote :

"Is this still an issue with planner 0.14-10 ?"

I would like to try it, but planner is still at version 0.13 in the dapper repository. Would it be possible to update planner in the dapper repository to 0.14? If not, are there packages in another location?

Thanks

Martin-Éric Racine (q-funk) wrote :

It's currently in Edgy (Ubuntu 6.10), which is going to be released next month.

Dave Rosky (d-rosky) wrote :

"It's currently in Edgy (Ubuntu 6.10), which is going to be released next month."

OK, but it would be nice if new versions of programs would also be updated in the currently-released version of Ubuntu, which is dapper at the moment. The ubuntu dapper repositories seem to have so many old versions of software :-( .

Since there's no package available, is there a tarball that will compile on dapper against the libraries normally provided on dapper? If not, I guess I will wait till I have time to play with Edgy...

Thanks,
Dave

Sebastien Bacher (seb128) wrote :

No new versions are pushed to stable usually, you can't really have a stable distribution if you keep doing changes to it (new versions fix bugs and also often bring some new ones too). A dapper-backport has been request: bug #49585, according to the bug it's not possible though since the edgy package require a dpkg-dev version not available from dapper

Changed in planner:
assignee: seb128 → desktop-bugs
Dave Rosky (d-rosky) wrote :

Not updating stable is a tough call. I think it makes sense for system-wide things, but in general an application like planner can't break anything else on a stable system. In any case, that's what backports is for, so people who need the new features can get them at their own risk. In the case of planner, the last distro I used where planner worked correctly for me is Fedora 4, so I have to boot Fedora 4 whenever I need to use planner. It's quite painful, I'd rather take a chance on a new version. It sounds like backporting is not easy in this case, however.

Anyway, thanks for the help, I will download an edgy snapshot as soon as I get a chance and check it out there.

RichardKinder (richard-kinder) wrote :

Can we get the simple fix for this into 6.06? This bug makes the application look very amateurish.

The fixes aren't that big or extensive - surely they can be patched in with little effort? I may even do it myself - I'll report back if I get it working...

Martin-Éric Racine (q-funk) wrote :

Of which simple fix are we talking about? I'd like a URL to the GNOME bug entry and to the patch. If it looks good, I could merge it in the next upload.

RichardKinder (richard-kinder) wrote :

Attached is a diff I've done that seems to fix the issue for me. I've squeezed the patches from Gnome bug 128983 into the source from 6.06. Not sure if it's 100% correct, but may help others who are suffering from misaligned project plans.

Changed in planner:
status: Confirmed → Triaged
Brent Newland (brent-newland) wrote :

http://bugzilla.gnome.org/show_bug.cgi?id=144773 -- "Unable to recreate in version 0.14.2". Mark as fix released?

this bug is still confirmed from breezy has this bug been fixed, or can it be confirmed in intrepid or jaunty?

Martin-Éric Racine (q-funk) wrote :

Is this issue fixed as of Jaunty or Karmic?

Nigel Babu (nigelbabu) wrote :

Is this bug fixed now? Can someone confirm?

Changed in planner (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Incomplete

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in planner (Ubuntu):
status: Incomplete → Fix Released
Changed in planner:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.