package netplan (not installed) failed to install/upgrade: intentando sobreescribir `/usr/sbin/netplan', que está también en el paquete nplan 0.12

Bug #1665842 reported by GERARDO RODRÍGUEZ RAMOS on 2017-02-18
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nplan (Ubuntu)
High
Mathieu Trudel-Lapierre
Xenial
Undecided
Unassigned
plan (Ubuntu)
Undecided
Unassigned

Bug Description

[Impact]
People attempting to install both netplan (plan server) and nplan (netplan network configuration parser); will fail the installation due to file conflicts.

[Test case]
- Attempt to install nplan after netplan has been installed.
- Attempt to install netplan after nplan has been installed.

In both cases, the installation should request that you remove the other package before allowing the installation to continue. Installation should not fail with file conflict errors.

[Regression potential]
Any failure to work with existing configuration should be considered a regression. Any new failure of the test suite would be a regression.

---

Se descarga pero al instalarse falla la aplicación y sale un letrero de falla, eso es todo

ProblemType: Package
DistroRelease: Ubuntu 16.10
Package: netplan (not installed)
ProcVersionSignature: Ubuntu 4.8.0-37.39-generic 4.8.16
Uname: Linux 4.8.0-37-generic x86_64
ApportVersion: 2.20.3-0ubuntu8.2
Architecture: amd64
Date: Fri Feb 17 21:49:40 2017
ErrorMessage: intentando sobreescribir `/usr/sbin/netplan', que está también en el paquete nplan 0.12
InstallationDate: Installed on 2017-01-26 (23 days ago)
InstallationMedia: Edubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160130)
RelatedPackageVersions:
 dpkg 1.18.10ubuntu1
 apt 1.3.4
SourcePackage: plan
Title: package netplan (not installed) failed to install/upgrade: intentando sobreescribir `/usr/sbin/netplan', que está también en el paquete nplan 0.12
UpgradeStatus: Upgraded to yakkety on 2017-01-28 (20 days ago)

Hans Joachim Desserud (hjd) wrote :

Thanks for taking the time to report this issue and help making Ubuntu better.

I can confirm this issue. It looks like the binary /usr/sbin/netplan is part of both nplan [1] and netplan [2], but the packages aren't marked as conflicting each other to prevent both from being installed at the same time. Furthermore it looks like netplan is synced from Debian, while nplan is an Ubuntu-only package so it might be likely to apply the fix to the latter.

[1] http://packages.ubuntu.com/zesty/amd64/nplan/filelist
[2] http://packages.ubuntu.com/zesty/amd64/netplan/filelist

Changed in plan (Ubuntu):
status: New → Confirmed
Changed in nplan (Ubuntu):
status: New → Confirmed
tags: added: package-conflict packaging zesty
Changed in nplan (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
milestone: none → ubuntu-17.05
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nplan - 0.21

---------------
nplan (0.21) artful; urgency=medium

  [ Ryan Harper ]
  * Add support for setting MTU on a device. (LP: #1668693)

  [ Mathieu Trudel-Lapierre ]
  * Don't rebind Atheros AR9271; it would confuse the driver. (LP: #1672740)
  * debian/control: Add Conflicts: against netplan; the network 'plan' daemon.
    Both ship the same /usr/sbin/netplan. (LP: #1665842)

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 02 May 2017 09:37:57 -0400

Changed in nplan (Ubuntu):
status: In Progress → Fix Released
description: updated

Hello GERARDO, or anyone else affected,

Accepted nplan into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nplan/0.21~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nplan (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers