goes from 24% to 80% & then fails at select & install software

Bug #99303 reported by Shirish Agarwal on 2007-03-31
2
Affects Status Importance Assigned to Milestone
pkgsel (Ubuntu)
Undecided
Colin Watson

Bug Description

Binary package hint: debian-installer

Hi all,
        I downloaded the 7.04 beta using bittorent. The first time I installed it, it installed without any issues. Due to certain other issues decided to re-install. I checked the md5sums given at the site, with a checksum software which I've at my end. http://www.slavasoft.com/?source=HashCalc.exe . Also bittorent reported as a clean thing. Then before installing, I checked the CD for defects. I re-formatted the partitions as I'm aware of the bug https://launchpad.net/ubuntu/+source/partman-partitioning/+bug/94647 . No guided partitioning, it was all manual. It's a text-based install (no oem install or F6 expert install) , it proceeds to install the base system & installs it successfully. But the next phase where it starts installing the rest of the software packages, it waits at a couple of places for long -time, then jumps, then around at 24-25% it jumps to 86% & says the installation package failed at select & install software. I burnt a second CD thinking there might be some burn issues or something like tht but still the same error is re-produced.

description: updated
Shirish Agarwal (shirishag75) wrote :

All the logs are 0 except the dpkg.log which is of 219 KB as well as lastlog which is of 30 KB hence uploading both of them. Also the timings are all screwed up but tht's another matter altogether.

description: updated
Shirish Agarwal (shirishag75) wrote :
Shirish Agarwal (shirishag75) wrote :

Ok, I think I might have found the culprit, it is most probably the usage where one can move from standard to either news, largefile, largefile 4. Each time I was using largefile. The moment I came back to standard, the install went ahead.

Colin Watson (cjwatson) wrote :

Please reproduce the failure and attach /var/log/syslog (you can extract it using the "Save debug logs" main menu item).

I suppose anything's possible, but it seems unlikely that largefile could be involved unless you're running close to the edge of disk space requirements.

Changed in debian-installer:
assignee: nobody → kamion
status: Unconfirmed → Needs Info
Shirish Agarwal (shirishag75) wrote :

What do u mean by :-
¨I suppose anything's possible, but it seems unlikely that largefile could be involved unless you're running close to the edge of disk space requirements.¨

     I did make a post about it in ubuntuforums http://ubuntuforums.org/showthread.php?t=398588

   I would be doing it again on April 5th-6th so if u can keep it open till tht time, I would do it, otherwise you can close it for now & if I again have the issue at tht time with the alternate CD would do it. As far as syslog is concerned, I had saved it on /var & when I looked from windows I did see the log but it was 0 bytes. Thnx for your time.

Shirish Agarwal (shirishag75) wrote :

I have tried the same thing 10 times & only the 2 logs I get with some info. each time. All other logs are 0 bytes.

Shirish Agarwal (shirishag75) wrote :

Hi all,
     I am currently reading the debian installer guide, one thing which occured to me is there is also the possibility as we are using the newer/experimental drivers being used https://wiki.ubuntu.com/LibAtaForAtaDisks . If such a case happened then it should have been reported long time back. Anyway now when the RC build will be coming, would do the needful as well as when the final build is also there. This way the alternate CD installer is tested well.

Shirish Agarwal (shirishag75) wrote :

Could u please tell what do u mean by "I suppose anything's possible, but it seems unlikely that largefile could be involved unless you're running close to the edge of disk space requirements."

 Here are 4 photos which show what I've been doing, These have been done using VMware, please lemme know where I'm going wrong.

http://img264.imageshack.us/img264/3908/bootparameter1ag0.png

http://img175.imageshack.us/img175/2606/hddmanualpartition2bp2.png

http://img70.imageshack.us/img70/4886/packageinstallationerrogf5.png

http://img175.imageshack.us/img175/1961/vt4errorlogpw8.png

 Looking forward for inputs

Shirish Agarwal (shirishag75) wrote :

http://img511.imageshack.us/img511/586/partitionsetupla0.png

 Another photo just to show how I was setting up partitions, now this 5% reserved blocks are going to be from the partition space itself or aside of it, nothing is known.

John Dong (jdong) wrote :

Talked to shirish in IRC today, and he was using largefiles (which creates 1MB inodes). I tested in a vmware and within 1 second into install, 5000 files were unpacked on disk, completely depleting all the inodes on my 5GB test root.

So, it's not really a d-i bug, but rather a user error.

Changed in pkgsel:
status: Needs Info → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers