Minimal Setup progress bar at 100% while downloading

Bug #806076 reported by hexafraction on 2011-07-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pkgsel (Ubuntu)
Medium
Canonical Foundations Team
Oneiric
Medium
Canonical Foundations Team

Bug Description

While setting up Ubuntu Oneiric via minimal CD, after selecting optional software and waiting on a blank screen, the progress bar is at 100% when a download is still processing. This is in VmWare, 316MBram, 20GB SCSI hard disk, own IP-address on internal network, no sound card, partitioned with guided setup partitioning, encrypted LVM. Also, I believe that the progress-bar-less pause before this progress bar with the bug is rather excessive.

hexafraction (rarkenin) wrote :
tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. confirmed with netboot installer.

affects: ubuntu → debian-installer (Ubuntu)
Changed in debian-installer (Ubuntu):
importance: Undecided → Low
status: New → Triaged
importance: Low → Medium
hexafraction (rarkenin) wrote :

Looking at graphs of network usage by vmware, during the 15-minute pause after selecting the optional software, and the buggy progress bar, a download was commenced. This took 15 minutes, and I believe that a progress bar is needed during this download.

hexafraction (rarkenin) on 2011-07-06
tags: added: ui
Colin Watson (cjwatson) on 2011-07-08
affects: debian-installer (Ubuntu) → pkgsel (Ubuntu)
hexafraction (rarkenin) wrote :

A big pain to those with either slow internet connections, or slow execution of dpkg... An hour of staring at a 100% progress bar? Not likely usable for a production copy.

Colin Watson (cjwatson) wrote :

You don't need to explain why this is an important problem - I understand.

However, I don't seem to be able to reproduce this here. My Internet connection is very slow, apparently rather similar to yours, so I cannot easily experiment with different options until I hit on the one that matches what you did. Could you tell me exactly which software collections you selected to install at the "Choose software to install:" prompt?

It would also help if you could attach /var/log/installer/syslog from an installation that had this problem. Ideally, it should be an installation performed with the DEBCONF_DEBUG=developer boot parameter passed to the installer (although in that case make sure not to use a valuable password).

tags: removed: bar progress setup
Changed in pkgsel (Ubuntu):
status: Triaged → Incomplete
hexafraction (rarkenin) wrote :

This is a bug in an oneiric alpha,(Probably not in the stable release of Natty) and if you had read Jean-Baptiste Lallement's comment, you would see that it is confirmed. Am changing back to confirmed. Wish someone would mark as triaged, the way it was before.

Changed in pkgsel (Ubuntu):
status: Incomplete → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Colin surely read my comment, but he was requesting more information because he couldn't reproduce the problem locally. That's why he set the status to 'incomplete'

Anyway here are the logs produced on a test system where there is a long delay without any application feedback. I seletected 'Ubuntu Desktop' at the the 'software selection' stage.

The main difference with the original issue is that I don't see any progress bar at all, maybe due to the speed of the download (I tried without proxy which is a bit slower but didn't even see the bar)

Andrey, could you tell exactly which software collections you selected to install at the "Choose software to install:" prompt?

hexafraction (rarkenin) wrote :

I do not remember my selections, but they are probably in the setup logs and then I got a long pause, followed by the bad progress bar. Maybe you hadn't seen the progress-bar yet? I will attach the logs later.(Within a week)

Colin Watson (cjwatson) wrote :

Andrey-computer: I was perfectly well aware that it was a problem in Oneiric. It is quite distressing that you chose to attack me rather than answering my question. I am the developer responsible for fixing this problem; if I do not get an answer to my question then I cannot fix your bug.

hexafraction (rarkenin) wrote :

Colin, I am sorry if my comments have offended you, but I meant no insult whatsoever. Anyway, here are the logs from var/log/installer.

Changed in pkgsel (Ubuntu Oneiric):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in pkgsel (Ubuntu Oneiric):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers