9.10 Server i386: Installation step failed .. failing step is: Select and install software

Bug #478754 reported by justAnotherUser on 2009-11-08
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
pkgsel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: debian-installer

Installing 9.10 Server i386 with a checked CD (both no media errors and MD5 clean) yields "Installation step failed .. failing step is: Select and install software". After several attempts with reduced packages to be installed I ended up with a very minimal system.

Further investigation revealed a /etc/apt/sources.list file with only one line: "deb cdrom:[Ubuntu-Server 9.10 _Karmic Koala_ - Release i386 (20091027.2)]/ karmic main restricted". Another file (sources.list.apt-setup) contained much more usable information. So I renamed it to "sources.list" and deleted the cd-specific lines. Now I can at least install on my own.

However, I even have no program to report directly (ubuntu-bug, in which package can I find it?) and I have no idea how to get all the software I need to run my server. Please do not explain how to use apt-get or aptitude. My problem is that ordinary users can not know all the specific packages that are needed to set up, e.g. an Ubuntu Enterprise Cloud server, because there is no meta package for it (or at least I was not able to find it in the vast variety of packages.

Providing a installer that does not install most of the software is not useful. Exhibiting such a mistake in the installation process of a server product does not produce trust, which it very much in need when setting up a server for serious purposes.

This did not appear in our pre-release testing (we would not have
released 9.10 with such a bug), which means that we need information
from you to track down the failure.

Could you please attach the /var/log/installer/syslog file from your
completed installation? (I'm assuming that you didn't reboot between the
failure and correcting it.)

 status incomplete

Changed in debian-installer (Ubuntu):
status: New → Incomplete
tags: added: iso-testing

I seem to be in the same situation - installation fails in "select and install software" step.

Boot from CDROM, tried in expert mode and in normal mode.

It says that "something" has failed - it only showd the failed command ... the whole dpkg output in a text field would be great in such an unexpected case.

Anyways, created debug logs and entered the shell.

The last entry I saw failing was the linux-headers-2.6.31-pae package so I ran the command it showed me in the error window during installation: "chroot /target --install --force-...something /media/cdrom0/[...]/linux-headers-2.6.31-[...].deb" and ran that command there in the shell.

To my astonishment, it gave up with the following:

~ # df
Filesystem 1K-blocks Used Available Use% Mounted on
tmpfs 222312 144 222168 0% /dev
/dev/sr0 655944 655944 0 100% /cdrom
/dev/sda1 19528876 605744 17946384 3% /target
/dev/sda1 19528876 605744 17946384 3% /dev/.static/dev
tmpfs 222312 144 222168 0% /target/dev
/dev/sr0 655944 655944 0 100% /target/media/cdrom0
/usr/bin # chroot /target/ dpkg --force-all --install /media/cdrom0/pool/main/l/linux/linux-headers-2.6.31-14-generic-pae_2.6.3
1-14.48_i386.deb
(Reading database ... 14458 files and directories currently installed.)
Unpacking linux-headers-2.6.31-14-generic-pae (from .../linux-headers-2.6.31-14-generic-pae_2.6.31-14.48_i386.deb) ...
dpkg: error processing /media/cdrom0/pool/main/l/linux/linux-headers-2.6.31-14-generic-pae_2.6.31-14.48_i386.deb (--install):
 unable to create `/usr/src/linux-headers-2.6.31-14-generic-pae/include/config/nf/nat/proto/udplite.h.dpkg-new' (while processing `./usr/src/linux-headers-2.6.31-14-generic-pae/include/config/nf/nat/proto/udplite.h'): No space left on device
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /media/cdrom0/pool/main/l/linux/linux-headers-2.6.31-14-generic-pae_2.6.31-14.48_i386.deb
/usr/bin #

... which in my opinion makes no sense.

Only thing I could think of are too strong or unlucky compilation flags for dpkg or the running kernel or file system code, something I had sometimes in a custom-compiled Gentoo system.

Will try to attach my full syslog output I transfered out via USB storage.

Promised installer syslog.

Bharath Ramesh (krosswindz) wrote :

I am facing the same problem with the amd64 alternate install CD. The only way I managed to get past this issue was by constantly modifying /target/etc/apt/sources.list to a valid ubuntu http mirror. I am not sure if the problem is that it is trying to look for _Karmic Koala_ instead of "Karmic Koala" when it tries configuring APT.

Colin Watson (cjwatson) wrote :

Ernst, if it says you're out of disk space, then it means it. Compiler flags have nothing to do with it. I'll grant you that our error handling in this case isn't great ...

affects: debian-installer (Ubuntu) → pkgsel (Ubuntu)

Well, notice the line from my extract from "df":

/dev/sda1 19528876 605744 17946384 3% /target

... and it says "no free space". This should not be! There are 17G free space. I assume a problem in the installer logic.

I am also certain from experience that compiler flags can create misbehavior in code from "optimizations".

NickHussey (imahussey) wrote :

I have the same problem as the first comentor, just hoping for an update on this issue.

Launchpad Janitor (janitor) wrote :

[Expired for pkgsel (Ubuntu) because there has been no activity for 60 days.]

Changed in pkgsel (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers