Ubuntu

alternate installer: installation step failed

Reported by moboticdes on 2008-04-18
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pkgsel (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 8.04 Beta i386 install fails with the alternate install cd, I choose automatic partitioning with LVM and Encryption and when it come to the install software step at over 80% it pops up a red window with written:

-----------------
[!!] Select and install software
Installation step failed
An installation step failed. You can try to run the failing item again from the menu, or skip it and choose something else. The failing step is: Select and install software
<Continue>
-----------------

Tried to skip it and jump to the next item which is install grub but still it failed and says the system wont be bootable without grub..

What can I do? I had tried the graphical standard install cd and it worked smoothly the installation, so this is a alternate install problem maybe having to do with the LVM and crypto options I chose.

the step after the one which first fails is not install grub rather "Build LTSP chroot", now I'll try to install again with the alternate install cd but without choosing LVM and crypto option.
Another thing: I tested the install cd (it's a dvd actually so should be less prone to errors) and it has no errors.

Ok tried the Ubuntu 8.04 Hedgy Hoary Beta i386 alternate install (text mode) and this time without LVM and crypto system, again same error.. so this has nothing to do with LVM and crypto options, its a plain debian installer problem... Quite big and critical though! Hope they fix it before releasing the UBuntu 8.04 definitive!

Colin Watson (cjwatson) wrote :

Please attach /var/log/syslog from the running installer. You can extract it using "Save debug logs" from the main menu.

Changed in debian-installer:
status: New → Incomplete
Colin Watson (cjwatson) wrote :

By the way, "Ubuntu 8.04 Hedgy Hoary" is an incredibly mangled version - "Hoary Hedgehog" was 5.04, while 8.04's codename is "Hardy Heron". Just say 8.04, though, we'll understand that fine without you having to add the codename too.

Rich Clayton (rich464) wrote :

I've just had the same problem doing an install of Ubuntu 7 from the alternate CD but looking at the syslog after pkgsel fails seems to show my partition sizes incorrectly showing and pkgsel failing because the partion is full (showing 1.6gb 100% used despite my partiton being set to over 40gb). I'm not sure if this is the same as the reported bug but it appears to be a bug with the initial partitioning rather than pkgsel itself. It's definately worth switching to a console and checking /var/log/syslog if you get this error.

description: updated

I have the exact same problem, see bug #228416

Just after the attached error got displayed, I type CTRL+ALT+F2 and Enter to get a terminal and typed the following command:

# md5sum /dev/scd0
166991d61e7c79a452b604f0d25d07f9 /dev/scd0

Which is the same checksum as seen on http://releases.ubuntu.com/8.04/MD5SUMS
The checksums match, so it is NOT a problem with burning the CD, it is a bug within the Ubuntu alternate distribution.
How come some individual packages would be corrupt, whereas the whole CD is not ?

Changed in pkgsel:
status: Incomplete → Confirmed
description: updated

I thought I would install 7.10 alternate with encrypted LVM and then upgrade from there, so I downloaded the ISO, burnt it at 2x speed, launched the Ubuntu integrity check tool that checks every single package, and began installing. Default settings except: French keyboard, no network yet, encrypted LVM. And guess what ? It failed at the same "Select and install software" step with the same message ! Please find the syslog attached.

I finally got it working by NOT using the "guided" encrypted LVM partitioning.
Instead, I did the following:
- Create a 256 MB bootable ext3 /boot
- Create a large encrypted volume
- Select the menu item that is about configuring the encrypted volume
- From there, configure the encrypted volume as your ext3 /

It worked for me this way. So I suspect a bug with the guided partitioning tool. Hopefully the two syslog files I attached will help debug this.
Cheers !

zerwas (zerwas) wrote :

I can confirm this bug using Ubuntu 8.10 Alternate CD. The md5sum is correct.

Is there any additional information needed to solve this problem?

I had the same problem with Ubuntu 8.04.1 alternate CD amd64 but I found that:
- md5sum was correct
- cd test from Ubuntu installer showed an error

So I reburned my cd and all went ok (cd test from installer was ok).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers