installation step failed - Select and install software

Bug #1417918 reported by Lars Noodén on 2015-02-04
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
pkgsel (Ubuntu)
Medium
Unassigned

Bug Description

When installing the Alternate image
http://iso.qa.ubuntu.com/qatracker/milestones/332/builds/88790/testcases

the installation fails at the step "select and install software" According to the console there are broken packages

what should have happend is that the packages and package dependencies all resolved correctly and installed

Lars Noodén (larsnooden) wrote :
Lars Noodén (larsnooden) wrote :
Lars Noodén (larsnooden) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1417918

tags: added: iso-testing
Boris Reinhard (reinhard-boris) wrote :

Could it possibly be your downloaded image was damaged/ corrupted Lars?
I'm downloading now and not seeing any of the download speed issues you mentioned, I guess there is somethign wrong on your end or maybe you have network congestion, remaining about 4 minutes for me.

Lars Noodén (larsnooden) wrote :

The MD5 sum was ok, I always check that. There were some comments on the Ubuntu Forums about slow dowloads of the images yesterday, but I can't find the link.

About work-arounds you mention on the QA list that manually skipping to the next step after the error still gave you a bootable system. Does it run reliably?

Boris Reinhard (reinhard-boris) wrote :

It did boot reliably and without error BUT there was not much of a system as far as I could tell as it seemed to be as barebone as it could get, basically only the terminal and vi, eg. no vim, no nano, no desktop and such,...

I now strongly suspect this was due to the manifest issue which caused alternate builds to be incomplete and having missing/ broken packets. The ppc desktop build however (which only became available later after the alternate build) was not affected, I tested the image and live boot worked!

So this apparently is a duplicate of those:
https://bugs.launchpad.net/ubuntu/+source/lubuntu-meta/+bug/1417784
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1417251

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Changed in debian-installer (Ubuntu):
status: Confirmed → Incomplete
Lars Noodén (larsnooden) wrote :

Which information is needed?

sudodus (nio-wiklund) wrote :

This symptom is also affecting

Lubuntu trusty-alternate-i386.iso (14.04.2 LTS release candidate dated feb 18 00:41)

I found it during iso-testing in a computer with the following motherboard

http://www.asus.com/Motherboards/M2NVM_DVI/

This computer has an AMD Athlon CPU that can run 32-bit and 64-bit operating systems.

AMD Athlon(tm) 64 X2 Dual Core Processor 4400+

Red screen: Installation step failed
The failing step is: Select and install software

ctrl-alt-f4:
The following packages have unmet dependencies:
gvfs-daemons: depends: x11-utils but it is not going to be installed
libglapi-mesa-lts-utopic: conflicts: libglapi-mesa
lubuntu-core: depends: xorg but it is not going to be installed
lubuntu-desktop: depends: x11-utils but it is not going to be installed
xserver-xorg-lts-utopic: recommends ...
Conflicts: libgl1-mesa-glx
Conflicts: libglapi-mesa
Conflicts: libopenvg1-mesa
...
Configuring pkgsel failed with error code 1

Walter Lapchynski (wxl) wrote :

i'm going to assume those bugs are different.

tags: added: i386 ppc
summary: - PPC - installation step failed - Select and install software
+ installation step failed - Select and install software
Changed in debian-installer (Ubuntu):
status: Incomplete → Confirmed
Walter Lapchynski (wxl) wrote :

This was reported against 14.04.2 for ppc, i386 and amd64 (though no comments on the subject have been made here).

tags: added: amd64
sudodus (nio-wiklund) wrote :

comment #11 is a comment on the subject

turtlepurple (turtle-purple) wrote :

I had the same problem in 14.04.1 alternate i386 (https://bugs.launchpad.net/ubuntu/+source/pkgsel/+bug/1065349)

But the failing package there was just one: libunity9
Is this a duplicate then??

I Believe this to be important because together with this bug https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1426219 the whole alternate cd is faulty for me: The MBR-Bug applies to "Install" and "expert install" and the software-bug applies to "Install lubuntu" (Thats the options i have in unetbootin menu )

The MBR-Bug is easy to workaround though - see bugreport.

And as the Desktop-CD (14.04.2) is still failing on encrypted LVM - Installation (https://bugs.launchpad.net/ubuntu/+bug/1241833) the alternate CD is still the best way to go.
Extended how-to here:(https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1424789)

I can confirm this as well; but the issue seemed to have more to do with how the seeds and meta-package for lubuntu are set up for alternate. All other images appeared to behave properly.

I tried to dig into this a bit, but I'm not as familiar with the lubuntu seeds as others. Perhaps someone who has also more time could take a look?

Reassigning to pkgsel for now; since debian-installer seems to be doing what it should and this is related to the package selection for the installing system.

affects: debian-installer (Ubuntu) → pkgsel (Ubuntu)
Changed in pkgsel (Ubuntu):
importance: Undecided → Medium
tags: added: trusty
tags: added: lubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers