"Incomplete language support" for english after netboot installation

Bug #1056689 reported by Jean-Baptiste Lallement on 2012-09-26
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
language-selector (Ubuntu)
Medium
Colin Watson
Precise
High
Colin Watson
Quantal
Medium
Colin Watson
pkgsel (Ubuntu)
Medium
Colin Watson
Precise
Medium
Unassigned
Quantal
Medium
Colin Watson

Bug Description

[Impact] The installer reports incomplete language support when it shouldn't.
[Test case] Run an alternate install in en_US and make sure it doesn't report incomplete language support after installation. (This test case is just for the language-selector half; the pkgsel half is less urgent and only affects netboot.)
[Regression potential] Seems very safe - it's just running through set() to deduplicate, and the resulting set is fed to sorted() almost immediately afterwards.

Original report follows:

Quantal Netboot

After installation in English from a Quantal netboot ISO, I got the "Incomplete language support" dialog

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: debian-installer (not installed)
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
CurrentDmesg:

Date: Wed Sep 26 04:07:53 2012
Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Bochs Bochs
MemoryUsage:
 total used free shared buffers cached
 Mem: 994724 933468 61256 0 17324 209232
 -/+ buffers/cache: 706912 287812
 Swap: 1021948 20704 1001244
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-15-generic root=UUID=4b4a9e3a-579e-4f90-aef4-6bf6e6004aab ro splash quiet vt.handoff=7
SourcePackage: debian-installer
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/01/2007
dmi.bios.vendor: Bochs
dmi.bios.version: Bochs
dmi.chassis.type: 1
dmi.chassis.vendor: Bochs
dmi.modalias: dmi:bvnBochs:bvrBochs:bd01/01/2007:svnBochs:pnBochs:pvr:cvnBochs:ct1:cvr:
dmi.product.name: Bochs
dmi.sys.vendor: Bochs

Jean-Baptiste Lallement (jibel) wrote :
tags: added: qa-manual-testing rls-q-incoming
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1056689

tags: added: iso-testing
Changed in debian-installer (Ubuntu):
importance: Undecided → Medium
Changed in debian-installer (Ubuntu):
status: New → Triaged
tags: removed: rls-q-incoming
Colin Watson (cjwatson) wrote :

I suspect this is because for historical reasons we appear not to install language-selector-common in the netboot case and thus don't have check-language-support. I don't see any justification for this nowadays, so I'll fix that and see if that improves things.

affects: debian-installer (Ubuntu Quantal) → pkgsel (Ubuntu Quantal)
Changed in pkgsel (Ubuntu Quantal):
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Colin Watson (cjwatson) on 2012-09-27
Changed in language-selector (Ubuntu Quantal):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Colin Watson (cjwatson)
Changed in pkgsel (Ubuntu Quantal):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pkgsel - 0.36ubuntu5

---------------
pkgsel (0.36ubuntu5) quantal; urgency=low

  * Install language-selector-common even for netboot installs, since we
    need check-language-support (LP: #1056689).
 -- Colin Watson <email address hidden> Thu, 27 Sep 2012 13:34:53 +0100

Changed in pkgsel (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.89

---------------
language-selector (0.89) quantal; urgency=low

  * check-language-support: De-duplicate output for a single target language
    (LP: #1056689).
 -- Colin Watson <email address hidden> Thu, 27 Sep 2012 13:04:24 +0100

Changed in language-selector (Ubuntu Quantal):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) on 2013-02-13
Changed in pkgsel (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
milestone: none → ubuntu-12.04.3
Changed in language-selector (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-12.04.2
description: updated

Hello Jean-Baptiste, or anyone else affected,

Accepted language-selector into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/language-selector/0.79.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in language-selector (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.79.1

---------------
language-selector (0.79.1) precise; urgency=low

  * check-language-support: De-duplicate output for a single target language
    (LP: #1056689).
 -- Colin Watson <email address hidden> Wed, 13 Feb 2013 16:44:55 +0000

Changed in language-selector (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers