Shouldn't copy Enhances lines from the binaries it strips symbols from

Bug #1049324 reported by Micah Gersten
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pkg-create-dbgsym (Ubuntu)
Fix Released
Low
Martin Pitt

Bug Description

Enhances doesn't make much sense for a ddeb

From my local sbuild:
xchat-gnome-indicator-dbgsym_0.3.11-0ubuntu4_i386.ddeb
──────────────────────────────────────────────────────

 new debian package, version 2.0.
 size 18322 bytes: control archive= 412 bytes.
     459 bytes, 13 lines control
 Package: xchat-gnome-indicator-dbgsym
 Source: xchat-indicator
 Version: 0.3.11-0ubuntu4
 Depends: xchat-gnome-indicator (= 0.3.11-0ubuntu4)
 Architecture: i386
 Maintainer: Ubuntu Desktop Team <email address hidden>
 Installed-Size: 37
 Enhances: xchat-gnome
 Section: misc
 Priority: extra
 Homepage: https://launchpad.net/xchat-indicator
 Description: debug symbols for package xchat-gnome-indicator
  XChat-GNOME plugin to utilize the Messaging Indicator.

drwxrwxr-x root/root 0 2012-09-11 14:12 ./
drwxrwxr-x root/root 0 2012-09-11 14:12 ./usr/
drwxrwxr-x root/root 0 2012-09-11 14:12 ./usr/lib/
drwxrwxr-x root/root 0 2012-09-11 14:12 ./usr/lib/debug/
drwxrwxr-x root/root 0 2012-09-11 14:12 ./usr/lib/debug/.build-id/
drwxrwxr-x root/root 0 2012-09-11 14:12 ./usr/lib/debug/.build-id/5f/
-rwxrwxr-x root/root 37416 2012-09-11 14:12 ./usr/lib/debug/.build-id/5f/069e35a15542c605f63cd797e8118d47aeca7e.debug

Martin Pitt (pitti)
affects: pkgbinarymangler (Ubuntu) → pkg-create-dbgsym (Ubuntu)
summary: - pkgbinarymangler shouldn't copy Enhances lines from the binaries it
- strips symbols from
+ Shouldn't copy Enhances lines from the binaries it strips symbols from
Martin Pitt (pitti)
Changed in pkg-create-dbgsym (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Martin Pitt (pitti)
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pkg-create-dbgsym - 0.53

---------------
pkg-create-dbgsym (0.53) quantal; urgency=low

  * tests/: Add Enhances: field to dhtest test case, and ensure that ddebs do
    not have an Enhances: field. Reproduces LP #1049324.
  * pkg_create_dbgsym: Filter out Enhances: (LP: #1049324)
  * pkg_create_dbgsym: Call readelf with C locale to avoid output parsing
    errors due to translations.
 -- Martin Pitt <email address hidden> Wed, 12 Sep 2012 09:56:16 +0200

Changed in pkg-create-dbgsym (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers