pixmap FTBFS with latest xorg

Bug #248657 reported by Cesare Tirabassi on 2008-07-15
4
Affects Status Importance Assigned to Milestone
pixmap (Ubuntu)
Medium
Unassigned
xorg (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: pixmap

pixmap FTBFS with latest xorg on all arches, see build logs here:

https://edge.launchpad.net/ubuntu/+source/pixmap/2.6pl4-17ubuntu2

The build fails with this error:

make[1]: *** No rule to make target `/etc/X11/rgb.txt', needed by `dotpixmap'. Stop.

Indeed, /etc/X11/rgb.txt is not provided anymore by latest x11-common:

 [ Timo Aaltonen ]
 * control:
   - Drop x11-common Replaces on xrgb, since rgb.txt is obsolete with the
     new xserver and thus not shipped anymore.

Related branches

Changed in pixmap:
assignee: nobody → norsetto
importance: Undecided → Medium
status: New → In Progress
Cesare Tirabassi (norsetto) wrote :

It seems that the only way to solve this is to add to this package its own local copy of rgb.txt.
I'm opening a new task for xorg to ask them to considering re-adding rgb.txt it back to x11-common, this change will surely break compatibility for several legacy applications.
Its a very small text file, I don't see it as a big problem to keep it in a common place instead of every application making use of their own copy.
Please also note that in the current x11-common package there is a dangling symlink left in /usr/share/X11/ which is pointing to /etc/X11/rgb.txt.

Bryce Harrington (bryce) wrote :

I think it should be ok for us to ship a static copy for backwards compatibility.

Changed in xorg:
assignee: nobody → bryceharrington
importance: Undecided → High
status: New → Triaged
Changed in pixmap:
assignee: norsetto → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pixmap - 2.6pl4-18ubuntu1

---------------
pixmap (2.6pl4-18ubuntu1) intrepid; urgency=low

  * Fix FTBFS due to x11-common not shipping rgb.txt anymore (LP: #248657):
    - add local copy to source tree
    - modify Imakefile so that it points to the new location
    - modify debian/rules to install it
    - remove dependency on x11-common for debian/control

 -- Cesare Tirabassi <email address hidden> Sun, 24 Aug 2008 19:16:37 +0200

Changed in pixmap:
status: Fix Committed → Fix Released
Timo Aaltonen (tjaalton) wrote :

was not a bug in xorg but pixmap, and fixed now.

Changed in xorg:
assignee: bryceharrington → nobody
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers