pitivi crashed with RuntimeError in _closePadLink(): maximum recursion depth exceeded

Bug #926621 reported by Pixel on 2012-02-04
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
pitivi (Ubuntu)
Undecided
Unassigned

Bug Description

crash after insert video and drag and drop it into time-line

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: pitivi 0.15.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Sat Feb 4 12:41:22 2012
ExecutablePath: /usr/bin/pitivi
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120131.2)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: python /usr/bin/pitivi
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/pitivi']
SourcePackage: pitivi
Title: pitivi crashed with RuntimeError in _closePadLink(): maximum recursion depth exceeded
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Pixel (fabio-colinelli) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pitivi (Ubuntu):
status: New → Confirmed

I received this error when loading a movie file from kazam screencaster.

It's easy to reproduce on Ubuntu 12.04.

Get kazam 1.0.2 from http://launchpad.net/kazam

Run kazam, record some video, stop recording.
In the dialog choose to open video in pitivi.
Pitivi opens, the video loads and appears in the timeline, then pitivi crashes.

Attached is the output of me running kazam --debug and then subsequent errors from pitivi.

Sameer Morar (smorar) wrote :

This bug has been fixed in pitivi version 0.15.1:
http://git.pitivi.org/?p=pitivi.git;a=commit;h=0f0389dd3e02cf9847b8b673fbbdab6c9d703200

I have ported patched the current version in precise, which is attached.

Changed in pitivi (Ubuntu):
assignee: nobody → Sameer Morar (smorar)
tags: added: patch
Sameer Morar (smorar) on 2012-02-27
Changed in pitivi (Ubuntu):
assignee: Sameer Morar (smorar) → nobody
Daniel Holbach (dholbach) wrote :

Thanks a lot for your work on this. Uploaded - it's now sitting in the queue for Beta1 Freeze review.

Changed in pitivi (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pitivi - 0.15.0-0ubuntu2

---------------
pitivi (0.15.0-0ubuntu2) precise; urgency=low

  * debian/patches/singledecodebin.patch:
    - Prevent endless loop with new parsers (LP: #926621)
 -- Sameer Morar <email address hidden> Mon, 27 Feb 2012 18:49:10 +1000

Changed in pitivi (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers