Pitivi 0.14 package should depend on python-gtk2 >= 2.18

Bug #792261 reported by Stephen Irons on 2011-06-03
This bug affects 11 people
Affects Status Importance Assigned to Milestone
pitivi (Ubuntu)

Bug Description

Binary package hint: pitivi

I installed pitivi 0.14.0 from the gstreamer ppa. The install completes correctly. However, when I start the program, it displays a dialog box saying:

You do not have a recent enough version of the GTK+ Python bindings (currently 2.17.0)

Install a version of the GTK+ Python bindings greater or equal to 2.18.0

Indeed, I have python-gtk2 version 2.17.0.

1. There is no python-gtk2 2.18.anything for Lucid

2. The dependency in the pitivi package says Depends: python-gtk2 (>=2.17)

There is definitely a packaging bug: pitivi 0.14.0 depends on python-gtk2 >=2.18.

It does not seem possible to run pitivi with Lucid unless you install a new version of python-gtk from somewhere, or pitivi is changed to work with python-gtk2 0.2.17.

Blake W (blake-weyman) wrote :

I can confirm this, I'm running KXStudio 10.04.2. I'm not aware of any PPAs providing >=2.18, and from my limited experimentation a moment ago, it seems to require an upgrade/compilation of quite a few cairo and pygtk related packages in order to compile the required package.

Chris (xtoast) wrote :

I can also confirm this bug in Lucid.

Changed in pitivi (Ubuntu):
status: New → Confirmed
summary: - Pitivi 0.14.0 does not start on Lucid
+ Pitivi 0.14 package should depend on python-gtk2 >= 2.18

If I remember correctly, the pitivi 0.14 package when first released did actually depend on python-gtk2 >= 2.18. A bit later, it was changed so the package was installable, but not able to run.

The strange thing is that Pitivi actually worked on Ubuntu 10.04. So was there really a change so short before the release that requires a higher GTK version? And is this change so important as to drop support for Ubuntu 10.04 (which is LTS, at last)?

Timothy Davenport (warrickguy) wrote :

I am affected by this also.

There should be a new package in the PPA for ubuntu 10.04 that fixes this now.

Changed in pitivi (Ubuntu):
status: Confirmed → Fix Released
Nicola Jelmorini (jelmorini) wrote :


I have installed just now the package "pitivi 0.14.0-2~lucid2", but the issue is still present in my Ubuntu 10.04 64 bit.
When I run Pitivi the error message for wrong binding of gtk+ library 2.17.0 instead 2.18.0 is displayed as before.

The package is still waiting in queue to be built in the PPA (it has
been in the queue for 8 hours now...), so you'll have to give it some

Nicola Jelmorini (jelmorini) wrote :

Thank you!
Installed few seconds ago and perfectly working!
Pitivi is awesome btw :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers