pitivi crashed with SIGSEGV in PyEval_EvalCodeEx()

Bug #635622 reported by Ric Flomag on 2010-09-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pitivi (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: pitivi

Steps to reproduce:

* import clips
* drag a clip to the time line
* change the timeline zoom with the slider while the video thumbnails are being generated -> crash

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: pitivi 0.13.4.2-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-24.42-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
Architecture: i386
CrashCounter: 1
Date: Sat Sep 11 10:48:54 2010
ExecutablePath: /usr/bin/pitivi
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100910)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: python /usr/bin/pitivi
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x80df43a <PyEval_EvalCodeEx+218>: addl $0x1,(%edx)
 PC (0x080df43a) ok
 source "$0x1" ok
 destination "(%edx)" (0x00000000) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: pitivi
StacktraceTop:
 PyEval_EvalCodeEx ()
 ?? ()
 PyObject_Call ()
 ?? ()
 PyObject_Call ()
Title: pitivi crashed with SIGSEGV in PyEval_EvalCodeEx()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Ric Flomag (ricflomag) wrote :

StacktraceTop:
 PyEval_EvalCodeEx (co=0x9b964e8, globals=0x9b7fdfc, locals=0x0,
 function_call (func=0x9be209c, arg=0x9db732c, kw=0x0)
 PyObject_Call (func=0x9be209c, arg=0x9db732c, kw=0x0)
 instancemethod_call (func=0xa1d71bc, arg=0x9db732c, kw=0x0)
 PyObject_Call (func=0xa1d71bc, arg=0x9db718c, kw=0x0)

Changed in pitivi (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Jeff Fortin Tam (kiddo) wrote :

I can't reproduce this with the instructions you provided.
Furthermore, the stack traces you provided are missing debug symbols, so they don't give out any meaningful information. Make sure you have the following packages installed:

python-dbg python-gtk2-dbg python-gst0.10-dbg gstreamer0.10-gnonlin-dbg *gstreamer0.10*-dbg libglib2.0-0-dbg python-cairo-dbg

Then provide updated logs.

You can also create debug logs by running pitivi like this:
PITIVI_DEBUG=*:5 GST_DEBUG=2 /usr/bin/pitivi > debug.log 2>&1

Then compress and attach the log file to this bug report.

visibility: private → public
Changed in pitivi (Ubuntu):
status: New → Incomplete
Ric Flomag (ricflomag) wrote :

@Jean-François : please see bug #640630 where i provided the stack traces with debug symbols.

Closing this bug.

Changed in pitivi (Ubuntu):
status: Incomplete → Invalid
Sergio (porobu) on 2010-09-27
Changed in pitivi (Ubuntu):
status: Invalid → Confirmed
Ric Flomag (ricflomag) wrote :

@Sergio: closing this bug again as it has been superseded by bug #640630.

Changed in pitivi (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers