[packaging] *.xptv files should be associated with PiTiVi (update-mime-database isn't run)

Bug #541613 reported by Jeff Fortin Tam on 2010-03-19
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Ken VanDine
PiTiVi
Fix Released
Medium
pitivi (Ubuntu)
Low
Ken VanDine

Bug Description

Binary package hint: pitivi

see also https://bugzilla.gnome.org/show_bug.cgi?id=563456

The current situation with the lucid packages is that:
- the file is correctly installed to /usr/share/mime/packages/pitivi.xml
- the mimetype association still doesn't work. According to the gnome docs [1],
it seems to me that what is missing is "update-mime-database /usr/share/mime".

As such, it is a packaging error, where some scripts are missing.

[1]: http://library.gnome.org/devel/integration-guide/stable/mime.html

If ubuntu could provide a working patch and send it upstream, that could be nice :)

Jeff Fortin Tam (kiddo) on 2010-03-19
Changed in pitivi (Ubuntu):
status: New → Confirmed
Changed in pitivi (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in pitivi:
status: Unknown → Confirmed
Changed in pitivi:
status: Confirmed → Incomplete
Sense Egbert Hofstede (sense) wrote :

Thank you for helping with making Ubuntu and its video editor PiTiVi better by reporting this bug. I'm accepting this as a paper cut since it is a small issue that can be easily fixed and which affects the desktop experience of users on the default installation.

tags: added: packaging
summary: - xptv pitivi project files mimetype should be associated with pitivi
+ [packaging] *.xptv files should be associated with PiTiVi (update-mime-
+ database isn't run)
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → maverick-round-6-sound+video
status: New → Triaged
Changed in hundredpapercuts:
status: Triaged → In Progress
Changed in pitivi (Ubuntu):
status: Triaged → In Progress
Changed in hundredpapercuts:
assignee: nobody → Bilal Akhtar (bilalakhtar)
Changed in pitivi (Ubuntu):
assignee: nobody → Bilal Akhtar (bilalakhtar)
Changed in pitivi (Ubuntu):
assignee: Bilal Akhtar (bilalakhtar) → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pitivi - 0.13.4-3ubuntu3

---------------
pitivi (0.13.4-3ubuntu3) maverick; urgency=low

  * debian/patches/03_set_mime_type.patch
    - Pulled in a patch from git which sets the mime type for xptv
      files (LP: #541613)
 -- Ken VanDine <email address hidden> Fri, 06 Aug 2010 10:46:42 -0400

Changed in pitivi (Ubuntu):
status: In Progress → Fix Released
Changed in pitivi:
status: Incomplete → Fix Released
Changed in hundredpapercuts:
status: In Progress → Fix Released
Changed in hundredpapercuts:
assignee: Bilal Akhtar (bilalakhtar) → Ken VanDine (ken-vandine)
Changed in pitivi:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.