"Razor" , an odd name for the split tool

Bug #506642 reported by Vish
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Fix Released
Low
Unassigned
pitivi (Ubuntu)
Fix Released
Low
Unassigned

Bug Description

Binary package hint: pitivi

The name of the split/cut/crop tool is named "Razor" and the key binding is Ctrl+R .
Oddly , the icon for the "razor" is a scissor and the tooltip says "cut clip at mouse position"

It would be better if the option is named either Split tool / Cut tool / Crop tool.

ProblemType: Bug
Architecture: i386
CheckboxSubmission: 417990aadff2335cd485c57bb06c8968
CheckboxSystem: 5484a8dd99f006173bd2ac53fa4837c2
Date: Wed Jan 13 03:08:45 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
Package: pitivi 0.13.3-2
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
SourcePackage: pitivi
Tags: lucid
Uname: Linux 2.6.32-10-generic i686

Revision history for this message
Vish (vish) wrote :
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → lucid-round-6
status: New → Triaged
Revision history for this message
Jeff Fortin Tam (kiddo) wrote :

This is already fixed in the git version of pitivi; it is a "Split" tool now, and it is modeless. See also http://jeff.ecchi.ca/blog/2009/11/30/move-playhead-on-click-modeless-splitting-full-height-playhead/

Changed in pitivi (Ubuntu):
status: New → Fix Committed
Revision history for this message
Jeff Fortin Tam (kiddo) wrote :

Although if the scissors icon is not the best metaphor for "Split", I'm sure better icons would be welcome. I'm not as good as some tango artists/pixel pushers out there.

Revision history for this message
Vish (vish) wrote :

Jean-François:
If its named as "split: tool , then i dont think the current icon is a bad metaphor. It does show a scissor splitting/cutting a film.

It was odd when a button named razor showed a scissor. ;)

summary: - "Razor" , an odd name for the cut/crop tool
+ "Razor" , an odd name for the split tool
Changed in hundredpapercuts:
status: Triaged → Fix Committed
Revision history for this message
Vish (vish) wrote :

Jean-François:
When do we expect these changes to land in Lucid?

Revision history for this message
Jeff Fortin Tam (kiddo) wrote :

When pitivi 0.13.4 comes out... which I have no idea when it will happen because there is a lot on the dev's plates and there doesn't seem to be a clear list of required feature/criteria for determining when we have "reached the required feature set and should make a release".

If the ubuntu community or Canonical could lend some coding hands, more things could be implemented by then. If there are particular features that you would like to see implemented "at the very least" for that release to be included in ubuntu 10.04, it would be nice to list them ; see also https://bugzilla.gnome.org/buglist.cgi?product=pitivi;bug_status=NEW;bug_status=ASSIGNED;bug_status=REOPENED;bug_status=NEEDINFO (this excludes unconfirmed bugs)

Strategically, I would like to know when is the freeze in Ubuntu that will forbid new releases of pitivi from being included (ie: the deadline we must try to "aim" at) and whether or not there can be a freeze exception for pitivi.

Revision history for this message
Jeff Fortin Tam (kiddo) wrote :
Revision history for this message
Vish (vish) wrote :

Feb 18th is the feature freeze.
You can check out the full Lucid schedule > https://wiki.ubuntu.com/LucidReleaseSchedule

Rick Spencer was looking closely into pitivi as default in Lucid. He might know more about what's required.

Revision history for this message
Jeff Fortin Tam (kiddo) wrote : Re: [Bug 506642] Re: "Razor" , an odd name for the split tool

That deadline is definitely too close. I'm not a dev but I hang with them
almost every day and run pitivi git. Many issues from 0.13.3 are solved in
the git version. (See
https://bugzilla.gnome.org/buglist.cgi?query_format=advanced&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=NEEDINFO&bug_status=RESOLVED&bug_status=VERIFIED&target_milestone=0.13.4&product=pitivi
 )

...but, in my humble opinion, it's not progressing fast enough at the
moment. Unless expectations for new features are low. I'm quite worried
about a backlash from users that want fancy transitions and effects, for
example (but this may take a long time before it gets implemented, judging
from the state of things).

A list of criteria that would define what 0.13.4 would surely help,
especially in evaluating what can and cannot be done in that timeframe...
I'd then be able to provide a more insightful prediction. but I have my
doubts that a new release could be done within 2 weeks especially if it
means "more high profile features such as transitions/effects/revamped
rendering dialog/etc".

On the other hand, I don't think 0.13.3 would be supported for 3 years
(since the project can pretty much only afford to support last stable
release + the dev version), so I'm unsure what to do here. I don't want
0.13.3 to be the version shipped with Lucid, but time is short.

Revision history for this message
Vish (vish) wrote :

That seems to be a bit of troubling news.
Could you send a mail to the desktop mailing list regarding these concerns with version 0.13.3: > http://lists.ubuntu.com/mailman/listinfo/ubuntu-desktop

The desktop team would atleast be aware of the critical bugs which would need to be fixed before release.

Revision history for this message
Jeff Fortin Tam (kiddo) wrote :

I'll try to chat with at least one of the devs about this before posting to
that mailing list, I'll add that to my todo list.

In the meantime, I would also like to add that gstreamer good/bad/ugly
plugins only get released on february the 23th, if I recall correctly (see:
http://gstreamer.freedesktop.org/wiki/ReleasePlanning2010 ). This is past
the ubuntu feature freeze. PiTiVi depends heavily on them. Does ubuntu plan
to include them?

Revision history for this message
Vish (vish) wrote :

Jean-François , I'v mentioned your concerns to the desktop team.
They are looking into ways to speed things with pitivi [possible hackfest?] and considering all possible options. Thanks.

Changed in pitivi (Ubuntu):
importance: Undecided → Low
Revision history for this message
Sebastien Bacher (seb128) wrote :

the new version is in lucid now, closing that bug

Changed in pitivi (Ubuntu):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers