pitivi does not work with python2.6

Bug #339312 reported by j^ on 2009-03-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
PiTiVi
Invalid
Undecided
Unassigned
Nominated for Trunk by Kẏra
python-gst
Invalid
Undecided
Unassigned
gst0.10-python (Ubuntu)
Undecided
Unassigned
Declined for Jaunty by William Grant
pitivi (Ubuntu)
Medium
William Grant
Declined for Jaunty by William Grant

Bug Description

Binary package hint: pitivi

pitivi does not work with python 2.6 since it uses "as" as a variable name.
attached patch replaces offending variable with a save name

Related branches

j^ (j) wrote :
William Grant (wgrant) on 2009-03-08
Changed in pitivi:
assignee: nobody → wgrant
importance: Undecided → Medium
status: New → Triaged
William Grant (wgrant) on 2009-03-08
Changed in pitivi:
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pitivi - 0.11.3-1ubuntu1

---------------
pitivi (0.11.3-1ubuntu1) jaunty; urgency=low

  * debian/patches/01_python2.6_fix.patch: Add. Rename 'as' to 'asettings'
    in pitivi.timeline.timeline.Timeline.getAutoSettings(), to work with
    Python 2.6. (LP: #339312)

 -- William Grant <email address hidden> Sun, 08 Mar 2009 17:45:11 +1100

Changed in pitivi:
status: In Progress → Fix Released
Kẏra (thekyriarchy) wrote :

Pitivi is still broken for my with the gstreamer PPA enabled.

~$ sudo apt-get install pitivi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  pitivi: Depends: python-gst0.10 (>= 0.10.14-2~intrepid1) but 0.10.14-1ubuntu1 is to be installed
E: Broken packages

~$ sudo apt-get install python-gst0.10
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  python-gst0.10: Depends: python (< 2.6) but 2.6.1-0ubuntu3 is to be installed
E: Broken packages

Danny are you using intrepid or jaunty? And can you paste your sources.list?

Kẏra (thekyriarchy) wrote :

I'm using jaunty 64-bit and the gstreamer ppa i'm using is:
deb http://ppa.launchpad.net/gstreamer-developers/ppa/ubuntu jaunty main

I can't reproduce this. I can install and upgrade from that repo.

these are the python-gst0.10 deps i can see:

Package: python-gst0.10
Source: gst0.10-python
Version: 0.10.14.1~git20090312-1~jaunty1
....
Depends: libc6 (>= 2.4), libglib2.0-0 (>= 2.16.0), libgstreamer-plugins-base0.10-0 (>= 0.10.22), libgstreamer0.10-0 (>= 0.10.22), libpython2.6 (>= 2.6), libxml2 (>= 2.6.27), python (<< 2.7), python (>= 2.5), python-central (>= 0.6.11), python-gobject (>= 2.11.2), python-libxml2

so i don't know where that < 2.6 is coming from

Kẏra (thekyriarchy) wrote :

i removed some intrepid repos (oops) from my sources.list and that fixed the problem. the problem was on my end, sorry

William Grant (wgrant) wrote :

Regardless of the Intrepid lines, anything involving a PPA is not a bug in Ubuntu.

Changed in pitivi:
status: New → Invalid
Changed in python-gst:
status: New → Invalid
Changed in gst0.10-python (Ubuntu):
status: New → Invalid

yes but I didn't change the status as danny replied to an actual bug that was closed and the fix released

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers