[FFe] Please sync latest upstream release (0.9x) from Debian unstable - Pitivi developers recommends to use 0.92 or later

Bug #1253009 reported by Mantas Kriaučiūnas on 2013-11-20
68
This bug affects 11 people
Affects Status Importance Assigned to Milestone
pitivi (Baltix)
Medium
Mantas Kriaučiūnas
pitivi (Ubuntu)
Wishlist
Unassigned

Bug Description

Ubuntu Trusty still has old and outdated Pitivi version - 0.15, while Pitivi developers recommends to use 0.92 or later, see download page on http://pitivi.org :
Various Linux distributions provide Pitivi in their repositories, but the version provided may be too old. For an optimal experience, make sure you are using Pitivi 0.92

Please sync latest upstream Pitivi release (0.9x) from Debian experimental - AFAIK we have enough time until 14.04 import freeze to find if latest Pitivi release series is good enough for including into LTS release.

Pitivi Wiki also contains info, that 0.15 release is lower quality than 0.92:
That said, one month after 0.91, with the feedback we have received so far, we are pretty confident that the new release series is of much higher quality than the 0.15 series and older.
See http://wiki.pitivi.org/wiki/0.93
and http://wiki.pitivi.org/wiki/0.92

Addendum/Mirv: pitivi 0.15 end user experience as it is currently on Ubuntu makes most people to back away from it - it requires specific settings to not crash or hang, for example (I've found webm container to usually work, but the last time I tried that didn't work either which may be some bitrotting happening)

Related branches

Adolfo Jayme (fitojb) on 2013-11-20
Changed in pitivi (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
tags: added: upgrade-software-version
Jackson Doak (noskcaj) wrote :

There is a debian version in experimental. Can someone please investigate if we want to merge from there?

Changed in pitivi (Baltix):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Mantas Kriaučiūnas (mantas)
Mantas Kriaučiūnas (mantas) wrote :

Package from Debian Experimental contains small dependency bug (it seems Pitivi 0.92 requires python-gi (>=3.10) ), but it shouldn't cause any problem on Ubuntu 13.10 or newer, because python-gi version 3.10 is on Ubuntu 3.10 or newer and Pitivi 0.9x will start normally.
See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=732813

summary: - Please sync latest upstream release (0.9x) from Debian experimental -
- Pitivi developers recommends to use 0.92 or later
+ [FFe] Please sync latest upstream release (0.9x) from Debian
+ experimental - Pitivi developers recommends to use 0.92 or later

On 4 March 2014 21:39, Mathieu Duponchelle <email address hidden> wrote:
> Hey, I'm a maintainer of Pitivi, is there a reason preventing this from
> happening ?
>

Looking at the history it appears that at least 0.15.2 was packaged
before it was available in debian.
Now it is available, and differences (if there are any that matter)
need to be reconciled.
By default ubuntu syncs/merges from unstable, not experimental.
Ideally, debian maintainers should upload it to unstable, as otherwise
next debian stable will also be stuck with 0.15.x series.

I'll try to talk to them, next time i see them on irc.

--
Regards,

Dimitri.

> Hey, I'm a maintainer of Pitivi, is there a reason preventing this from happening ?

Ubuntu is feature frozen, an ffe is needed, see https://wiki.ubuntu.com/FreezeExceptionProcess

(seems like that bug is intended to be a ffe but nobody subscribed the "ubuntu-release" team to it, if you consider the bug ready to be reviewed you should do that)

Sebastien Bacher (seb128) wrote :

There is no activity/reply to my previous comment, if you are still interested in that update to happen for trusty you should file the ffe request...

Hi Sebastien, sorry for not getting back to you. Asking for ffe seems like an involved process, and we would need to ask for it for 4 separate components, pitivi itself, gst-editing-services, gst-python and gnonlin, not sure how doable that would be. Too bad for ubuntu ;)

Mantas Kriaučiūnas (mantas) wrote :

Good news for some Ubuntu users - latest and greatest Pitivi 0.93 packages are in ppa:gstreamer-developers/ppa , see:
https://launchpad.net/~gstreamer-developers/+archive/ppa

There also are latest and most stable releases of gstreamer-editing-services 1.2, gnonlin 1.2 and gst-python 1.2 :)

For more info about latest releases of Pitivi 0.93 and related gstreamer libraries see:
http://jeff.ecchi.ca/blog/2014/03/21/pitivi-0-93-released/
http://fundraiser.pitivi.org/blog/2014/03/21/gstreamer-hackfest-and-first-beta-release-pitivi-ra-happy/

Sadly, but currently Ubuntu 14.04 has older releases - 1.1.90 of gstreamer-editing-services, gnonlin and gst-python, see:
https://launchpad.net/ubuntu/+source/gst-python1.0
https://launchpad.net/ubuntu/+source/gnonlin1.0

Debian also has older (1.1.90) releases in experimental.
How I can help to get packaged final stable releases (1.2.0) of gstreamer-editing-services, gnonlin and gst-python in final Ubuntu 14.04 release?

Mathieu Duponchelle (mduponchelle1) wrote on 2014-03-21:
> Asking for ffe seems like an involved process, and we would need to ask for it for 4 separate components, pitivi itself, gst-editing-services, gst-python and gnonlin

description: updated
Sebastien Bacher (seb128) wrote :

> Asking for ffe seems like an involved process, and we would need to ask for it for 4 separate components, pitivi itself, gst-editing-services, gst-python and gnonlin, not sure how doable that would be

Did you read the wiki page before writing that? The bug here has most of the details it needed, you just needed to click subscribe and "ubuntu-release", that's easy enough ... just did it for you.

You are right that it's late in the cycle but the package is not on the default installation and it might make sense to get the new upstream release for the LTS, let's see what the release team says

Changed in pitivi (Ubuntu):
status: Triaged → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pitivi (Ubuntu):
status: New → Confirmed
Changed in pitivi (Ubuntu):
status: Confirmed → New
Changed in pitivi (Ubuntu):
status: New → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

This should probably remain set as "New" in order to be evaluated by the Release Team.

As a sidenote, pitivi 0.93-2 got uploaded to unstable now in Debian (earlier in experimental): http://packages.qa.debian.org/p/pitivi.html

Changed in pitivi (Ubuntu):
status: Confirmed → New
Timo Jyrinki (timo-jyrinki) wrote :

It seems also that the pre-requirements are met now, with gst-python1.0, gnonlin1.0 and gstreamer-editing-services1.0 at 1.2.0 as of today:

https://launchpad.net/ubuntu/+source/gst-python1.0/1.2.0-1
https://launchpad.net/ubuntu/+source/gnonlin1.0/1.2.0-1
https://launchpad.net/ubuntu/trusty/+source/gstreamer-editing-services1.0/1.2.0-2

description: updated
Timo Jyrinki (timo-jyrinki) wrote :

I compiled the new Pitivi from Debian in a PPA for easier trying out:

sudo apt-add-repository ppa:timo-jyrinki/pitivi
sudo apt-get update
sudo apt-get install pitivi

(https://launchpad.net/~timo-jyrinki/+archive/pitivi)

Works for me in my smoke test, although tends to be picky about formats even though I've plenty of GStreamer 1.0 plugins around.

summary: - [FFe] Please sync latest upstream release (0.9x) from Debian
- experimental - Pitivi developers recommends to use 0.92 or later
+ [FFe] Please sync latest upstream release (0.9x) from Debian unstable -
+ Pitivi developers recommends to use 0.92 or later
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pitivi (Ubuntu):
status: New → Confirmed
Changed in pitivi (Ubuntu):
status: Confirmed → New

I've just given the version in Timo's PPA a quick smoke test, and it looks good to me so far. Installs and upgrades cleanly. I'm able to import and edit videos, etc...

Upstream has already commented on this bug, but I think it is also worth pointing out that they explicitly state on their website that they "cannot investigate bugs that occur on older release series (such as 0.15.x)." So I feel it's important to get this into trusty.

(Setting back to New since Launchpad Janitor keeps fiddling with the status.)

Timo Jyrinki (timo-jyrinki) wrote :

A release team member asked for an Ubuntu Studio representative to comment on this bug, since pitivi is seeded on their image. Is there anyone following this report from there?

I updated the PPA with 0.93-3 and a slight Ubuntu specific update to keep generating .pot file for Launchpad.

However, I can see one problem with this newer pitivi - it depends on among else the new gstreamer-editing-services1.0 which is in universe repository, while pitivi itself is in main. I'd suggest demoting pitivi to community supported universe repository, which would solve the problem.

Eric Hedekar (stochastic) wrote :

As an old (and returning) Ubuntu Studio Developer I would support this FFE as the current version shipped is clearly past its end-of-life state. I will try to test it out personally soon but according to reports above, the new version is working well.

Kaj Ailomaa (zequence) wrote :

Looks fine to me also. I gave it a testrun. (Also, it's a greatly anticipated upgrade among many video editors from what I hear)

Michael Terry (mterry) wrote :

Yeah, looks like this could be safely demoted to universe.

$ seeded-in-ubuntu pitivi
pitivi (from pitivi) is seeded in:
  ubuntustudio: dvd

Eric Hedekar (stochastic) wrote :

My tests on the debian package in 14.04 turned out positive. I fully support inclusion into 14.04 if the release team allows it.

Scott Kitterman (kitterman) wrote :

Seems well tested and a significant update to get in. Approved. Get it done quickly though and make sure someone from Studio is subscribed to bugs.

Changed in pitivi (Ubuntu):
status: New → Triaged
Adam Conrad (adconrad) wrote :

syncpackage: Source pitivi -> trusty/Proposed: current version 0.15.2-0.2ubuntu1, new version 0.93-3
syncpackage: New changes:
pitivi (0.93-3) unstable; urgency=medium

  * debian/control:
    + Depend on python-gi (>= 3.10), older versions do not work
      with pitivi (Closes: #732813).
    + Add missing dependency on gir1.2-clutter-gst-2.0 (Closes: #743692).
    + Add suggests on gir1.2-notify-0.7 and gir1.2-gnomedesktop-3.0.

 -- Sebastian Dröge <email address hidden> Sat, 05 Apr 2014 15:28:16 +0200

pitivi (0.93-2) unstable; urgency=medium

  * debian/patches/01_disable-devel-mode.patch:
    + Fix typo in patch.
  * Upload to unstable.

 -- Sebastian Dröge <email address hidden> Sat, 29 Mar 2014 15:35:00 +0100

pitivi (0.93-1) experimental; urgency=medium

  * New upstream release candidate.

 -- Sebastian Dröge <email address hidden> Sat, 29 Mar 2014 15:22:50 +0100

pitivi (0.92-1) experimental; urgency=low

  * New upstream release candidate.

 -- Sebastian Dröge <email address hidden> Mon, 04 Nov 2013 20:38:20 +0100

pitivi (0.91-1) experimental; urgency=low

  * New upstream release candidate.

 -- Sebastian Dröge <email address hidden> Fri, 01 Nov 2013 10:22:08 +0100
Sync this package [y|N]? y
syncpackage: Request succeeded; you should get an e-mail once it is processed.

Changed in pitivi (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.