oneconf-service crashed with HTTPError in __negotiatehttp(): (403, 'Forbidden')

Bug #863717 reported by Jean-Baptiste Lallement on 2011-09-30
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
httplib2
Unknown
Unknown
piston-mini-client (Ubuntu)
High
Michael Vogt
Oneiric
High
Michael Vogt

Bug Description

I get this crash on 2 different systems when I update the package cache

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: oneconf 0.2.6.7
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
Date: Sat Oct 1 00:44:31 2011
ExecutablePath: /usr/share/oneconf/oneconf-service
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110209)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/oneconf/oneconf-service
PythonArgs: ['/usr/share/oneconf/oneconf-service']
SourcePackage: oneconf
Title: oneconf-service crashed with HTTPError in __negotiatehttp(): (403, 'Forbidden')
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Jean-Baptiste Lallement (jibel) wrote :
tags: removed: need-duplicate-check
visibility: private → public
description: updated
description: updated
Changed in oneconf (Ubuntu Oneiric):
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
affects: oneconf (Ubuntu Oneiric) → piston-mini-client (Ubuntu Oneiric)
Martin Pitt (pitti) on 2011-10-03
Changed in piston-mini-client (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Didier Roche (didrocks)
Didier Roche (didrocks) on 2011-10-03
Changed in piston-mini-client (Ubuntu Oneiric):
assignee: Didier Roche (didrocks) → nobody
assignee: nobody → Michael Vogt (mvo)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in piston-mini-client (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) wrote :

The problem here is that the python-httplib2 code will use socks.py for the proxying. That in turn only adds support
for proxy via the "CONNECT" method that requires a acl in squid. Not this is needed for https based proxying, but
for plain http this is not needed. The attach patch from the google project page fixes this by adding a new proxy
type for http with no tunnel. I think this is a good approach. The problem is of course that we add a interface to
a public library this way that is not part of upstream. So a better approach may actually be to "import socks"
first in python-httplib2 so that e.g. piston-mini-client can provide its own socks implementation with the patch applied.

Both the fix for python-httplib2 and the fixed branch for python-piston-mini-client are needed currently.

The attachment "Fix for python-httplib2 based on the patch in the google project" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Michael Vogt (mvo) wrote :

I think the attached piston-mini-client is actually sufficient and we can avoid the httplib2 patch.

Michael Vogt (mvo) on 2011-10-04
Changed in piston-mini-client (Ubuntu Oneiric):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package piston-mini-client - 0.6+bzr48-0ubuntu1

---------------
piston-mini-client (0.6+bzr48-0ubuntu1) oneiric; urgency=low

  * new bzr snapshot of the pending release:
    - work with http proxies that do not support CONNECT type of
      proxy (CONNECT acl/support is still required for https)
      (LP: #863717)
 -- Michael Vogt <email address hidden> Tue, 04 Oct 2011 16:50:29 +0200

Changed in piston-mini-client (Ubuntu Oneiric):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.