Should ship libpipewire0.2 alongside pipewire 0.3 for chrome support?

Bug #1899224 reported by Joe Barnett on 2020-10-10
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pipewire (Ubuntu)
Undecided
Unassigned

Bug Description

Per https://wiki.archlinux.org/index.php/PipeWire#WebRTC_screen_sharing, it appears that chrome/chromium need pipewire 0.2 userspace libraries installed for pipewire based screen sharing to work. (Verified that it doesn't appear to work with manually compiled, pipewire enabled builds of mutter/gnome-shell/xdg-desktop-portal and the chrome pipewire flag enabled, while building firefox with the fedora pipewire patch* is able to share screen on the same system).

*: https://src.fedoraproject.org/rpms/firefox/blob/master/f/firefox-pipewire-0-3.patch

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: pipewire 0.3.10-4
ProcVersionSignature: Ubuntu 5.8.0-20.21-generic 5.8.10
Uname: Linux 5.8.0-20-generic x86_64
ApportVersion: 2.20.11-0ubuntu49
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: GNOME
Date: Fri Oct 9 17:11:10 2020
InstallationDate: Installed on 2019-08-17 (419 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20190305.1)
RebootRequiredPkgs:
 evolution-data-server
 linux-image-5.8.0-21-generic
 linux-base
SourcePackage: pipewire
UpgradeStatus: Upgraded to groovy on 2020-09-28 (11 days ago)

Joe Barnett (thejoe) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pipewire (Ubuntu):
status: New → Confirmed
soredake (soredake) wrote :

Any progress on this?

Ernst Sjöstrand (ernstp) wrote :

Latest firefox doesn't seem to need this, they have 0.3 patches upstream now.

Tom Cook (tom-k-cook) wrote :

Firefox might not but lots of other things do.

It is allegedly possible to install the libpipewire0.2 binaries from an earlier Ubuntu on 20.10 but I've had no success doing so; no applications are able to share my screen (firefox, chrome, slack, teams...)

Rasmus Eneman (pie-or-paj) wrote :

Screensharing with Firefox and Chrome unstable works now in 21.04 but Chrome stable crashes. While chrome stable will probably start working before 21.04 is released (both 89 and 90 coming up), electron apps like Slack and Teams are usually not as fast to update and libpipewire0.2 would be great to have for supporting them.

Daniel van Vugt (vanvugt) wrote :

The crashes you mention are probably bug 1916716.

Rasmus Eneman (pie-or-paj) wrote :

>The crashes you mention are probably bug 1916716.

I tried your mentioned workaround and rebooted but Chrome still crashes. ctrl+shift+alt+r work now tough.

When Chrome crashes I get this in the terminal:
can't load /usr/lib/x86_64-linux-gnu/spa/support/libspa-support.so: /usr/lib/x86_64-linux-gnu/spa/support/libspa-support.so: cannot open shared object file: No such file or directory
zsh: segmentation fault google-chrome

Current stable chrome is 88 and according to this post https://jgrulich.cz/2020/12/18/webrtc-chromium-updates-in-2020/ 89 is the version that will probably receive 0.3 support so 88 would absolutely need libpipewire0.2 (and possible something else if it isn't libpipewire0.2 that provides libspa-support.so).

Tom Cook (tom-k-cook) wrote :

Some progress in 21.04. Screen sharing in Chrome now sort of works, but with some weirdness. I'm working on laptop with two external screens; sharing the laptop's built-in screen works, but sharing an external screen with a different resolution doesn't; I get a somewhat-old-school effect where the remote side sees three copies of my screen side-by-side with an interlaced effect.

Screen-sharing in Slack allegedly works now if you use a command-line argument to enable pipewire though I haven't had occasion to test it; Teams is still waiting for an update to the most recent version of Electron, though presumably the web client run in Chrome would work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers