pinentry-gtk2 does not register keys while scim-bridge is running

Bug #176815 reported by Louis-Dominique Dubeau on 2007-12-17
0
Affects Status Importance Assigned to Milestone
pinentry (Debian)
Fix Released
Unknown
pinentry (Ubuntu)
High
Unassigned
pinentry (openSUSE)
Unknown
Unknown

Bug Description

Binary package hint: pinentry-gtk2

Versions
=====

I'm running a current installation of Gutsy Gibbon (by "current" I mean all packages are at the latest published version).

pinentry-gtk2 is at version 0.7.3-1ubuntu2

How to reproduce
==========

Your input method configuration must be set to scim-pinyin. Then, try to perform any operation that requires a gpg key. (I've gotten the problem while trying to sign a binary file and also while running dpkg-buildpackage). pinentry-gtk-2 will come up but it won't register any keystrokes.

If I tell gpg not to use an agent, I can enter my password to the terminal prompt without any problem.

Here is how my input method configuration is set up:

$ im-switch -l
Your input method setup under en_US locale as below.
=======================================================
The configuration "/home/ldd/.xinput.d/en_US" is defined as a link pointing to
scim-pinyin
This private configuration supersedes the system wide default.
=======================================================
The system wide default is pointed by "/etc/alternatives/xinput-all_ALL" .
xinput-all_ALL - status is auto.
 link currently points to default
default - priority 10
none - priority 0
scim - priority 0
scim-immodule - priority 0
Current `best' version is default.
=======================================================
The available input method configuration files are:
default none scim scim-chewing scim-immodule scim-pinyin scim_xim th-xim
=======================================================

References:

This bug was reported in OpenSUSE also:

https://bugzilla.novell.com/show_bug.cgi?id=330073#c5

Unfortunately this next reference is in Japanese, a language I don't understand:

http://lists.sourceforge.jp/mailman/archives/scim-imengine-dev/2006-November/001429.html

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Xubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Xubuntu release, Hardy Heron 8.04.01 or Intrepid Ibex 8.10? The bug that was reported in OpenSUSE also: https://bugzilla.novell.com/show_bug.cgi?id=330073#c5 has been closed. However, there is an open bug at http://bugzilla.xfce.org/show_bug.cgi?id=4082 that I will link this to if it is still valid for you. Thanks in advance.

Changed in pinentry:
status: New → Incomplete
Charlie Kravetz (charlie-tca) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in pinentry:
status: Incomplete → Invalid
Louis-Dominique Dubeau (ldd) wrote :

This bug is no longer a problem for me. I'm running Ubuntu 8.10 and I have changed my input method to scim-bridge instead of scim-pinyin:

$ im-switch -l
Your input method setup under en_US locale as below.
=======================================================
The configuration "/home/ldd/.xinput.d/en_US" is defined as a link pointing to
scim-bridge
This private configuration supersedes the system wide default.
=======================================================
The system wide default is pointed by "/etc/alternatives/xinput-all_ALL" .
xinput-all_ALL - status is auto.
 link currently points to default
default - priority 10
default-xim - priority 0
none - priority 0
Current `best' version is default.
=======================================================
The available input method configuration files are:
default default-xim none scim scim-bridge scim-chewing scim-immodule scim-pinyin th-xim
=======================================================

I do not know whether the problem has in fact been properly fixed by an upgrade or whether changing from scim-pinyin to scim-bridge worked around the problem. Both scim-pinyin and scim-bridge use the scim-bridge module but they do it in slightly different ways.

Rolf Leggewie (r0lf) wrote :

it turns out this actually still a problem

Changed in pinentry (Ubuntu):
importance: Undecided → High
status: Invalid → Triaged
Changed in pinentry (Debian):
status: Unknown → Confirmed
Changed in pinentry (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.