Ubuntu

Gnome-Pilot Bluetooth HotSync Functions ONLY Once without "device" re-mapping

Reported by Manowar on 2009-05-08
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pilot-link (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-pilot

Syncing a Palm Centro with Ubuntu 9.04 evolution contacts & calendar works once (and only once!) after pairing and configuring the conduits. After that, the Centro displays the following message:

"Unable to initiate HotSync operation because the port is in use by another application"

Accord to Palm, this means that the host system is not allowing the device to connect via Bluetooth

After hours of tinkering, I have discovered a work-around, namely:

gnome-pilot Settings > Devices > Edit > Change BLUETOOTH to NETWORK > OK > Close
gnome-pilot Settings > Devices > Edit > Change NETWORK to BLUETOOTH > OK > Close

This will enable the Centro to HotSync, but again only ONCE. Therefore this procedure needs to be performed before EVERY sync.

UBUNTU: Ubuntu 9.04 2.6.28-11-generic i686 GNU/Linux
GNOME-PILOT: 2.0.17-0ubuntu1

Manowar (talon7) on 2009-05-08
summary: - Gnome-Pilot Bluetooth HotSync Functions ONLY Once foronce wihtout device
- restart
+ Gnome-Pilot Bluetooth HotSync Functions ONLY Once wihtout "device" re-
+ mapping
summary: - Gnome-Pilot Bluetooth HotSync Functions ONLY Once wihtout "device" re-
+ Gnome-Pilot Bluetooth HotSync Functions ONLY Once without "device" re-
mapping
Matt Davey (mcdavey) wrote :

I suspect this is a known pilot-link bug, present in version 0.12.2 and scheduled to be fixed in the 0.12.4 release.
  http://bugs.pilot-link.org/1872

You can check whether this is the problem by running gpilotd in a terminal window. If you see a segfault after sync then this bug is likely the cause.

It should be straightforward to patch using the diff attached to the above bug listing (fedora have been using the patch for over a year).

Matt Davey (mcdavey) wrote :

Attaching the pilot-link patch from pilot-link-bug 1872

I can confirm this exact behavior as described in Manowar. I can sync one time only. Then I have to switch the device to network and close, then bluetooth and close. Then I can sync once. I am grateful that I can sync via bluetooth at all, but it would be nice to get it working correctly.

Thomas G (thomas-gronwall) wrote :

I can also confirm this behavior. Thank you very much for the work-around. When will this bug fix be available?

Josef Wells (josefwells) wrote :

While doing the workaround dance as stated above, I tried something and seem to have it fixed!

gnome-pilot Settings > Devices > Edit > Change BLUETOOTH to USB > OK > Close

Now, when I sync, it just seems to work!

Note that I have a second "Cradle1" under Devices, that is set to Bluetooth (for another phone), that I did not change.

I seem to be able to Sync over and over again with the "Cradle" device set to USB.

Perhaps having one set to USB and the other to BLUETOOTH sets something to working.

Running a fairly up to date Karmic x64 system here.

gnome-pilot 2.0.17-0ubuntu2
gnome-pilot-conduits 2.0.15-1.2

Daniel Holbach (dholbach) wrote :

New releases have the updated version of pilot-link where Matt's patch is included.

affects: gnome-pilot (Ubuntu) → pilot-link (Ubuntu)
Changed in pilot-link (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers