Ubuntu

AIM account "Connection can't be established" error

Reported by Joe Barnett on 2011-08-22
110
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Adium
New
Unknown
BitlBee
Confirmed
Undecided
Unassigned
Pidgin
New
Unknown
Telepathy Haze
New
Undecided
Unassigned
empathy (Ubuntu)
Undecided
Unassigned
pidgin (Ubuntu)
Undecided
Unassigned

Bug Description

starting today, getting red box with "Connection can't be established" for my AIM account

debug logs show SSL Cert error:
Chain is VALID
Checking for a CA with DN=OU=Class 3 Public Primary Certification Authority,O="VeriSign, Inc.",C=US
Also checking for a CA with DN=OU=Class 3 Public Primary Certification Authority,O="VeriSign, Inc.",C=US
haze_notify_message: error: SSL Certificate Error
haze_notify_message: Unable to validate certificate
haze_notify_message: The certificate for api.screenname.aol.com could not be validated. The certificate chain presented is invalid.
Failed to verify certificate for api.screenname.aol.com
Connection error on 0x1532d40 (reason: 0 description: Error requesting https://api.screenname.aol.com/auth/clientLogin: Unable to connect to api.screenname.aol.com: SSL peer presented an invalid certificate)

connecting using pidgin works fine.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: empathy 3.1.5-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-9.12-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
Date: Mon Aug 22 13:42:56 2011
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: empathy
UpgradeStatus: Upgraded to oneiric on 2011-07-13 (40 days ago)

Joe Barnett (thejoe) wrote :
Joe Barnett (thejoe) wrote :

possibly related to bug #828756 ?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
David Krieg (david.a.krieg) wrote :

After reading bug #828756, I do not believe this is the same bug. Also, since it had a fix released late last month and I have the version of the packages supposed to contain the fix, I feel like it is a separate issue, perhaps isolated to the haze plugin.

Mari (piratemari) wrote :

Same as the above user - I think they are different bugs. I do NOT have the issue in bug #828756, with "connection is untrusted" warning dialogues. However, as of two days ago (I have had Oneric installed for over a week now) it says "connection cannot be established" when I try to connect to AIM, and notification popups continually ask for my password (which I have confirmed as working, and not being typed wrong).

Ian Sharum (typerextreme) wrote :

Last night empathy kept saying "disconnected - status is set to offline", when it wasn't. Today, it says "connection can't be established".

Ross Patterson (rossp) wrote :

I see this same error using bitlbee-libpurple so I think the issue is in libpurple. See also http://www.cocoaforge.com/viewtopic.php?f=13&t=23407.

Daniel Llewellyn (diddledan) wrote :

This bug is still present in the 12.04 beta1 version of empathy.

Bilal Shahid (s9iper1) wrote :

tell me your latest empathy and ubuntu version ?

Changed in empathy (Ubuntu):
status: Confirmed → Incomplete
Joe Barnett (thejoe) wrote :

still seeing this with latest 12.04 package (empathy 3.3.5)

when it happens, can usually get it to connect by killing telepathy-haze and reconnecting a bunch of times, but sometimes takes longer than others.

Changed in empathy (Ubuntu):
status: Incomplete → Confirmed
Bilal Shahid (s9iper1) wrote :

attach the mission control log with the bug ?
 you can get it from the help ==> debug menu
 and dont confirm your own bug.

Changed in empathy (Ubuntu):
status: Confirmed → Incomplete
Changed in adium:
status: Unknown → New
Joe Barnett (thejoe) wrote :
Download full text (87.0 KiB)

re-confirming with the info you requested, as initially confirmed by launchpad janitor, as well as Daniel Llewellyn's comment

mission control log:

mcd-DEBUG: 03/13/2012 09:43:57.248704: mcd_connection_reconnect: 0x15b1b10
mcd-DEBUG: 03/13/2012 09:43:57.248794: _mcd_connection_attempt: called for 0x15b1b10, account haze/aim/JjjoooeeE0
mcd-DEBUG: 03/13/2012 09:43:57.248850: _mcd_account_dup_parameters: called
mcd-DEBUG: 03/13/2012 09:43:57.248939: _mcd_account_set_connection_status: haze/aim/JjjoooeeE0: 1 because 1
mcd-DEBUG: 03/13/2012 09:43:57.248986: mcd_account_freeze_properties: haze/aim/JjjoooeeE0
mcd-DEBUG: 03/13/2012 09:43:57.249032: _mcd_account_set_connection_status: changing connection status from 2 to 1
mcd-DEBUG: 03/13/2012 09:43:57.249075: _mcd_account_set_connection_status: changing connection status reason from 2 to 1
mcd-DEBUG: 03/13/2012 09:43:57.249121: mcd_account_changed_property: called: Connection
mcd-DEBUG: 03/13/2012 09:43:57.249186: mcd_account_changed_property: First changed property
mcd-DEBUG: 03/13/2012 09:43:57.249456: mcd_account_changed_property: called: ConnectionStatus
mcd-DEBUG: 03/13/2012 09:43:57.249557: mcd_account_changed_property: called: ConnectionStatusReason
mcd-DEBUG: 03/13/2012 09:43:57.249630: mcd_account_changed_property: called: ConnectionError
mcd-DEBUG: 03/13/2012 09:43:57.249716: mcd_account_changed_property: called: ConnectionErrorDetails
mcd-DEBUG: 03/13/2012 09:43:57.249799: mcd_account_thaw_properties: haze/aim/JjjoooeeE0
mcd-DEBUG: 03/13/2012 09:43:57.249870: emit_property_changed: called
mcd-DEBUG: 03/13/2012 09:43:57.250060: mcd_account_connection_bind_transport: account haze/aim/JjjoooeeE0 transport remains 0x139ed80
mcd-DEBUG: 03/13/2012 09:43:57.250138: _mcd_connection_connect: called for 0x15b1b10, account haze/aim/JjjoooeeE0
mcd-DEBUG: 03/13/2012 09:43:57.250207: _mcd_connection_connect_with_params: Trying connect account: haze/aim/JjjoooeeE0
mcd-DEBUG: 03/13/2012 09:43:57.250282: _mcd_account_set_connection_status: haze/aim/JjjoooeeE0: 1 because 1
mcd-DEBUG: 03/13/2012 09:43:57.250349: mcd_account_freeze_properties: haze/aim/JjjoooeeE0
mcd-DEBUG: 03/13/2012 09:43:57.250417: mcd_account_thaw_properties: haze/aim/JjjoooeeE0
mcd-DEBUG: 03/13/2012 09:43:57.254750: request_connection_cb: created /org/freedesktop/Telepathy/Connection/haze/aim/JjjoooeeE
mcd-DEBUG: 03/13/2012 09:43:57.255469: _mcd_connection_set_tp_connection: new connection is 0x15df3c0
mcd-DEBUG: 03/13/2012 09:43:57.255562: mcd_account_changed_property: called: Connection
mcd-DEBUG: 03/13/2012 09:43:57.255649: mcd_account_changed_property: First changed property
mcd-DEBUG: 03/13/2012 09:43:57.256467: on_connection_status_changed: status_changed called from tp (2)
mcd-DEBUG: 03/13/2012 09:43:57.257850: mcd_connection_early_get_statuses_cb: /org/freedesktop/Telepathy/Connection/haze/aim/JjjoooeeE: Early Get(Statuses) succeeded
mcd-DEBUG: 03/13/2012 09:43:57.257953: presence_get_statuses_cb: account haze/aim/JjjoooeeE0:
mcd-DEBUG: 03/13/2012 09:43:57.258086: presence_get_statuses_cb: available
mcd-DEBUG: 03/13/2012 09:43:57.258223: presence_get_statuses_cb: busy
mcd-DEBUG: 03/13/2012 09:43:57.258352: presence_get_stat...

Changed in empathy (Ubuntu):
status: Incomplete → Confirmed
Bilal Shahid (s9iper1) wrote :

thanks for the info.
you can send ot to upstream now. and share the link here

Changed in empathy (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Confirmed

Home computer hasnt worked for a while. Work computer was working this morning(3/27/2012) until I ran the latest update and restarted. I'm now getting the same error on my work desktop:

on_connection_ready: got error: Error requesting https://api.screenname.aol.com/auth/clientLogin: Unable to connect to api.screenname.aol.com: SSL peer presented an invalid certificate

Alexander Hall (compuguy1088) wrote :

Having a similar issue with pidgin as well:

¨Unable to validate certificate - The certificate for api.screenname.aol.com could not be validated. The certificate chain presented is invalid.¨

Changed in pidgin:
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pidgin (Ubuntu):
status: New → Confirmed
Vova U (uwl) wrote :
Bilal Shahid (s9iper1) wrote :

for empathy is will be reported in bugzilla.org

GonzO (gonzo) wrote :

Please tell me this'll be fixed for the 12.04 release...?

GonzO (gonzo) wrote :

Also: Big thanks to Vova Uralsky, post #17. That worked!

deschmit (deschmit) wrote :

post #17 lets me connect, but my buddies no longer show up in my contact list. Know how to fix that?

Ross Patterson (rossp) on 2012-05-12
Changed in bitlbee:
status: New → Confirmed
Vova U (uwl) wrote :

2deschmit: same problem by me, after your buddy just sends you a message you see the contact, im not sure if it's also regression or not, have too few AIM contacts. I'll check this in lucid soon.

Vova U (uwl) wrote :

it's a regression, lucid is not affected, we are probably need to open a new bug for this issue

dougtwyman (dltwyman) wrote :

same problem for me , 12.04 64bit , the Vova Uralsky, post #17 fix worked ! thanks

Bilal Shahid (s9iper1) wrote :

thanks for info plz somebody send this bug to upstream now!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.