pidgin can no longer log in to ICQ

Bug #683076 reported by Captain Chaos on 2010-11-30
126
This bug affects 27 people
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
High
KarliMosh
Lucid
High
Unassigned

Bug Description

WORKAROUND:
Change server to login.icq.com
(ssl - off, client login - off)

---

Pidgin will no longer connect to ICQ. There are various existing bug reports about Pidgin not connecting to ICQ, but they all say something like "turn off SSL" or "turn on clientConnect" to work around it. It appears that none of these workarounds work any more. I have tried every combination of SSL and clientConnect, and Pidgin will not connect to ICQ with any of them:

use SSL off, use clientLogin off: "unknown reason"
use SSL on, use clientLogin off: "unknown reason"
use SSL off, use clientLogin on: "received unespected response from https://api.oscar.aol.com/aim/startOSCARSession: Invalid requested host"
use SSL on, use clientLogin on: "received unespected response from https://api.oscar.aol.com/aim/startOSCARSession: Invalid requested host"

Turning SSL on or off seems to make no difference at all (why is Piding trying to connect using HTTPS when SSL is off???), turning clientLogin on or off just changes the error message.

Please let me know how I can help debug this problem! Are there log files I can provide, debug loggin I can turn on, etc.?

Captain Chaos (launchpad-chaos) wrote :
gdcondor (florian2000) wrote :

Same problem here : it works yesterday by turning SSL off but it's not working at all today, same error messages

Petr Čermák (cermak-petr6) wrote :

Same here. I've just installed the lastest pidgin update and it still doesn't work. Empathy doesn't work either.

radek35 (radek35) wrote :

I had the same problem. Try to update Pidgin to 2.7.7. I did and it is working now.

Captain Chaos (launchpad-chaos) wrote :

Setting to confirmed in view of the number of people reporting this...

Ubuntu Lucid has version 2.6.6 of Pidgin. Since Lucid is an LTS version, would it be possible to back-port the fix to Piding 2.6, or to update the version of Pidgin in Lucid to 2.7?

Changed in pidgin (Ubuntu):
status: New → Confirmed
julianibus (jwienand) wrote :

Same problem. ICQ works with no program anymore.

julianibus (jwienand) wrote :

Got it working:
Change Server to slogin.icq.com

Changed in pidgin (Ubuntu):
assignee: nobody → julianibus (jwienand)
assignee: julianibus (jwienand) → nobody
Aequiternus (aequiternus) wrote :

Same problem.
>Change Server to slogin.icq.com
doesn't work for me

Marton Balazs (balazs-math) wrote :

>Change Server to slogin.icq.com
didn't solve for me either.

smarf (smarf) wrote :

Same problem here, slogin.icq.com didn't solve, tried every combination SSL / clientlogin

Mitja (i-launchpad-mitja-cc) wrote :

*flame* same here.. :/

lukas krejci (moodyluky) wrote :

I have same problem. When I uncheck SSL get: "https://api.oscar.aol.com/aim/startOSCARSession: Invalid requested host" When I uncheck SSL/client login I get: "Connection lost with server: Connection reset by peer" (transated from czech language) and when I chek only client login I get: I can't connect to BOS server: SSL Negotiation Failed (transated from czech language)

Empathy doesn't work either. :/

Oleg Kostyuchenko (c4eater) wrote :

slogin.icq.com didn't work for me either.
Pidgin 2.7.7, connecting to port 5190

Lively (lively-alex-mail) wrote :

Change server to login.icq.com
(pidgin 2.7.3, ssl - off, client login - off)

Alexander Somov (al-s) wrote :

It seems that 2.7.7 really works. Just found a workaround on forum.ubuntu.ru, and it solved the problem for me. Prebuilt packages for Lucid are available in ppa:pidgin-developers/ppa . After the update from this source there's no more error on log in to ICQ. Also this version uses some kind of magic :) It changes "login.messaging.aol.com" to "login.icq.com" and "slogin.oscar.aol.com" to "slogin.icq.com" on application restart.

lukas krejci (moodyluky) wrote :

#14

On Pidgin 2.6.6 it works too....

Aequiternus (aequiternus) wrote :

> ppa:pidgin-developers/ppa
it works now. thanks

Attached is a patch crafted from upstream's fix for the issue applied against 1:2.6.6-1ubuntu4.2. I recompiled pidgin and installed the libpurple0 deb, and now ICQ and AOL both work normally.

gdcondor (florian2000) wrote :

changing the server to login.icq.com with ssl and client login off solves the problem for me ! thanks !

On a side note, I simply added an entry in the changelog using 'debchange -b -v 1:2.6.6-0ubuntu4.3' to specify the version number for my recompiled package, and then put libpurple0 on hold by issuing 'printf "%s hold\n" | sudo dpkg --set-selections'.

This fixes it for me using Empathy, which relies upon libpurple0.

Now maybe Ubuntu will issue a fix for this issue shortly ... :)

The workaround from comment #14 (changing the server to login.icq.com) works for me too (on Pidgin 2.6)! And a patch is here too, looks like this will be sorted quickly... :-)

Michael Nagel (nailor) on 2010-11-30
description: updated
tags: added: patch
10111 (joachim-neu) wrote :

Can confirm both the issue and the workaround with Ubuntu 10.04 (Pidgin 2.6.6) AMD64.

Chuck Short (zulcss) wrote :

Hi,

Thanks for the patch can you please follow the process outlined as https://wiki.ubuntu.com/StableReleaseUpdates. I am unsubscribed the sponsor team since there is nothing to be done here.

chuck

Jonathan Riddell (jr) wrote :

Seems to be in lucid-proposed unapproved queue. Awaiting ubuntu-sru approval, not subscribed.

Changed in pidgin (Ubuntu Lucid):
status: New → Triaged
Changed in pidgin (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in pidgin (Ubuntu Lucid):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

the issue is already fixed in the natty version

Changed in pidgin (Ubuntu):
status: Triaged → Fix Released
Sebastien Bacher (seb128) wrote :

unsubscribing the sponsors since that has been uploaded

Accepted pidgin into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pidgin (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Any testers of the lucid-proposed package? As this has been in -proposed for nearly three months, I'll remove the proposed package soon if there is no feedback. Thank you!

Martin Pitt (pitti) wrote :

Patch was tested in comment 23.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pidgin - 1:2.6.6-1ubuntu4.3

---------------
pidgin (1:2.6.6-1ubuntu4.3) lucid-proposed; urgency=low

  * Apply upstream patch related to ICQ server changes. Thanks to
    Stephen Leavitt for digging out the patch (LP: #683076)
    - add debian/patches/95_icq_server_split_fix.patch
    - add debian/patches/96_icq_server_migration.patch
 -- Chris Coulson <email address hidden> Mon, 13 Dec 2010 10:21:49 +0000

Changed in pidgin (Ubuntu Lucid):
status: Fix Committed → Fix Released
KarliMosh (skania5) on 2011-07-26
Changed in pidgin (Ubuntu):
assignee: nobody → KarliMosh (skania5)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers