pidgin ICQ connection error

Bug #675903 reported by rexcze on 2010-11-16
206
This bug affects 86 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Omer Akram
Maverick
Undecided
Unassigned
pidgin (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Omer Akram
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: pidgin

Pidgin is not able to connect to ICQ network with this message: Received unexpected answer from https://api.oscar.aol.com/aim/startOSCARSession: Ok. I think it is solved in latest pidgin(as they say on web page), so someone should build latest pidgin for ubuntu 10.04 LTS! Why we have old packages in LTS (I understand to it in non LTS, but in LTS, strange)

TEST CASE:
- Make sure that SSL and clientLogin is activated in the ICQ account.
- Check if you can connect to ICQ.

Kay (noiq) wrote :

Confirming for 10.10 64bit.
On my 10.10 32bit system everything works all right for me.

John Doe (gehkacken02) wrote :

Problem still present on my 10.10 32bit install.

Thomas Barbier (thomas-barbier) wrote :

I have the same issue on my Ubuntu 10.10 64bits

AmenophisIII (amenophisiii) wrote :

this is (again, see bug 506647) probably a server problem only. disabling ssl "solves" the problem.

Thomas Barbier (thomas-barbier) wrote :

Thanks AmenophisIII !!! :-)

gabriela (salvie) wrote :

I'm using Ubuntu 10.10 64bit. When I start Pidgin (which is still 2.7.3 from Ubuntu) it shows "XXXXXX deaktiviert" and "Unbekannter Grund" (while XXXXXX is my ICQ UIN, "Deaktiviert" means "disabled" and "Unbekannter Grund" means "unknown reason"). When I login with my ICQ UIN on the icq.com web page, it works and it shows my contacts. So my account isn't disabled on the ICQ side. There must be something wrong with pidgin or ICQ. Did AOL/ICQ change once again their protocols? Maybe the problem could be solved with Pidgin 2.7.5, but I didn't get any updates. Here it's still 2.7.3. I'm reluctant to switch to manually installed program versions, because this would mean to manually check for updates for one more application.

When I look at the ICQ account settings, SSL is *not* checked. The server name is login.messaging.aol.com, port 5190. I have installed and often use the OTR plugin, but IMHO this shouldn't interfere with logging into ICQ.

Kay (noiq) wrote :

I have the same settings as gabriela including *no* SSL checked and the OTR plugin (and the german translations ;-) ). So I obviously commented the wrong bug.

The solution to my to this problem is to check the "use clientLongin".

Michael (m-laubach) wrote :

I have the problem on 10.4 32bit.

Turning of SSL helped me as well. Thanks for the workaround.

Dominik (dominik-dbruhn) wrote :

I had to turn of SSL and turn on "Client Login", does somebody know what this setting does? Why can't we use SSL?

ernie_6234 (heis2201) wrote :

Empathy, Ubuntu 10.04.1 (lucid) 32-bit, same problem, deactivation SSL is no solution for me!

pberndt (phillip-berndt) wrote :

Same here, Maverick 32 Bit:
Disabling SSL fixes the problem for me. However, on my notebook this is not an option.

Please update the (stable) repositories' package to the fixed upstream version.

Felix Geyer (debfx) wrote :

The ICQ connection error is fixed in Pidgin 2.7.5 (natty).

Changed in pidgin (Ubuntu):
status: New → Fix Released
Felix Geyer (debfx) wrote :

I've attached a debdiff that backports the relevant commits to bug #676972

Changed in pidgin (Ubuntu):
importance: Undecided → Medium
gabriela (salvie) wrote :

Until the fix is distributed (it wasn't in today's updates), it seems like turning off SSL *and* turning on "Client Login" will do the trick. Thanks @Dominik for that hint.

Accepted pidgin into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pidgin (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
rexcze (rexcze) wrote :

Ok, but what about Ubuntu 10.04 LTS? Will it be released?

Felix Geyer (debfx) on 2010-11-22
description: updated
Kay (noiq) wrote :

The maverick-proposed version works fine for me with SSL and clientLogin.

Skippa skippa (skippa) wrote :

The -proposed version works fine for me on Lucid 10.04 LTS with SSL, client login and aim server activated. Thanks.

Martin Pitt (pitti) wrote :

Skippa, which version did you test? We didn't push out an update for lucid yet?

I'll waive the usual 7 day testing period for this update and release it now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pidgin - 1:2.7.3-1ubuntu3.2

---------------
pidgin (1:2.7.3-1ubuntu3.2) maverick-proposed; urgency=low

  [ Chow Loong Jin ]
  * debian/patches/workaround-msn-ssl-failure.patch: Workaround SSL
    connectivity issues with MSN (LP: #676972)

  [ Felix Geyer ]
  * debian/patches/62_icq_server_changes.patch: Adapt to ICQ server changes.
  * debian/patches/63_icq_server_migration.patch: Migrate existing accounts to
    the new login server names. (LP: #675903)
 -- Felix Geyer <email address hidden> Sat, 20 Nov 2010 13:37:00 +0100

Changed in pidgin (Ubuntu Maverick):
status: Fix Committed → Fix Released
Vasya Pupkin (shadowlmd) wrote :

Can this fix be included into 10.04 LTS please? ICQ is not working there for more than month already.

Omer Akram (om26er) wrote :

lucid users can use this ppa to upgrade libpurple to get empathy working again i think. https://launchpad.net/~pidgin-developers/+archive/ppa/

Changed in empathy (Ubuntu):
status: New → Fix Released
Changed in empathy (Ubuntu Maverick):
status: New → Fix Released
Tomofumi (tomofumi) wrote :

thanks omer for the ppa links, i can confirm that it fixed the icq login error in 10.04, hopefully it would solved the MSN omega cert error as well ;)

Vasya Pupkin (shadowlmd) wrote :

For some reason, libpurple from ppa did not fix issue with Empahy for me. There were no login error, but there were no contacts in contact list after login as well.

Vasya Pupkin (shadowlmd) wrote :

It's fixed in 10.04 now, by the way.

TiloBunt (til0) wrote :

as this should be a dup from https://bugs.launchpad.net/empathy/+bug/676060 :

Still not!! working in 10.04 with Empathy 2.30.3 (checked for updates today)

Linux t-laptop 2.6.32-27-generic #49-Ubuntu SMP Thu Dec 2 00:51:09 UTC 2010 x86_64 GNU/Linux

libpurp. pack:
1:2.6.6-1ubuntu4.2

TiloBunt (til0) wrote :

FYI, now (today) fixed in 10.04. Thanks.

Martin Pitt (pitti) on 2011-02-01
tags: added: verification-done
removed: verification-needed
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers