pidgin crashed with SIGSEGV in pidgin_conv_window_add_gtkconv()

Bug #474211 reported by johniez on 2009-11-04
50
This bug affects 11 people
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pidgin

Crash after closing window with messages (I have opened another one with chat and they don't join into tabs)

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Wed Nov 4 14:48:10 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/pidgin
Package: pidgin 1:2.6.2-1ubuntu7
ProcCmdline: pidgin
ProcEnviron:
 LANG=cs_CZ.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SegvAnalysis:
 Segfault happened at: 0x80a1b1e <pidgin_conv_window_add_gtkconv+1070>: mov 0x2c(%eax),%eax
 PC (0x080a1b1e) ok
 source "0x2c(%eax)" (0x0000002c) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: pidgin
StacktraceTop:
 pidgin_conv_window_add_gtkconv ()
 ?? ()
 purple_conversation_new () from /usr/lib/libpurple.so.0
 ?? ()
 purple_marshal_VOID__POINTER_POINTER_POINTER_POINTER_UINT ()
Title: pidgin crashed with SIGSEGV in pidgin_conv_window_add_gtkconv()
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

johniez (johniez) wrote :

Out of curiosity, do you hide new conversations by default?

Nizar Kerkeni (nizarus) wrote :

this is happening randomly when closing any conversation window not only new ones.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Do you get the same with Lucid or Maverick? Thanks in advance.

Changed in pidgin (Ubuntu):
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in pidgin (Ubuntu):
status: Incomplete → Invalid
Marcus Brito (mbrito) wrote :

I've just run into this bug -- pidgin crashed after I tried to close a conversation (by pressing ESC). I do hide new conversations by default (Always).

Alex Shulgin (alex-shulgin) wrote :

I'm also affected by this bug. It only started to happen after upgrade to Natty from Maverick (clean install.)

See my new bug report here: https://bugs.launchpad.net/ubuntu/+source/pidgin/+bug/804164

Chrescht (sekateur) wrote :

Happened to me on Ubuntu 11.10 with pidgin 2.10.0.

Changed in pidgin (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pidgin (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers