Pidgin/Gaim doesn't include SILC support

Bug #44728 reported by Sean Cassidy on 2006-05-14
46
Affects Status Importance Assigned to Milestone
gaim (Debian)
Fix Released
Unknown
pidgin (Ubuntu)
Wishlist
Ubuntu Desktop Bugs
Nominated for Hardy by agent 8131
Nominated for Intrepid by agent 8131
silc-toolkit (Debian)
Fix Released
Unknown

Bug Description

Binary package hint: gaim

Gaim doesn't compile in SILC support. All that is needed is for the SILC libraries to be installed when running ./configure.

Related branches

not currently, as there is no silc toolkit deb available. i believe the
silc team is working to get a package accepted.

On Tue, Jul 20, 2004 at 04:18:38PM +0200, Katarina Machalkova wrote:
> Subject: gaim: Gaim Silc support
> Package: gaim
> Version: 1:0.80-3
> Severity: wishlist
>
> Can Silc support be included in Gaim debian package ? There is a source
> tarball and rpm's downloadable from silcnet.org webpage, but I didn't
> find anything for debian there yet.
>
>
> --
> "... and if you ask, then you must know.
> If you still doubt, you should be told..."
>
> Katarina "Bubli" Machalkova
> spravce bloku D

Now that silc-toolkit has made it into Debian, it's just a matter of
build-depending on libsilc-dev and recompiling (eventually you'd have to
point --with-silc-include to the right includes)

Cheers,
Michele

It would be even better if there were a separate gaim-silc package, so as not
to make the normal gaim package depend on libsilc.

it would be better yet if gaim could detect the toolkit as provided by
the libsilc and libsilc-dev packages ;-)

luke

On Mon, Aug 23, 2004 at 08:14:34PM -0500, Mark Doliner wrote:
> It would be even better if there were a separate gaim-silc package, so as not
> to make the normal gaim package depend on libsilc.
>
>

# Automatically generated email from bts, devscripts version 2.8.4
package gaim
merge 268853 260420

This bug is fixed.
There's silc support in latest Debian gaim.

reopen 268853
thanks

Huh? No there isn't.
> This bug is fixed.
> There's silc support in latest Debian gaim.

reopen 260420
reopen 268853
thanks

Uhm... unless somebody has NMU'd it in the past few hours, the Debian
Gaim package does not contain SILC support, and won't do so until
#273871 is fixed. The SILC client library is packaged by somebody who
apparently denies that shared libraries have versions. I do not want to
introduce a dependency on these broken packages, because it will break
when SILC undergoes any API or ABI changes in the future. I'd prepare an
NMU if I cared about SILC, but I don't. I'd refer this bug to the
technical committee if I believed anything would actually happen.

Regards,
Rob

Package: libsilc-1.0-2
Version: 0.9.12-4.1
Severity: grave
Justification: renders package unusable

It appears the NMU for libsilc is missing the actual libraries. Only
the documentatios under /usr/share/doc/libsilc-1.0-2/ is in the package,
and nothing else:

$ dpkg -L libsilc-1.0-2
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/libsilc-1.0-2
/usr/share/doc/libsilc-1.0-2/changelog.gz
/usr/share/doc/libsilc-1.0-2/copyright
/usr/share/doc/libsilc-1.0-2/changelog.Debian.gz

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.11.10-leviathan
Locale: LANG=C, LC_CTYPE=en_US (charmap=ISO-8859-1)

-- no debconf information

merge 328889 331630
kthxbye

--
----------------------------
Michael Schultheiss
E-mail: <email address hidden>

The patch from ubuntu fixes this.

http://packages.qa.debian.org/s/silc-toolkit.html

The debian/*.install files are misnamed.

Hi,

I've fixed the *.install files and uploaded an NMU. interdiff attached.

Happy birthday, vorlon!

--
off the chain like a rebellious guanine nucleotide

Binary package hint: gaim

Gaim doesn't compile in SILC support. All that is needed is for the SILC libraries to be installed when running ./configure.

Richard Laager (rlaager) wrote :

The libsilc package in Debian has serious problems. That's likely why this hasn't been done yet.

Sean Cassidy (slamsean) wrote :

Richard: problems like what? Is there a bug report? I'm using upstream silc libraries and they work fine.

Luke Schierer (lschiere) wrote :

Right, the upstream tarballs are fine. It is the debian package that has issues. For example, being empty.

Sean Cassidy (slamsean) wrote :
Luke Schierer (lschiere) wrote :

there have been two silc toolkit packages for debian. I do not know which has made it into ubuntu.

However, in current debian (again, I'm unsure of ubuntu), the only silc package is libsilc-1.0-2 for which I see the following:
luke@shorty:~/doc/gaim/gaim.my$ dpkg -L libsilc-1.0-2
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/libsilc-1.0-2
/usr/share/doc/libsilc-1.0-2/copyright
/usr/share/doc/libsilc-1.0-2/changelog.Debian.gz
/usr/share/doc/libsilc-1.0-2/changelog.gz
luke@shorty:~/doc/gaim/gaim.my$

It thus contains nothing except a changelog and a copyright. To this the -dev package adds several READMEs, a TODO, and a credits file.

In Ubuntu the packages are filled:

dennis@blackbird:~$ dpkg -L libsilc-1.0-2 libsilc-1.0-2-dev | wc -l
1142

They are a mess though, see
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=273871 which is
supposedly fixed in Debian but not yet in Ubuntu. Enabling the gaim silc
plugin will require:

1) A sync of libsilc from debian
2) A main inclusin report for libsilc
3) A patch to the gaim package

This will *not* happen for Dapper due to the various freezes that are
currently in effect.

I've testbuilt gaim with --enable-silc once for breezy (with the messy
libsilc package) and it seemed to work fine, so this will be a nice
thing to have in edgy.

there is no --enable-silc flag to configure. Unless you are specifying which protocols to build with either --with-static-prpls or --with-dynamic-prpls (both of which take a list of protocols to build, ie --with-dynamic-prpls=oscar,irc) then SILC support will be built if the silc libraries are discovered by configure at build time. As they are often at non-standard locations (ie /usr/local/silc), there are --with-silc-includes=DIR and --with-silc-libs=DIR configure flags, but I would highly doubt these would be necessary for a debian package of libsilc. Still, I imagine that #s 1 and 2 would block even though #3 should be a non-issue.

Richard Laager (rlaager) wrote :

For the record:
At this point, I think the best thing to do is to make sure that the libsilc package is fixed upstream to actually include contents while still fixing the soname issue. If that's done, it'll surely be synced to Ubuntu, and then you can presumably request Gaim to be built with libsilc support (which might require libsilc getting into main if it's not already).

> there is no --enable-silc flag to configure.

heh, then my memory is failing me :)

Adam Petaccia (mighmos) on 2006-05-17
Changed in gaim:
status: Unconfirmed → Confirmed

Will be fixed after dapper

Changed in gaim:
assignee: nobody → desktop-bugs
status: Confirmed → Fix Committed

If a new package was uploaded, why hasn't there been an update shown on
packages.debian.org? Also, this bug is still open?

Richard

Erinn Clark <email address hidden> writes:

> I've fixed the *.install files and uploaded an NMU. interdiff attached.

Looks like it didn't make it to the archive. Can you re-upload?

Thanks,

Matej

# Automatically generated email from bts, devscripts version 2.9.20
block 333907 with 331630

tag 331630 + fixed

quit

This message was generated automatically in response to a
non-maintainer upload. The .changes file follows.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 25 Jul 2006 17:50:00 +0200
Source: silc-toolkit
Binary: libsilc-1.0-2-dev libsilc-1.0-2
Architecture: source i386
Version: 0.9.12-4.3
Distribution: unstable
Urgency: high
Maintainer: Tamas SZERB <email address hidden>
Changed-By: Julien Danjou <email address hidden>
Description:
 libsilc-1.0-2 - SILC library (silc-toolkit)
 libsilc-1.0-2-dev - developer files for SILC library (silc-toolkit)
Closes: 331630
Changes:
 silc-toolkit (0.9.12-4.3) unstable; urgency=high
 .
   * Non-maintainer upload.
   * Fix empty packages (Closes: #331630)
   * Bump standards version
Files:
 a1ccf2890546b5148dd4f5cff17a26fc 620 devel optional silc-toolkit_0.9.12-4.3.dsc
 08ad0404186c2db76fc277e97f682d01 22057 devel optional silc-toolkit_0.9.12-4.3.diff.gz
 a069be97f426bee879236df439bee308 995216 libdevel optional libsilc-1.0-2-dev_0.9.12-4.3_i386.deb
 50ff7fd9023a455e0f9a00b9e21b5d69 410048 libs optional libsilc-1.0-2_0.9.12-4.3_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFExkK6pGK1HsL+5c0RAhtyAJ0ZPjszNe3c0VoiOBGGlk8SlcCVAwCeJ6fU
zEhUp+DTnLqrn9WVjxfvpHQ=
=UDBH
-----END PGP SIGNATURE-----

Changed in silc-toolkit:
status: Unconfirmed → Fix Committed

We're heading into Edgy but I can't see any packages in the Edgy repos that will fix this. Is this still planned to be in Edgy? Silc support is really important to me.

Sebastien Bacher (seb128) wrote :

not fixed yet or the bug would have been updated

Daniel Holbach (dholbach) wrote :

Somebody needs to write a main inclusion report for silc-toolkit (http://wiki.ubuntu.com/UbuntuMainInclusionQueue) and test gaim built with silc

Thanks for your advice, Daniel.

I have created https://wiki.ubuntu.com/MainInclusionReportSilc-toolkit with as much as I can do alone. I haven't done a main inclusion report before, so it still needs work from someone who knows what they are doing. Hopefully all the links etc. that I have put in there will save that person a fair amount of time. I haven't added it to the queue.

Daniel Holbach (dholbach) wrote :

Thanks for your work on that. Now it'd be good to have gaim built with silc and see how stable it is and how much sense it makes to ship it to our users.

Changed in silc-toolkit:
status: Fix Committed → Fix Released

Daniel is correct. I don't feel comfortable filling in any more of the gaps and didn't want to link it to the Queue because it wasn't complete.

Sorry if I have confused people :).

Robert McQueen said:
> Uhm... unless somebody has NMU'd it in the past few hours, the Debian
> Gaim package does not contain SILC support, and won't do so until
> #273871 is fixed. The SILC client library is packaged by somebody who
> apparently denies that shared libraries have versions. I do not want to
> introduce a dependency on these broken packages, because it will break
> when SILC undergoes any API or ABI changes in the future. I'd prepare an
> NMU if I cared about SILC, but I don't. I'd refer this bug to the
> technical committee if I believed anything would actually happen.

Hi,

At last, #273871 concerning silc has been closed.

Could you provide gaim with silc support ?

Regards,

--
Simon Paillard

No, because the bug was closed due to libsilc being removed from Debian.
Which reminds me, I need to close these bugs as it is no longer possible
to build the SILC plugin without a working libsilc package.

Simon Paillard wrote:
> Hi,
>
> At last, #273871 concerning silc has been closed.
>
> Could you provide gaim with silc support ?
>

reopen 260420 !
reopen 268853 !
thanks

Judging from http://packages.qa.debian.org/s/silc-toolkit.html there seems to be
a proper version of libsilc in Debian, thus I'd ask for another attempt to
incorporate silc in gaim.

Thanks,
Michael

Why is this marked as fix committed? As I understand it there is still no fix.

I have added the package to the queue in the hope that it will encourage somebody that knows what they are doing to fill the holes.

Sebastien Bacher (seb128) wrote :

fix commited make easier to spot changes to do for the next upload usually, that one will not be changed now though, marking as confirmed instead then

Changed in gaim:
status: Fix Committed → Confirmed
Changed in gaim:
status: Unknown → Unconfirmed

and it seems the guy who did it this time understands that libraries have versions.

tags 260420 patch
thanks

Now that silc-toolkit is back on track in main, i just tried building
gaim with silc enabled.

It appears to work for me. i connected to a silc server and it was
able to chat with folks, though it didn't appear to be able to cope
with a private key that had a passphrase on it.

I made very minor changes to the debian package to get it to build.

I'm publishing those changes here:

  http://lair.fifthhorseman.net/~dkg/src/silc/add-silc-to-debian-gaim.diff

but they're small enough to include as a straight diff, below.

Please let me know if i can help get this moving again. it would be
great to have SILC available on gaim in debian.

Regards,

 --dkg

diff -ru gaim-2.0.0+beta5.clean/debian/changelog gaim-2.0.0+beta5/debian/changelog
--- gaim-2.0.0+beta5.clean/debian/changelog 2007-01-08 13:12:31.000000000 -0500
+++ gaim-2.0.0+beta5/debian/changelog 2007-01-08 13:19:05.000000000 -0500
@@ -1,3 +1,10 @@
+gaim (1:2.0.0+beta5-9.1) unstable; urgency=low
+
+ * NMU.
+ * added silc support.
+
+ -- Daniel Kahn Gillmor <email address hidden> Mon, 8 Jan 2007 13:19:05 -0500
+
 gaim (1:2.0.0+beta5-9) unstable; urgency=low

   * 15_file_save_name.patch:
diff -ru gaim-2.0.0+beta5.clean/debian/control gaim-2.0.0+beta5/debian/control
--- gaim-2.0.0+beta5.clean/debian/control 2007-01-08 13:12:31.000000000 -0500
+++ gaim-2.0.0+beta5/debian/control 2007-01-08 13:16:42.000000000 -0500
@@ -10,7 +10,7 @@
  libstartup-notification0-dev, libzephyr-dev, libxml2-dev,
  libebook1.2-dev, libedata-book1.2-dev, libcamel1.2-dev,
  libdbus-glib-1-dev, dbus, python (>= 2.4), libavahi-compat-howl-dev,
- libxml-parser-perl, libncursesw5-dev
+ libxml-parser-perl, libncursesw5-dev, libsilc-1.0-2-dev
 Standards-Version: 3.6.1
 XS-Vcs-Svn: svn://svn.debian.org/svn/pkg-gnome/unstable/gaim

diff -ru gaim-2.0.0+beta5.clean/debian/rules gaim-2.0.0+beta5/debian/rules
--- gaim-2.0.0+beta5.clean/debian/rules 2007-01-08 13:12:31.000000000 -0500
+++ gaim-2.0.0+beta5/debian/rules 2007-01-08 13:16:58.000000000 -0500
@@ -13,7 +13,7 @@
 LDFLAGS = -Wl,--as-needed

 # for gaim
-DEB_CONFIGURE_EXTRA_FLAGS := --enable-perl --disable-silc --with-zephyr=/usr --enable-dbus --enable-gnutls=no --enable-nss=yes
+DEB_CONFIGURE_EXTRA_FLAGS := --enable-perl --enable-silc --with-zephyr=/usr --enable-dbus --enable-gnutls=no --enable-nss=yes
 DEB_DH_MAKESHLIBS_ARGS_gaim := -V -X/usr/lib/gaim
 DEB_DH_SHLIBDEPS_ARGS_gaim := -X/usr/lib/gaim/libgg.so -X/usr/lib/gaim/libzephyr.so -X/usr/lib/gaim/tcl.so -X/usr/lib/gaim/gevolution.so -X/usr/lib/gaim/libsametime.so -- -dSuggests debian/gaim/usr/lib/gaim/libgg.so debian/gaim/usr/lib/gaim/libzephyr.so debian/gaim/usr/lib/gaim/tcl.so debian/gaim/usr/lib/gaim/libsametime.so -dDepends

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Any word on getting silc into gaim? i see a new version of gaim just
dropped into experimental, which includes cyrus SASL support. Cyrus
SASL is good news for folks concerned with secure instant messaging.
Thanks! Adding SILC back in would be even more good news.

If there's a policy-based, technical, or political reason to exclude
SILC from gaim, that'd be understandable. If that's the case, just
say what it is (and close this bug wontfix) and i won't keep bugging
you about it ;)

Otherwise, the silc-enabling changeset is actually pretty small, and
worth trying, especially if we're using the experimental repository.

Thanks again for maintaining Gaim in debian. It's good to have the
flagship free IM client so well-supported in our distro!

Regards,

 --dkg
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Processed by Mailcrypt 3.5.8+ <http://mailcrypt.sourceforge.net/>

iD8DBQFFvPJXiXTlFKVLY2URAvyoAJ0ekSFbBXYT+FwEFjpM1L3Y9LNQNQCg0H5J
QvQmtM3ATtUj5JejA/h4eZ0=
=kWqV
-----END PGP SIGNATURE-----

This is mostly because I didn't feel that the libsilc package in Debian
has matured enough to be built with gaim and be a possible blocker for it.
libsilc hasn't been updated to a new upstream version in more than 2
years, even though there have been new releases since then.

Daniel Kahn Gillmor wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Any word on getting silc into gaim? i see a new version of gaim just
> dropped into experimental, which includes cyrus SASL support. Cyrus
> SASL is good news for folks concerned with secure instant messaging.
> Thanks! Adding SILC back in would be even more good news.
>
> If there's a policy-based, technical, or political reason to exclude
> SILC from gaim, that'd be understandable. If that's the case, just
> say what it is (and close this bug wontfix) and i won't keep bugging
> you about it ;)
>
> Otherwise, the silc-enabling changeset is actually pretty small, and
> worth trying, especially if we're using the experimental repository.
>
> Thanks again for maintaining Gaim in debian. It's good to have the
> flagship free IM client so well-supported in our distro!

reassign 260420 pidgin
forcemerge 424935 260420
thanks

The libsilc packages are currently in the process of being updated and
fixed, and I don't plan on enabling silc support until after that
happens.

Should this one be assigned to the pidging package now?

Sebastien Bacher (seb128) wrote :

Caspar, feel free to reassign bugs from gaim to pidgin when it makes sense if you want, the gaim bugs are still open though so there is no hurry

Source: pidgin
Source-Version: 2.0.2-1

We believe that the bug you reported is fixed in the latest version of
pidgin, which is due to be installed in the Debian FTP archive:

pidgin-data_2.0.2-1_all.deb
  to pool/main/p/pidgin/pidgin-data_2.0.2-1_all.deb
pidgin-dbg_2.0.2-1_amd64.deb
  to pool/main/p/pidgin/pidgin-dbg_2.0.2-1_amd64.deb
pidgin-dev_2.0.2-1_all.deb
  to pool/main/p/pidgin/pidgin-dev_2.0.2-1_all.deb
pidgin_2.0.2-1.diff.gz
  to pool/main/p/pidgin/pidgin_2.0.2-1.diff.gz
pidgin_2.0.2-1.dsc
  to pool/main/p/pidgin/pidgin_2.0.2-1.dsc
pidgin_2.0.2-1_amd64.deb
  to pool/main/p/pidgin/pidgin_2.0.2-1_amd64.deb
pidgin_2.0.2.orig.tar.gz
  to pool/main/p/pidgin/pidgin_2.0.2.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Ari Pollak <email address hidden> (supplier of updated pidgin package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: RIPEMD160

Format: 1.7
Date: Thu, 12 Jul 2007 10:37:09 -0400
Source: pidgin
Binary: pidgin-dbg pidgin-dev pidgin-data pidgin
Architecture: source amd64 all
Version: 2.0.2-1
Distribution: unstable
Urgency: low
Maintainer: Robert McQueen <email address hidden>
Changed-By: Ari Pollak <email address hidden>
Description:
 pidgin - multi-protocol instant messaging client
 pidgin-data - multi-protocol instant messaging client - data files
 pidgin-dbg - Debugging symbols for Pidgin
 pidgin-dev - multi-protocol instant messaging client - development files
Closes: 260420 429222 429623
Changes:
 pidgin (2.0.2-1) unstable; urgency=low
 .
   * New upstream version (Closes: #429222)
   * Enable SILC support (Closes: #260420)
   * 21_purple-remote_syntax.patch:
     - Fix syntax error in purple-remote script (Closes: #429623)
Files:
 619036a98399c05bc695f52f9544ea55 1278 net optional pidgin_2.0.2-1.dsc
 cffc242d50cc2a0bf0fdf06bdb5c6efd 11022798 net optional pidgin_2.0.2.orig.tar.gz
 9b903d96a660a5509239b4f71cea3d39 37741 net optional pidgin_2.0.2-1.diff.gz
 6d4b9f75ac769bbb13bf2ca638bab59e 6123876 net optional pidgin-data_2.0.2-1_all.deb
 c2869cfcaa5f6afec37715c5dbfd3b7c 218398 devel optional pidgin-dev_2.0.2-1_all.deb
 8b9581e008346d44ca7674e8940b9dd2 2045212 net optional pidgin_2.0.2-1_amd64.deb
 c79e8a50cd159067f94c87f3ddd3b577 4515298 net extra pidgin-dbg_2.0.2-1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGln2bwO+u47cOQDsRA4tyAJ9Svusd6oeFcBXc/cn8vvvTys6L3ACfVZ1O
w2wV/CMi+oa425bYFoTtQ6U=
=Y35y
-----END PGP SIGNATURE-----

Changed in gaim:
status: New → Fix Released

reassigning to pidgin.

It looks as if the dependent bugs are fixed in debian at least can silc be turned on in the compile yet? I guess this would mean turning it on in the build dependencies?

Sebastien Bacher (seb128) wrote :

silc would need to be promoted to main to build pidgin with it

# A New Hope
# A log time ago, in a galaxy far, far away
# something happened.
#
# Magically this resulted in the following
# action being taken, but this fake control
# message doesn't tell you why it happened
#
# The action:
# Bug archived.
thanks
# This fakemail brought to you by your local debbugs
# administrator

and what about splitting silc protocol plugin to a new universe-component package?

Sebastien Bacher (seb128) wrote :

You are welcome to join the MOTU team and work on that

I have no time to spend joining any working group, so I attach some changes that when applied to pidgin, should give pidgin-silc universe source package.

Cheers,

and add DEB_DESTDIR = $(DEB_SRCDIR)/debian/tmp to debian/rules.

splitting in a cleaner way; copy libpurple/protocols/silc/* and compile against pidgin-dev. I need also internal.h missed in libpurple-dev/pidgin-dev

cheers

Richard Laager (rlaager) wrote :

Copying files out of the Pidgin tarball is not cleaner. It requires that on every upgrade, someone copy a tree of files. Additionally, as you can see, internal stuff uses internal.h, which doesn't belong in libpurple-dev.

If I was to want to split this (which I think is a terrible idea compared to just building pidgin with SILC support in main), I would take the pristine upstream tarball and use that as the base of a pidgin-silc source package. You should configure with --disable-gtk --disable-consoleui. This should build just libpurple. (I haven't tested it, but if it doesn't, we can fix that upstream.) Then, instead of calling "make install" from your package's install target, you'd install just the single .so of the SILC prpl from debian/rules. Also, you'll want the pidgin-silc binary package to depend on libpurple >= ${source:Version}. This is more specific than you probably need (as you really only care about the major and minor, not the micro), but it's easier than rigging up some sort of script to create a substvar that's not really needed in practice.

This way, you'd get the results you want without needing to complicate future package maintenance. You'd just need to grab a new Pidgin tarball and rebuild the package.

agent 8131 (agent-8131) wrote :

I want to agree that splitting is a bad idea compared to just building in SILC support as is done in Debian now. I also want to note that the only thing required to fix this bug is to add the libsilc dev package to the build-deps and libsilc to the package dependencies. That's all that's been needed for at least the last couple of releases (edgy, feisty, gutsy). It's such a simple solution and would make the lives of all of us using silc so much easier that I would really like to see it happen before the next release. I'd also like to note that the pidgin and finch packages (in gutsy) both claim to have silc support when, in fact, they do not.

Also, if anyone comes across this thread wanting to enable silc support in pidgin or finch in gutsy here's how to do it:

http://ubuntumagnet.com/2007/10/enabling-silc-support-pidgin-under-ubuntu-7-10-gutsy-gibbon

Isaac Dupree (idupree) wrote :

I applied the technique on the above-mentioned page to compile with SILC support, however, it has the permissions problem described here

http://carnal0wnage.blogspot.com/2007/08/getting-silc-plugin-to-work-with-pidgin.html

"Cannot create SILC key pair"

Isaac Dupree (idupree) wrote :

running pigdin from command-line, I get

Could not create public key identifier: Success
Could not create public key identifier: Success

.

sudo pidgin works to create keys...

this seems to be a silc-toolkit problem?

Isaac Dupree (idupree) wrote :

argh,why do I need to make a new bulky post every time I forget to mention sometime? these are the successful messages from `sudo pidgin`

Public key has been saved into `/root/.silc/public_key.pub'.
Private key has been saved into `/root/.silc/private_key.prv'.

I'm on Gutsy x86 edition

agent 8131 (agent-8131) wrote :

*sigh*

This is still broken in Hardy beta. Come on, this is a 1 minute fix, why should this bug report be 2 years old and still not fixed? Anyway, nothing left to say except what has already been said:

The only thing required to fix this bug is to add the libsilc dev package to the build-deps and libsilc to the package dependencies. That's all that's been needed for at least the last couple of releases (edgy, feisty, gutsy, *hardy*). It's such a simple solution and would make the lives of all of us using silc so much easier that I would really like to see it happen before the next release. I'd also like to note that the pidgin and finch packages (in gutsy) both claim to have silc support when, in fact, they do not.

Richard Laager (rlaager) wrote :

That's not all that is needed. The big hang-up here is and always has been getting libsilc into Ubuntu main. I'm not sure what's holding that up, though.

agent 8131 (agent-8131) wrote :

I see. I had not realized the obvious that every package in main must depend only on other packages in main.

I read the the Main Inclusion Process (https://wiki.ubuntu.com/MainInclusionProcess) and submitted a Main Inclusion Report for silc-toolkit:

https://bugs.launchpad.net/ubuntu/+source/silc-toolkit/+bug/211179

Please see the MainInclusionReport here:
https://wiki.ubuntu.com/MainInclusionReportSilc-toolkit

Although it hasn't been accepted for about a year and a half.

8.04 has arrived and I don't see SILC support in pidgin-2.4.1-1ubuntu2

What more do we need to do/who do we need to talk to to get silc-toolkit included in main?

agent 8131 (agent-8131) wrote :

As it appears silc-toolkit is going into main (https://bugs.launchpad.net/ubuntu/+source/silc-toolkit/+bug/211179), I believe all that needs to happen now is:

1) libsilc-1.1-2-dev (or whichever version is in 8.10) to be added as a build-dep to the pidgin source package
2) libsilc-1.1-2 (or whichever version is in 8.10) to be added as a dependency to the libpurpl0 package

With those 2 changes SILC support in Pidgin should "just work" which I think is what everyone would like to see.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pidgin - 1:2.4.3-0ubuntu1

---------------
pidgin (1:2.4.3-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - can connect to the icq server (lp: #244591)
  * debian/control,
    debian/rules:
    - build-depends on libsilc which is in main now (lp: #44728)
  * debian/patches/16_yahoo_icon_crash.patch:
    - updated, some of the changes are in the new version

 -- Sebastien Bacher <email address hidden> Wed, 02 Jul 2008 11:20:18 +0200

Changed in pidgin:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.