Please upgrade to Pidgin 2.5.7

Bug #390249 reported by Hew on 2009-06-21
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Jaunty Jackalope Backports
Undecided
Unassigned
pidgin (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: pidgin

Please upgrade to Pidgin 2.5.7, which contains a number of important bugfixes.

* Yahoo Protocol 16 support, including new HTTPS login method; this should fix a number of login problems that have recently cropped up. (Sulabh Mahajan, Mike "Maiku" Ruprecht)
* Only display the AIM "Unable to Retrieve Buddy List" message once per connection. (Rob Taft)
* Blocking MSN users not on your buddy list no longer disconnects you.
* When performing operations on MSN, assume users are on the MSN/Passport network if we don't get network ID's for them.

Closed tickets: http://developer.pidgin.im/query?status=closed&milestone=2.5.7
Source: http://downloads.sourceforge.net/pidgin/pidgin-2.5.7.tar.bz2

Related branches

Hew (hew) on 2009-06-21
Changed in pidgin (Ubuntu):
importance: Undecided → Wishlist
Iain Lane (laney) on 2009-06-22
tags: added: desktop-upgrade
Changed in pidgin (Ubuntu):
assignee: nobody → Iain Lane (laney)
status: New → In Progress
Iain Lane (laney) wrote :

pidgin (1:2.5.7-1ubuntu1) karmic; urgency=low

  * Merge with Debian unstable (LP: #390249, #390297), remaining changes:
    - Update debian/prefs.xml to set the notify plugin prefs
      /plugins/gtk/X11/notify/*, set /pidgin/plugins/loaded to load
      the notify plugin and enable the standard logging options by default
    + 02_lpi.patch for LP integration. Add liblaunchpad-integration-dev to
      build-deps for this
    + 04_let_crasher_for_apport.patch to stop catching the SIGSEGV signal
      and let apport handle it
    + 05_default_to_irc_ubuntu_com.patch to set the default IRC
      server to irc.ubuntu.com
    + 10_docklet_default_off.patch for default behavior to have no
      notification area icon.
    + 11_buddy_list_really_show.patch to make it so that the buddy
      list tries harder to appear. This fixes some issues with it
      not appearing.
    + 13_sounds_and_timers.patch which adjusts the time out for sounds
      to be 15 seconds, which helps get fewer spurious login
      notifications on slow connections. Also, switches a few long
      term timers to _add_seconds to get a little bit of power savings.
    + 60_1024x600_gtk*.c.patch: Add scrolled bars into account dialog,
    + 73_upstream_change_fix_high_dpi_status_msg.patch: upstream change to
      stop the clipping of the infopane text when using high DPI
      pounce windows and preference window when screen height is less than 600.
    + Add nm-dev to build-deps to enable NM integration. Remove --disable-nm
      from configure line.
    + debian/libpurple0.symbols: Add libgdl & epochs
    + debian/control: Remove libpurple0 from deps of libpurple-bin
  * Also fixes Yahoo! connection problems (LP: #389322)
  * debian/libpurple0.symbols: Update
  * 99_autoconf: Refresh

 -- Iain Lane <email address hidden> Mon, 22 Jun 2009 17:14:29 +0100

Changed in pidgin (Ubuntu):
assignee: Iain Lane (laney) → nobody
status: In Progress → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pidgin - 1:2.5.7-1ubuntu1

---------------
pidgin (1:2.5.7-1ubuntu1) karmic; urgency=low

  * Merge with Debian unstable (LP: #390249, #390297), remaining changes:
    - Update debian/prefs.xml to set the notify plugin prefs
      /plugins/gtk/X11/notify/*, set /pidgin/plugins/loaded to load
      the notify plugin and enable the standard logging options by default
    + 02_lpi.patch for LP integration. Add liblaunchpad-integration-dev to
      build-deps for this
    + 04_let_crasher_for_apport.patch to stop catching the SIGSEGV signal
      and let apport handle it
    + 05_default_to_irc_ubuntu_com.patch to set the default IRC
      server to irc.ubuntu.com
    + 10_docklet_default_off.patch for default behavior to have no
      notification area icon.
    + 11_buddy_list_really_show.patch to make it so that the buddy
      list tries harder to appear. This fixes some issues with it
      not appearing.
    + 13_sounds_and_timers.patch which adjusts the time out for sounds
      to be 15 seconds, which helps get fewer spurious login
      notifications on slow connections. Also, switches a few long
      term timers to _add_seconds to get a little bit of power savings.
    + 60_1024x600_gtk*.c.patch: Add scrolled bars into account dialog,
    + 73_upstream_change_fix_high_dpi_status_msg.patch: upstream change to
      stop the clipping of the infopane text when using high DPI
      pounce windows and preference window when screen height is less than 600.
    + Add nm-dev to build-deps to enable NM integration. Remove --disable-nm
      from configure line.
    + debian/libpurple0.symbols: Add libgdl & epochs
    + debian/control: Remove libpurple0 from deps of libpurple-bin
  * Also fixes Yahoo! connection problems (LP: #389322)
  * debian/libpurple0.symbols: Update
  * 99_autoconf: Refresh

 -- Iain Lane <email address hidden> Mon, 22 Jun 2009 17:14:29 +0100

Changed in pidgin (Ubuntu):
status: Triaged → Fix Released
Sebastien Bacher (seb128) wrote :

thank you for your work there

Damiano Dallatana (damidalla) wrote :

Is it going to be uploaded as jaunty-updates or, at least, jaunty-backports?

Marking as affecting jaunty-backports.

Damiano Dallatana (damidalla) wrote :

The temporary workaround for Yahoo! connection does not work anymore (as reported on bug 389322), so the fix is now critical as that bug means a big loss of functionality for Pidgin on Ubuntu < 9.10.
Could it be updated on 9.04 (and 8.04, it's an LTS...)?

Tony Manco (trmanco) wrote :

Yes I can also confirm this, no more temporary workarounds for anybody.

Noel J. Bergman (noeljb) wrote :

Please note that there is a PPA for pidgin, which has Hardy, Intrepid, Jaunty and Karmic builds.

See https://launchpad.net/~pidgin-developers/+archive/ppa

I installed 2.5.7 from the PPA, and that resolved the Yahoo! problem for me.

Damiano Dallatana (damidalla) wrote :

Thank you Noel for the instructions. I am in fact using it.
The presence of an updated package in the developers' PPA should not be a pretext not to release an update or, at least, a backport. There are a lor of Yahoo! users using Ubuntu who are not going to add a PPA - they do not want to, or they are not able to.
It is a regression, it should be fixed.

Hew (hew) on 2010-03-05
Changed in jaunty-backports:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers