Ubuntu

Automatic install of 2.5.6 leaves libpurple at 2.5.5

Reported by R. Drew Davis on 2009-06-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pidgin

I'd previously installed from source pidgin 2.5.5 in /usr/local. Now that 2.5.6 can be installed automatically on ubuntu, I updated /etc/apt/sources.list.d per the web page instrucions and upgraded to 2.5.6 using update manager. "About" said I was now running 2.5.6 but from time to time pidgin would suggest that I upgrade to 2.5.6. Looking closer, I was still running libpurple 2.5.5. I tried to use synaptic to completely uninstall and reinstall pidgin and libpurple, but I still had libpurple 2.5.5. Only thing that seemed to work for me was to go back to the 2.5.5 source and as root, make uninstall.
Now it says Im at 2.5.6 with libpurple 2.5.6.

Drew

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/pidgin
Package: pidgin 1:2.5.6-1ubuntu1~pidgin5.8.10
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/opt/real/RealPlayer
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pidgin
Uname: Linux 2.6.27-14-generic i686
UnreportableReason: This is not a genuine Ubuntu package

R. Drew Davis (drewclist) wrote :
R. Drew Davis (drewclist) wrote :

Strangely, after a few days of all seeming well, pidgin crashed and wouldn't restart. Looking at debugging messages, I found that it somehow had discovered the 2.5.4 libraries were still in /usr/local. (it was the 2.5.5 ones that were previously removed to fix the previous problem with trying 2.5.6. I'd somehow overlooked the presence of the still older 2.5.4 libraries). I found I still had that source version around, so I tried as root, "make uninstall". It didn't work, but rather than try to debug why, I just used rm to rip the old version out of /usr/local. pidgin resumed working after that. I'm mystified how things could have been OK for a while and then the older library suddenly was noticed?? Bottom line is that with default library search paths in Ubuntu Intrepid, it evidently is real important to purge away all older versions of the purple libraries from /usr/local before plugging into the new repository for automatic pidgin updates. The install instructions should warn about this. If pidgin in [/usr/bin, /usr/lib] can't be happy coexisting with a different version in [/usr/local/bin, /usr/local/lib], then maybe the install scripts should watch out for that situation and rip the incompatible version out of /usr/local/lib before it causes trouble.

R. Drew Davis (drewclist) wrote :

The page with the instructions for putting updates of pidgin on auto-pilot is http://pidgin.im/download/ubuntu/ - The referenced repositories aren't official Canonical repositories. Does that imply this bug report needs to be lodged into some other bug tracking system than this one?

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Do you get the same with Lucid or Maverick? Thanks in advance.

Changed in pidgin (Ubuntu):
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in pidgin (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers